Setting up RME Babyface Pro

#1

Following recommendations on this forum, I just bought a Babyface Pro. A very nice unit, but I can’t get it going properly. I’m using both the earphones and the XLR outputs. At the moment, my sounds are all ring modulated and distorted. Can someone help me with easy instructions for setup? All I want is sound processing and that’s all. Any advice will be much appreciated.

#2

Did you install the latest Drivers?
What are your samplerate and buffer settings?

#3

Yes, I installed the latest drivers. I’ve experimented with all different sample rates but nothing changes. It continues to put out a distorted ring modulated sound. I’m beginning to suspect I may have a faulty unit. Is there a factory reset for the device? There’s no mention of it on the net. I’ve also made sure it was on the PC rather than CC mode. Others have reported faulty units. A factory reset would be good if it exists.

#4

Maybe this forum helps:

https://www.forum.rme-audio.de/viewtopic.php?id=22180

Re: strange Babyface problem (scrambled, distorted output and input sound)

The Babyface needs TotalMix after the start to get its settings.

best regards
Knut

Re: strange Babyface problem (scrambled, distorted output and input sound)

You have a USB performance problem that has nothing to do with this old Mac OS related thread. The BF Pro manual tells you how to check USB on a Windows computer.

#5

Keep your sampling rate at 44.1kHz and a buffer size at 512 to start (256 when everything works). I don’t know why, but it is sometimes necessary to restart GP after changing the sampling rate and buffer setting, so changing these parameters all the time, is not the best thing you can do.

You can also have a look here to check if it comes from a PC performance problem: DPC latency check

#6

If you’re playing with different sampling rates, etc, it can be useful to hold the SHIFT key down while starting GP to prevent it from loading rackspaces. That way, you can change the audio stuff really quickly.

1 Like
#7

Thank you for the tip.:+1:

#8

YEP! shift key down :wink:

Lots more tips here:
https://community.gigperformer.com/c/using-gig-performer-tips-and-tricks

#9

I’ve decided to send it back and let the supplier check it out.

#10

I’ve done a bit more fiddling around. My present interface is a NI Traktor Audio 2 MK 2 and it runs happily at 44.1 with 64 samples. So I set the Babyface to the same but it still distorts badly. Like a fuzz box on full. It seems the output from GP via the USB input is overloading. Is there a setting in GP to turn down the output level without losing volume? I’ve also been looking at the TotalMix software mixe that gets installed at the same time. But it’s a dreadful looking piece of software very hard to figure out. TotalMix seems to be letting a hot signal through but I can’t figure out where to change settings to lower this. Any further help out there?

#11

Change the sample buffer size to 256

#12

You are asking for any further help, but I am not sure you made some benefit of the previous advices. It really doesn’t make sense to go below a buffer size of 256 @44kHz. Don’t further fiddle, keep this settings. Your problem is somewhere else… perhaps in fiddling?.. :grimacing:

I have really nothing against the NI Traktor Audio 2 MK 2, and I am even thinking of buying one for preparing gigs when traveling in the train. But comparing the NI Traktor Audio 2 MK 2 driver with TotalMix is like comparing a game pad with a fighter jet cockpit. I can understand that it can be difficult for you to take off with TotalMix because it is very very similar to a professional digital mixer and light years away from a DJ mixer. So take the time to discover and learn the concepts behind TotalMix, there are many advantages to be gained. :wink:

1 Like
#13

I totally agree :+1:

1 Like
#14

Thanks for the help so far. I’ve set the Babyface Pro to 256 samples and will leave it there. One thing I haven’t mentioned is that I’m using a USB 3 hub (Trond Super Slim USB Hub 3.0 with Swiveling Connector 4 Port Compact, Bus-Powered, Silver). As my Surface Pro 6 has only one USB port, I have no choice as I’m using a wireless guitar controller. I also tried a second hub I have, but no improvement. Could the hub be the cause of the distortion? I have also tried a replacement USB cable but the Baby Pro wouldn’t even light up with that. Finally, I uninstalled the driver package and then plugged the BP in without drivers. The distortion was gone with clear clean sound coming out. Not sure what all this means, but if the BP cannot run from a hub, then I guess I’ll just have to return it.

#15

Touch base with RME customer support. I’m sure you’re not the first person with a single USB port who needs to run multiple devices. It may be that you need to use a specific kind of hub

#16

Thanks, I will.

#17

Have you tried using a powered USB hub?

#18

No, I haven’t got one to try out. I have a query out to RME asking for their info on the use of hubs.

#19

I sent this back to the supplier who tell me there is nothing wrong with the unit. What did I do wrong, and why wouldn’t it work for me?

#20

My guess is that the USB port in the Surface Pro can’t supply enough power to all attached USB devices, causing the RME Babyface Pro to malfunction. As I mentioned before, please try using a powered USB hub to insure that all your USB devices get enough power. They’re inexpensive.