Plugins popping and dropping

I’m getting popping noises at fairly high latency. The worst offending plugins include Roland’s Zenology and D-50, both of which get worse when I open the plugins themselves.

I’ve assembled a dedicated system for this rig, which includes a Geekom mini PC with a 13 gen. i9 chip, 32GB RAM and 2TB SSD running Windows 11. This machine is blistering fast.

My audio interface is a gen 3 Focusrite Scarlette 4i4 running the latest drivers and connected to the PC directly by USB C (no hubs or other stuff in between).

I have run through the “Optimizing Your PC For Music Production” provided by the amazing people of GP. I’ve done nearly everything in the guide - I swerved around some of the cores editing stuff because it was unfamiliar to me. Power management, bloatware, crud that runs in the background have all been addressed - including Windows Defender. I don’t even have basic windows apps installed - only Google Chrome for downloading stuff.

I’ve settled into 44.1/320 on my audio settings and this mostly addresses the popping issues/dropouts, but feels far more drastic than I should need and adds some annoying latency - especially on pianos.

Last, I’ll add that my GP CPU usage with these Roland apps is just 3-4%, which feels like there should be plenty of CPU gas in the tank for lower latency.

I could sure use some help fixing this - thanks in advance GP friends!

There was a recent thread here with someone having issues with their Zenology plugins.
You can have a read here:

Hi @Zipdog - one thing you could look into is temporarily downgrading the PCIE bus speed in the BIOS. I had a new PC build which suffered intermittent crackles and pops, despite being a beast with great latencyMon figures - and changing the buffer settings did nothing to fix the issue. Turned out the higher clock speeds were causing interference and changing the settings to a lower Generation fixed things completely.

Just an idea if your experiencing random crackles and pops, despite good specs. Happy to give more details if needed

1 Like

A photo or screenshot would be useful :slight_smile:

1 Like

The settings would probably be different for other motherboards, but photo below is where they were for my PC

I changed the 4 settings shown as either ‘Gen3’ or ‘Gen4’ - they were previously set to ‘AUTO’ - to one lower than the maximum option available.

It may be only one of these needed changing, but I haven’t investigated any further to narrow it down - it took a lot of hair pulling to find out this was the issue so I was just happy I could use the PC for music making, and it seems plenty fast enough.

The thing that threw me was I always associate the crackles and pops I was hearing with latency issues, yet increasing buffer settings made no difference, and the latency was fine in LatencyMon - that eventually led me to these settings.

Motherboard is ASRock B650M PG Riptide. Processor is AMD Ryzen 9 7900 with heaps of RAM, running Win 11


Useful info! :beers:

Thank you both! I’ll get into the Bios tonight after work and share a pic. I had read elsewhere about trying a downgrade.

Meanwhile, this is the latency result from a short scan yesterday.

I have found that when troubleshooting things like this it’s best to isolate the VST from GP to see where the inherent problem is.

If you download and use this, you can run your VST on it’s own without hosting it in GP. If your problems still persist…you know where the issue is.

Ok fellas, I’m in the deep end of the pool here. I’ve found my way into the Bios and the pics attached show what I see. Nothing that aligns with what @Matt shows. Please can you help direct me? Many thanks!!

Well, I’ve tried a few more things, but no progress. If anything the popping is worse at 44.1/320 than previously. So frustrated.

Since last post (apologies for the dup pics), I’ve dug back into the Bios and haven’t found any settings or options like are shown in @Matt ‘s pic, so I’m stuck there. I have confirmed CPU is running at 100% always and power is set to “high performance” this was a rollback from “ultimate performance”…just to see. I uninstalled Realtek and disabled other audio options that aren’t directly Focustite-associated (screen pic in next post). Made sure I had latest Focusrite ASIO drivers installed.

There HAS to be a fix, but feeling pretty defeated after a couple of weeks in this fight. Desperate for more ideas or suggestions. TIA!

1 Like

I’ve seen this on the desktop of my son, but that (the desktop I mean) has an AMD cpu.

Is the behavior you’re experiencing only with this plugin, or are plugins from other brands suffering from the same issue?

I guess I have to understand this like ‘Full Speed’, not lowered to 1.8 GHz or something like that? ('Cause when it is always 100% busy, GP wouldn’t have room to run)

1 Like

@Frank1119 thanks for reaching out. When I referenced that CPU setting, it was here.

In Gig Performer, the CPU usage is low single digits, so I think I’m ok there?

1 Like

That’s fine :+1:

It’s most notable on Roland D50 and Zenology, but getting it to a lesser degree with others (Pianoteq, for example)

And in GP the cpu monitor is really low?


(Because the cpu usage in the task manager is not good for measurement when it comes to the audio thread)

@Frank1119 yes. GP CPU meter sits between 3-6% even with as many as 3 plugins stacked.

Are these plugins using samples. If yes, are this located on fast storage (not on a network disk or a sd-card). This is a long shot, because sampled plugins will most like cache a lot in memory, so there might be crackling when a sample is loaded (although that’s not preferable), but after that not anymore. And I admit crackling is not popping and dropping.

Have you tried to connect the focusrite to a different usb port instead of a ‘genuine’ USB-C. Just a ‘normal’ USB-A port. There’s nothing to gain by using a usb-c port for a focusrite 4i4 3rd gen. (I have this myself). BTW: What is the driver version?


Hi @Frank1119
Yes, I got a little too cute with my “dropping and popping” thread title - you’re right - it’s really crackling.

I believe Roland Zenology is sample based, not so sure about the D-50. They’re both stored locally on a 2TB SSD, so plenty of speed and space there.

On the Focusrite, I’m using the USB-C out into a USB A 2.0 port on my mini PC using the short cable that came from Focusrite. I do have 3.0 USB ports available if you think that’s worth a go.

Last, my Focusrite is firmware 1605, driver 4.119.13 so maybe a bit newer than yours(?). Someone had suggested trying to roll back to a previous driver. I’m up for that, assuming it can be had from Focusrite’s site.

Thanks so much!!