MIDI change memory

Hi there,

Im trying Gig Performer and thinking to switch from Mainstage… but so far there’s a thing that I cant make work.

When I switch between racks it doesn’t remember the previous status in the midi controller (I’m using a nectar pacer - set to receive msg)

Ex. I activate lets suppose, delay and drive and my leds in pacer are activated, so I change the rack… when I come back it doesn’t show the previous set - the leds doesn’t change back to the previous status (this works wonderful In Mainstage)

Am I doing something wrong or its not possible to do that?
This is a total deal breaker for me.

Thank you,

Hi @maupo, welcom to the GP community.

I would be sad that something working on MS would’nt on GP, but I don’t know the Nektar Pacer very well. You will probably have answer from other users, but in the meantime, I would like to check something with you.

Do you have the Nektar Pacer switches set to momentary? (press a pedal CC# 127 is sent, release it CC# 0 is sent). With a Nektar Pacer switch set to momentary, you can have a GP switch widget set to Momentary to Latching and activate the MIDI SYNC (see widget properties, MIDI tab). Would that work for you?

1 Like

there is this nektar-pacer-discussion…

It is possible to sync things up correctly when you change rackspaces.

The only thing in GP is to select the ‘Sync’ button in the widget settings (Midi tab) and the ‘Momentary to Latching’ tick box. Everything else needs to be setup on the Pacer.

Do you program the pacer directly on the unit, or using the web tool?

It may be that the Pacer expects special messages to switch banks and/or the Nektar people provided a “driver” for MainStage. If anyone can find out what the messages are, it would probably be trivial to send them out through GP Script or through the “Extra messages” in a song part section

Thats exactly my problem.

Pity… I liked GP, but its a dealbreaker for me… gonna keep using MS.

Thank you all!

I think you are giving up a bit early, I am sure there is a solution for you.

1 Like

@maupo it does work. The Pacer has a special setting for ‘LED MIDI’ that needs to be activated in order for things to be correctly in sync. You need the footswitches to be “CC Trigger” and the “LED MIDI” to be “1”.

Pacer Setting (web editor):

GP Widget Setting:


I think you should not give up, there is sure a solution.

The pacer is correct configured. Toggle and led midi activated (Thats why it works in MS)
I set in GP to sync and check momentary… there’s no way to remember the previous status…
This is what happens:

Rack 1 - Activate drive and delay for example - pacer receives the msg and turn the leds on
Change to Rack 2 - Leds are still on but I have to step the stomp 2 times to update the status for the Rack 2 that’s was OFF.
Change back to Rack 1 - it shows the status left in Rack2 - have to step twice to update again. (Have to step twice in each stomp to update)

Everything is correct in pacer (and so far in GP - according to your advice)

I not giving up earlier… the thing is, my evaluation period is in the end, and I will not buy unless I can make it works, I think that makes sense, no?

Thank you guys! I appreciate the help!

When you switch the widgets in GP does pacer react?

Do you have a MIDI synced widget mapped to each of your Pacer switches in both rack 1 and rack 2? The idea is that the state of widget has to be recalled properly and update the Pacer LEDs accordingly. The Pacer is not supposed to recall any internal state.

I am not what you mean with toggle as I don’t own a Pacer. But, as a keyboardist I have a controll surface that I use to control a software mixer using GP. The control surface doesn’t “remember” the state of its buttons, it only send a CC# 127 when pushed and a CC# 0 when released. It is the GP widget which “remembers” the state and set the LED accordingly.

1 Like

How did you set your widgets?
Did you check “Ignore Variations”?

When you use a MIDI sniffer like the app “MIDI Monitor” what messages are sent back from Gig Performer?

Can you upload you example gig, so we could take a look at it?

How does the MIDI Assignment Window look like?

Thank you…

Well… I tried all the advices so far… its a very simple setup (as I’m just trying)

In the video you can see the problem… (red led -ON blue led OFF) out of sync when I change racks

OK, I see that the widgets react when the pacer switches are pressed.
What happens when you press a widget?

Can you please upload the gig file?

Do you use the Rig Manager?

When I use the screen the led respond… on off… but changing the rack, all the same. I even created a new profile in pacer from scratch and at this time when I change de rack it get wired… if ON when I change the 2 rack show as on when I come back to rack 1 all the leds show as OFF, and when I go back to 2 again, all leds show ON (only leds, widgets keep the status)

I don’t use Rig Manager (actually don’t know what it is… my version is the trial) Rackspace_1(2).rackspace (19.0 KB)

OK, I think I understand

Your Pacer sends CC 11 with value 127 when pressed and LED goes On
Then it again sends CC 11 with value 127 when pressed again and LED goes Off

Is that right?

Therefore you set “Momentary to latching” ?

What happens when you uncheck this option?

I tried the rackspace and connected the switches with the buttons of my X-Touch Mini.
The buttons on my controller are set to “latching”, and when i untick the “momentary to latching” option on the widgets, everything runs smooth.
Just to clarify: You said that the pedals on your Pacer are set as “toggle”… i expect this means:
Press pedal and release it → Pedal stays ON
Press & release again Pedal goes OFF
Is this right?

So if your pedals are already set as “latching” (which would mean “toggle”) then you should not have set the widgets as “momentary to latching” too, because the “latching” already happens in your pedal.
In that case you always would have to press&release the pedals twice to change the state of the widget.
Maybe this is what happens here?

I tried all the option:

  • in pacer set to trigger and check the momentary in GP (the issue that I describe - as in the video)
  • in pacer set to trigger and uncheck momentary in GP (stomp doesn’t “hold” - well, as expected and leds dont go back to the previous status)
  • in pacer set to toggle and check the momentary in GP - the same
  • in pacer set to toggle and uncheck momentary in GP - leds change but totally wrongly. ex: from
    rack 1 ON ON ON ON
    rack 2 OFF OFF OFF OFF (without stepping any stomp)

back to rack 1: OFF OFF OFF OFF
back rack 2 again ON. ON. ON. ON (without stepping, just change the rack)

gets even wired if I do like:

back to 1: OFF ON ON OFF
back to 2: ON ON ON ON
back to 1 again: OFF OFF OFF OFF

Jeez… dont know what else to try…

Is there an option in pacer that the led should not be controlled by the switch itself but by incoming MIDI?