Major glitching issues

Hi guys,
As the tech for a Pink Floyd tribute band, we adopted GP fairly early on and have been using it for some years with few problems. However, we decided to invest in a better laptop and interface, along with upgrading to GP4. We use a number of VST’s, but mainly Arturia Collection 7, IK B3X and Amplitube, NI Kontakt and a few other assorted oddments.

The laptop is an HP 250 G8, Intel Core i5-1035G1, 64gb RAM and 500GB SSD running Windows 10
The interface is a Focusrite 2i2

The problem we are having is audio glitching. We did initially have a lot of high CPU usage, but after a reinstall, CPU is now never more than 50%. I reduced the ASIO sample rate from 48Khz to 44.1Khz, and pushed the latency right back to 20ms, which helped, but it’s still there and with such latency means it’s almost unplayable.

We have tried numerous interfaces, including 2x Focusrite 2i2’s, a 4i4, a Behringer X18 mixer and an SSL Studio 26c, none of which have helped.

Firstly, I would like to know if anybody has any ideas regarding what might be causing this, and secondly, what people are using that works clean and reliably.

I have stripped Windows of any superfluous services, and CPU is low. Even running single rackspaces can cause it. The effect leads me to believe this is some kind of latency issue, but myself and our keyboard player are at our wits end trying to figure it out. Failing this all I can think of doing is getting another computer, which will be expensive, and we have gigs coming up soon.

Many thanks for any suggestions you may have,

Any chance you have an anti-virus program on the machines? Those things can play havoc with real-time applications.
Often, even just turning them off doesn’t help, they have to be completely removed.

Does this happen if you just run a single plugin? It’s also possible that you’ve introduced something else into the machine that is now impacting stuff.

What is the Audio Buffer size you are using? At 20ms it must be pretty high.
Have you run LatencyMon?

Was just seeing that your Intel Core i5-1035G1 has a base clock of around 1.2 Ghz. That processor may not be good enough for what you’re trying to achieve, at least not without some overclocking.
The ‘G’ type Intel processors have good graphics processing, but for audio I’ve found the ‘HQ’ type to be what I need. You can read about processor types here.


And IK B-3X needs a lot of cpu

What is your buffer size? Also, use the free application LatencyMon to see if there is another driver interfering. I use a Scarlet 2i2, 44100, and 128 buffer size.

Yes, that base clock of 1.2Ghz may not be enough.
But also, what drivers are you using?

Don’t go under 3GHz of base frequency.

1 Like

Yes, I know. It’s a bit of a hog.

The only AV is the built in Windows one.
And yes, even with one plugin it can still play up.

I haven’t got the machine to hand, but I have tried it at most buffer sizes and it makes little difference.
My concern is CPU load is <50%, so I can’t see this being a CPU issue.

The latest Focusrite drivers.

The problem is not purely the CPU power, but the fact that we are trying to get a real time behavior out of a non real time OS. Here good results are only obtained thanks to the responsiveness of the CPU. I never had success under 3GHz… I only shared my own experience…

1 Like

I am under the impression from the specs here that this is a 3.6Ghz processor.
Or have I got that wrong?

Thanks. Well I have discovered this particular CPU is rated at 1Ghz, but has a Turbo boost of up to 3.6Ghz. I need to check a) whether it is enabled in the BIOS and b) whether it makes any difference.
Also, can I ask, if you use a laptop, what is it? I’m not very up on hardware and if I need to buy another I don’t want to get another lemon.

Yes, see the point [4] here: FREE e-book by Deskew - Optimize your Windows PC for the stage!

A little bit of A/B testing and experimenting is necessary.

Only the lower frequency mainly matters, unfortunately. 1GHz is really too low in my opinion…

You might try QuickCPU.
You can set up a custom profile that allows you to raise the base frequency, and control the range it operates in. What you don’t want is Turbo kicking in and out—that in itself will cause audible pops. You can however use the range that Turbo operates in and keep it there, You want to find the balance where your CPU is operating at an elevated Ghz range without overheating. It takes a little experimentation, but you will find improve performance.
Will it be enough for what you’re wanting to achieve? I don’t know. It’s worth a shot, before you go scrap that laptop and buy something else.

1 Like

The irony is that on my Mac, I’m using TurboBoost to prevent my Mac from going too fast and get too hot. So far it has had no impact on Gig Performer (three weeks with 12 shows with no issues a few weeks ago)

@dhj Clearly your machine has some room to spare in the processing dept. and isn’t prone to spike when the turbo comes on. In lesser machines, what can happen is a sudden demand for processing(a CPU hog plugin, for example) comes in coupled with a turbo increase in processing power and a subsequent increase in fan usage and causes some pops and cracks. You want a machine that operates at a static frequency, with a static fan speed—and then to push the limits as defined by those two rules. No jolts or bumps.

My problem here is I can’t seem to find any way of managing the Turbo function, or even disabling it in the BIOS. And this laptop has no fans or vents, it’s a very minimalist thing.