Issue with rackspace change

Hello there. I am getting a short increase in loudness when switching rackspaces and playing guitar at the same time. It seems like the sound will be doubled for a short time. Own GP4 and with GP3 it is the same. Thanks.

How does your rackspaces look?
Do you you Patch persist ?

I tried it with a distorted amp. Same setting on the other rackspace only delay on. This was only to try what is the problem. The signal seems to to louder a few milliseconds when switching rackspaces.

Are you using the global rackspace?

No. It is only an amp sim on regular rackspace.

Can you upload a short gig to show the issue?

What do you mean with gig? The file?

Ooops sorry, yes the gig Gile :wink:

Not at the moment. But it is only input - amp sim - output. Nothing else. Same setup on both rackspaces.

And the volume in the rackspaces is the same, only when you switch you get a short amount of time a higher volume?

Yes it increases and after a very short time it is normal again. Like the two rackspaces are on at the same time.

How is you setting of input muting and output fading.
When you lower down Output Fading, does it influence anything?

Yep exactly like on the picture. Did not try to decrease the tails because I like to get it. Have to try it.

I built a test case and when I switch fast between the rackspaces I can clearly hear the changes in volume as you describe.

1 Like

This is absolutely normal. For about 2.5 seconds both rackspaces will play. The one that you just left will mute within that tail length time, but for a short period, of course, both rackspaces will play which will increase the loudness.

This depends heavily on what kind of rackspaces you have and if you are playing through as you are switching. Try reducing the tail length to a minimum and see if that helps. See how you like it if you set it to zero…

1 Like

@djogon I’ve noted the same behavior. I’m somewhat speaking beyond my expertise, but it seems as if the audio is summing vice mixing. Is it possible to have the mix or somehow control for volume? It’s nice to have the output trail when switching rackspaces to let reverb/delay trail out.

1 Like

Thanks. I will test it. But I would like to have trails for example with delay.

In my test case is set the tail length to zero and can clearly hear the jump in volume when I switch the rackspaces.

I haven’t upgraded to 4 yet and I know the devs included the tail length settings now. But it seems you’re still having this issue. Here’s a similar thread I started a few months ago about this exact thing:

Just add a bit of code on each rackspace, making sure the input is deactivated when switching to another rackspace. This way you’ll get the nice delay trail, but without doubling the inputs.


Create a Gain Balance Control as the first block in your wire setup. Give it a GPScript handle “GainBalance” and enable Use in GPScript. Open the script editor (ctrl+shift+2) and paste the following code and hit Compile:

   GainBalance : PluginBlock

On Activate
   SetParameter(GainBalance, 4, 0)

On Deactivate
   SetParameter(GainBalance, 4, 1)

Do this for all your guitar rackspaces. Never worry about volume doubling again!

1 Like

In v3 of GP you could not get the input to mute instantly and you did not have any control over it. In GP4 this is set to zero by default and the script you have should not be needed. You can test it though - just install a trial of GP4 and see if there’s a difference.