Fading-on pad sound via modwheel

Hey guys,

as a long time hardware user I am new to using Gigperformer. I am currently learning the ropes and trying to create different rackspaces. There is one topic - which I’m sure has been asked a zillion times - that has me stumped. I have not found anything suitable and therefore ask here. Should there be a Workaround/Thread - simply refer to it. Thanks for your help.

Simple case:

Piano sound (Native Kontakt Grandeur) is selected. In the chorus I would like to fade-in a pad sound (also Native Kontakt Strings) via modwheel (stepless, so no simple “on/off”. The volume should be dependent on the modwheel position. I often use this with my Nord Stage).

Currently Pad & Piano are sounding constantly. How do I proceed here? I tried to learn the volume of Kontakt in Wiring mode, but somehow it doesn’t work. What is the right way here?

Thank you and greetings,
Michael

Hi Michael, and welcome to the Gig Performer family! :beers:

Just use your two instances of Kontakt (piano and strings) wire their outputs to the inupts of a 4ch mixer and connect the mixer’s output to the audio outs.
Then on the Panel-View place a widget (knob or fader) on the panel, learn it MIDI-wise with your MOD-wheel and connect it parameter wise with the volume parameter of the according channel of the mixer plugin. That’s it.
You could also use another widget to adjust the piano’s volume on the other channel (no midi learning needed for this one).

2 Likes

Hey schamass,

Danke dir! Thank you ;). I watched the expert talk from you on YouTube about gig performers - great stuff!

Everything worked. Could I also do this “backwards”? Different song, similar case:

I have an electric piano sound selected. When I turn up the modwheel, the electric piano sound disappears and a string sound fades in. Currently I am “only” able to turn off the electric piano when I move the moodwheel. Here the transition is super hard. Is it also possible that the electric piano sound fades out when moving the modwheel and is not only switched “on/off”?

Thank you and greetings,
Michael

1 Like

It’s the same approach… two plugins go into a 4ch mixer, then you need two widgets which are connected to the according “volume” parameter of the mixer channels. Then learn both to the MOD-wheel, but for one of the widgets invert the MIDI input (see the manual Widget Properties inspector (gigperformer.com) item “MIDI Tab → Invert button”).
That way the widgets will move in opposite directions… voilà a simple crossfade!
In your place i would use another two Gain-blocks which would go between the plugin and the mixer, then use an additional two knob widgets which should be connected to the “Gain” parameter of the gain blocks. This will allow you to adjust the volume of the two plugins separately, while the mixer block will just control the mix-ratio.
You may also use the forums search for “crossfade” i am sure you will find some additional stuff. :wink:

Here is an extensive thread about how to crossfade, with diffrent solutions:
Stereo cross fader - Plugins - Gig Performer Community
And here is another Scriptlet-based option (if you want to use that):
[Gig] X-fader - crossfade two volume parameters - Gig and Rackspace Files - Gig Performer Community

2 Likes

Just to add something on this great Erik’s post → about widget groups: How to add a widget to a widget group?

1 Like

Thanks. :slight_smile: Yeah you are right it also can be done with widget grouping and inverted values, but i like the MIDI-invert more because the widget’s actually move in opposite directions then, while in a group both widgets will move in the same direction but will send diffrent values to the connectetd parameters… this always ocurs to me a bit “unusual” (at least visually) .