"Create New Song" dialogue freezes

Out of real ideas here, but maybe try to unplug your network and disable WiFi. Let’s see if networking has something to do with it.

I have WIfi deactivated anyway and disconnected Ehternet and all external USB devices but still the same issue and CPU usage.
Ok so it seems I have a very specific issue. But thanks for all you kind support and suggestions!! Really a fast and great support!!

I’d really like to know what this is :slight_smile: Please let us know if you figure something out.
Some things to try:

  • Remove any window, key or other “managers/helpers”
  • If you installed any kind of software that hijacks normal Windows behaviour and controls your windows usage like the start menu, windows etc… uninstall it
  • Update everything on your computer. Windows and drivers

Not really that helpful I know, but keep us posted.

Thank you so much for still beeing interested even if it seems to be an issue very specific to my system.

I purchased this laptop for playing VST iunstruments only and nothing else. So beside GigPerformer and some VSTi (Spectrasonic, VB3II, Blue3), the Office tools (for setlist management and creating leadsheets) and this Norton Antivirus I did not install anything else worth to mention. Especially no hacks and cracks, no Autohotkey or whatever managers/helpers. Windows and drivers are always up to date.

What about to just uninstall and reinstall GP?

I’d remove Norton AV entirely and see how that goes.

Try to follow the recommendations in our free book on how to optimize Windows pc for stage

Maybe that will resolve things.

What is your Windows version? (hold Win key and press “R” to open the Run dialog and then type WINVER and press Enter).

I’m interested to see what happens in Safe mode.
Are you able to enter Safe Mode, run Gig Performer and see if your problem is still there?

Please try that first.

As for security options:

  • Try to turn off SmartScreen (see the guide that @djogon posted)
  • Add Gig Performer (the whole folder) in the white list or the exception list in Norton (I’d also try to uninstall it to see what happens).


I’m on Windows 10, and have made songs/setlists hundreds of times, all good. I’ve never seen this behavior.

I also tested the procedure form @Markus and could’nt reproduce. Everything works properly.

I uninstalled Notron AV. The Issue is still the same.

It is Windows 10, Version 21H1 (Build 19043.1165)
I dont know SmartScreen. It seems to be a feature of the windows defender which was disabled and replaced by Norton AV on my System. So I guess SmartScreen was not active on my system.
I uninstalled Norton AV 30 minutes ago.
I will restart in save mode now and repeat the test.

In save mode the issue has gone and GP works fine.

1 Like

But if you think about tips and solution please remember that each time the “Create New Song” dialogue freezes, the CPU load increases to a full 1-core load (1 of 6 = 17%). This indicates more a thread is actively forever wating for something rather than a process beeing blocked from gui input by other external processes.

If in Safe Mode GP runs normally, then 100% is problem in a program/module/library that loads automatically in the Normal startup mode.

I recommend upgrading your Windows to the latest build.

1 Like

When I create another GP instance and do a “Create New Song” within this new instance everything is fine, no dialog freezing.

I do Windows Update frequently (system asks me if update is available) and today I also forced an update manually. But issue is still the same.

OK, since your issue is not present in Safe mode, I suggest (as djogon posted earlier) to optimize your PC in detail; please see this guide:
Link: "Create New Song" dialogue freezes - #39 by djogon

I think there’s no question that if GP works fine in Safe Mode, then something else is running or is being loaded as part of the normal boot-up process that is interfering though I have no idea what it would be.

I checked the “optimize your PC…” guide. For the first part which is BIOS settings my BIOS does provude no such options to disable.

Apart from that I disabled VT-d and VT-x in BIOS since I do not use any virtual machines. Issue still the same.

The only thing which I have added to the autostart is Google for Desktop. I will remove an check!

I don’t have idea either, but disabling/uninstalling unnecessary stuff may actually solve the issue.

For example, in my experience HP computers come with many bundled apps that can cause many issues. I tend to remove them all and keep it as clean as possible.

Ok thanks for all your help! I disabled everything in autostart but issue still the same.