"Create New Song" dialogue freezes

I use GP version 4.0.54 and tried to create a new Song in a setlist. The Song Properties dialogue is shown up with all input fields visible but disabled. I can not enter or edit any of the fields/gui-controls. Even clicking the x in title bar does not close this dialogue.


The only way to leave/close this dialogue is a “close all windows” in the context menu of GP item in taskbar. I experienced this in version 4.0.52 already and this is why I updated to 4.0.54. I also started with a new empty gig file containing the Default rackspace only, added just one Setlist (->Add New Setlist) and then tried to create this new Song (-> Create New Song) but still song Properties are unusable/disabled

So currently for me it is not possible to use setlists.

Am I missing something? Has anyone encountered simmilar issues? Any tips, ideas, solutions?

Do you have GP (or other GP windows) open in full screen? I’m suspecting there’s another dialog underneath?

No, GP window state is “normal” and there is no other window open, neither any GP window nor any other applications (modal or non modal) window.

When dialogue freezes and I press Alt+Tab then I see only the “GP main window” and this “Song Properties” dialogue in the list of open windows.

I also restarted Windows 10.

On Mac I cannot confirm.

How do you reproduce that? Do you start GP, then switch immediately to the setlist mode, select to create a new song or …?

I start GP, close the “Tepmplates” dialogue without chosing any template.

Then I goto “Setlists”

From Setlist menu “…” I select item “Add New Setlist” which then is the first Setlist in this “Untitled” gig.
I name it e.g. “Set1” and press OK.

From Setlist menu “…” I select item “Create New Song” which open the freezed “Song Properties” dialogue.

It is 100% reproducible

Thanks @Markus . Just followed your steps to the letter, but cannot reproduce.
Would it be possible for you to record a small video and post it here? Maybe we’re missing something.

give me 5 minutes

Unfortunatly my video is too big (108MB). I wasn’t aware of this 20MB restriction. I’ll try another resolution.

While @Markus is trying to get the video to us - can anyone else reproduce this using his steps above?

I just tried. Cannot reproduce on Mac

1 Like

I was doing exactly the same thing and cannot reproduce.

I see that you’ve used GP for a while. Did this just start happening?
Have you installed some “window managers” or something similar?

I also cannot reproduce with GP 4.0.54 on Win 10.

I checked out this setlists also in GP3 a while ago (~1 year?!?) and it worked but I did not test that much in GP3. Now in GP4 I wanted to go deeper into this feature and evaluate if I really can use it for my use cases. So I tried it in GP4 for the 1st time today.

I do not use any window managers. I use a laptop with internal and one external display.

Same issue when I use internal display only

What happens if you do not create a new setlist first, but create a song first?

Same issue