ASIO Behavior problem

I have enjoyed my free trial of Gig Performer and really love the simplicity of organizing plugins and making custom racks. However, the ASIO interaction just is not suitable. I use a KlarkTeknik DN9630 as my interface, 48 channels in/out direct to an x32 via USB. If I change by ASIO buffer size in GigPerformer then GigPerformer hangs. If I terminate GigPerformer and change buffer in the ASIO driver for the DN9630 and then bring GigPerformer it works. If I use ASIO4All this works a bit better, it is jsut slow and the ASIO4All interface also needs adjusting. I come from REAPER. In REAPER I can change buffers in REAPER with either driver and REWPER and the driver communicate and synch up and everything works great. With GigPerformer I gain stability at 1024 buffer size, with REAPER I can use 128 for as equal complex a setup as I can get. Oddly, with ASIO4ALL a buffer size of 64 also works well…just 128, 256, 512 do not…so that makes no sense, My trial has expired as I fought this battle, so I am now pretty much giving up on GigPerformer and going back to REAPER for live. The interface is nuch less friendly, but the interface works cleanly. Since I cannot test anymore, I can’t do much else…but I felt compelled to report this rather than just letting this issue exist and ghosting GigPerformer without helping to expose an issue.

The problem may be related to the actual plugins you’re trying to use — some of them don’t like being reset.

Question: have you tried changing the settings in an empty gig file?

(Also, your trial can be reset - just submit a ticket through our support system)

2 Likes

Bouncing GigPerformer still left me with the same problems upon restart. Also, using the same plugins REAPER has no problems…REAPER terminates flow of audio while changing ASIO buffer size, but after closing the menu the audio comes right back (very fast) and the driver interface reflects the buffer change. In GigPerformer I found that closing GigPerformer and changing the buffer in the device ASIO interface and then restarting GiGPerformer at least does not cause GigPerformer to hang, but I still require a bigger buffer when using GigPerformer. It makes me wonder if something is a bit off in how GiGPerformer and the ASIO driver interact.

That’s how I do it. I first change settings in the driver’s options dialog (or ASIO4ALL) and then adjust values in the Gig Performer Options window.

Once I set it - it works, I don’t need to mess with it. I use 128 samples as the buffer size.

Please create a new ticket to reset your trial.

5 Likes

That is the best practice, with all audio applications closed.

3 Likes

I’ll just toss out a couple additional thoughts…

Your interface looks like it operates at either 48K or 96K. Windows itself defaults to 44.1K. In my experience this can sometimes lead to problems. I don’t know if the issues are in Windows, the drivers, the applications, or just some weird and inconsistent interaction between them. I just try to make sure they all match. I usually run all my systems at 48KHz, so I go into windows control panel and set all my devices (ASIO or otherwise) to 48KHz in an effort to minimize issues.

I’d leave ASIO4ALL out of the mix if you can. It’s just putting another piece of (aged) software between your interface and GP and really shouldn’t be necessary for what you’re doing.

As others said, set up your sample rate and buffer size in the Klark Teknik driver first, then go into Gig Performer.

5 Likes

The PC speaker properties are not applicable to this interface, but I did make sure that the PC audio in/out was not using the same interface as GigPerformer…that did not seem to help. I have found that reducing CPU load on the PC did help…reduced plugin use…keeping it under 50% seems helpful so far. Thanks for the suggestion though…it did help me ensure no overlap from system sounds.

That image I posted was just an example showing which dialog box I meant in the control panel settings (on Windows 10 in that case).

You may only have two audio devices in yours, or you might have a several you don’t even think about. If your monitor has built in speakers it will show up as an audio device. On board sound drivers may create multiple devices. My suggestion was just to set them all to the same sample rate, even if you never use them.

That part was purely about the “ASIO dialog hangs” issue.

That sounds like a CPU utilization issue. I strongly suspect that if there are material differences it’s a function of how you have things set up in Reaper vs. GigPerformer rather than a real difference in the performance of the audio engine.

I used Reaper for live playing for years before I switched to GP. I did a lot of performance testing before switching. I’m not going to say there is no difference, but I will say that when I structured apples to apples comparisons the difference was immaterial.

I think the key thing to understand for that comparison is that your CPU has multiple cores, and Reaper is pretty good about figuring out what audio it can render on different cores, what audio it can render in advance, and what it has to do in a single thread.

Are you observing something like “I can run 18 VSTs in 6 different Reaper tracks and get no glitches at 128 samples” but the “same” setup glitches in GP? If so, you can probably get that same performance out of GP, but you’d probably have to set things up differently in GP.

That’s a pretty broad topic, though. It would be helpful to know what your setup is in Reaper and how you’re trying to replicate that in GP.

2 Likes

By the way, what is the link for creating a ticket? :nerd_face:

I already reset his trial :slight_smile:

FYI, the FreshDesk portal is here: Knowledgebase : Deskew Technologies, LLC

All material is up-to-date there as well.