Small audio pauses and clicks

Hi gp users, I have been a GP user (keyboards) since version 2 and exclusively using it untill i went back to hardware again and did so for about 18mths.
Anyway im back :crazy_face:. So… I have a decent windows based rack mounted 2u pc and a rme ucx interface running a yamaha CP 88 and Yamaha Yc 61 currently. Ill click a link for the rig i have as it was featured a couple of years ago in a gp write up.
The reason for this post is i have been having hearing some strange quiet ticks and clicks in the audio and slight pauses. I run 44100 and a 128buffer, I know it is not a processor problem as my cpu and pc hardware is more than capable. I started problem solving and have found that this problem does not happen when i connect my boards with 5pin midi to the rme as the interface. So i figure its a usb problem and changes all the cable (usb 3) as they are the only cables and ports i have still no fix. So im stumped, all rme drivers are up to date and the only difference from when i left gp for a stint is new m.2 hard drives and its now win 11. I have also noticed i have had alot more stuck notes than i ever use to get.
Any help greatly appreciated :pray: :slightly_smiling_face:.

I don’t know much, but I figured I’d confirm you are/are not using a USB hub?

Is your audio interface connected to the same hub as your MIDI controllers?

So i have tried the keyboards thru a usb hub i have also run them directly into the motherboard, tried both powered and unpowered hubs different cables. It happens when im just processing my hardware thru gig performer just doing program changes. I read that sometimes it is better to run usb 2 rather than 3 on rme forum. This is not possible for me to try as i have no usb2 ports. I will try the yamaha steinberg audio interface built into the keyboards when i get home to see if it has same problem. I also have a cheap native instruments interface i could try.

What happened to your first account? You lost your password?
Link: My custom 2u PC live rig


Yeah and what email it was associated with, i will sort it out and get back to the right acc asap. I have alot of gigs and gotta get my GP rig back to its former glory quick, right now its not reliable and cant figure out why.

Do your sample sizes match?
Link: ASIO Behavior problem - #6 by Vindes

Other guidelines: FREE e-book by Deskew - Optimize your Windows PC for the stage!

Yeah i have checked all of this and its all synced to 44100 on my rig. I run some tests last night and tried the built in yamaha audio interface on the cp88 and it was good, seems to be when connected to the rme it starts to play up. I know the rme is good coz its fine in my daw and in my other software host i use. Im thinking it may have something to do with the yamaha yc/cp and windows. Its a weird one but i will get to the bottom of it.

Windows11 user here with RME baby face. I have a Yamaha montage at work.

I almost exclusively use the 5 pin midi connections. In my experiences with montage, which is the same Steinberg interface Yamaha uses everywhere, glitchy things happen with usb midi and windows. The Steinberg drivers don’t like windows, both for audio and midi. Work fine with my iPad ironically enough.

Haven’t figured it out why and honestly don’t care. I bought a new midi breakout cable for the RME just so I could go back to hardware midi cables. If your board(s) has midi through, you can use DIN midi everywhere.

This is what im thinking also because my yamahas work perfectly with my ios version of camelot pro but i would prefer to use gig performer when vsts are involved so i think i also will just use the rme breakout cable and go old school and use 5pin din.

So if i dont try and process the audio from the yamaha boards all the clicks and popsgo away. Interesting??

1 Like

Were the sample rate and buffer size on the Yamaha audio interface built into the keyboards the same as in the RME?

It seems that there is some interfering on the Windows level.

Actually this is happening just from the audio getting processed thru gig performer the actual yamaha steinberg audio interface software is not installed on my pc anymore as i thought that was the cause. I honestly think it maybe a midi over usb thing as i set my keys to local off, when using gp. But strangely it doesnt do it when im using vsts only.