Using an iPad to send Program Changes

Hi, I’m using the trial version of 4.5.8.

I use a product called Linkesoft Songbook which uses a Program Change command, which works quite well (until you get to Song 128). The lyrics and chords scroll along at pace that coincides with the length of the song. I find Likesoft works really well. I previously used Onsong, but it was way too expensive, and very buggy.

I have been using this with Mainstage on stage, and the Program changes have worked quite well.
The PC command is embedded in the Songs txt file (which is in chord Pro format). There is a link to the commands on the above link, under Midi Support.

The Global Midi Manager (on Gig Performer) is Receiving the Program change messages when I send PC commands when changing songs, but doesn’t seem to change songs in the setlist section ( I assume that should work?). I have added the corresponding PC number into the song.

I have seen a few posts and tried following them but no luck so far. The iPad is enabled in the Audio Midi Setup.

I don’t really need to have different sounds for intro/verse/chorus, and I am just trying to keep it simple. With Mainstage they have a pretty screen with all the parameters, but I just mainly use the Edit screen, which shows more parameters.

The PC number needs to be entered in the first song part properties. You added it here and not in the song properties?

The other key place to check is the Global Midi options. It has a section for Program Change messages.

Thank you, I tried what you said (hopefully). I have added 3 songs that we do, as a test.
They are

  • 20 Good Reasons PC88
  • 3AM PC14
  • All Fired Up PC90
    I did this after I took on of the Images which still shows PC 1 for All Fired Up, It is now PC 90.
    The Changes come through on Global Midi Monitor (as per image).

The Program Change Control items all appear to be ticked, including the ipad (as per above image link). At this stage I’m just relying on PC changes, to keep it simple, put will look at Banks MSB/LSB later.

Still no luck.

How look the messages int the Global MIDI Monitor Window?

I have been fiddling with Program changes as well as LSB/MSB. They are just not talking to GP yet. Here is the screen shot.
Below is the Instruction Set from Linkesoft
> ### MIDI-Support
*> *
> SongBook supports MIDI on all iOS devices. When MIDI is activated in menu Settings, SongBook will connect to all input and output sources on the MIDI bus.
*> *
> You can select a song with a MIDI command by inserting a directive {midi-index: , ,…} in the song. You can also send certain MIDI commands when opening a song by inserting {midi: ,,…} in the song. You can also use a MIDI pedal to scroll up/down in a song, by entering the respective command in Settings.
*> *
> The general MIDI command syntax is .:@ (see table below). However, in most cases it is easier to just select the MIDI command from the list of last received commands (via menu in song editor, or for up/down pedal in Settings).
*> *
> |Command|Explanation|Example|
> | — | — | — |
> |N|Note (On/Off)|N60|
> |PC|Program Change|PC6|
> |CC|Control Change/Bank Select|CC100.10|
> |SS|Song Select|SS99|
> |START|Start|START|
> |PAUSE|Pause milliseconds before sending next command|PAUSE10|
> |XX.XX.XX…|Arbitrary bytes (e.g. System Exclusive)|F0.42.30.73.00.41.F7|
*> *
> For testing, write {midi: N60} anywhere in the song. This will play a C1 note on a connected keyboard whenever you display this song. Alternatively, if you have {midi-index: N60} anywhere in the song, this song will be displayed whenever you play a C1 on the keyboard.
*> *
> Note: MIDI is a very complex topic. Unfortunately we’re not able to help with specific questions about MIDI setup or MIDI commands.

So I usually send a Command like {PC88} to switch the Patch suitable for song #88

How looks your options to accept program changes in the global MIDI options?

This was confusing for me as well…but I think the solution is to go into ‘Global MIDI’ options and turn on ‘Use zero-based PC numbers’.

You will then see your song part PC numbers have shifted by 1. Change them back to 14, 90 etc, and try again.

I use an iPad running an app called OnSong. I am able to use OnSongs midi functions to wirelessly send program changes to my 500+ songs (rackspaces) in GP. OnSong also displays lyrics and chords and is my master midi controller.

Hi, I just did that. Didn’t seem to make a difference. That is what I did under Mainstage, and I had to adjust all changes by one. Very confusing. I played with numbers in the song intro. Still no luck.

I was using Onsong, but
1 it was too expensive
2. IOS only. They should have basic web support to edit files easier.
3. I have a Samsung Galaxy Fold, which is FANTASTIC. I don’t want to downgrade my phone
4. There are always messages of don’t upgrade IOS,as there are issues with Onsong vs IOS Upgrade compatibility.

Mine are already all ticked?

OK, next question
How looks the Global MIDI Monitor window when Gig Performer should get Program Change Messages?

According to your screenshot you linked above, you had zero based PC switched off. What this meant was that when you entered PC 14 in the song part properties, you actually needed to send GP PC 13 for it to work.

So I’m surprised it didn’t make a difference when you turned the option on.

He linked the screenshot, I’ll upload it here:

SUCCESS!

So, I did what was suggested again, that isSet the Midi messages to use zero based PC numbers. I remember having a similar issue in Mainstage, hence I have to set every patch number MINUS 1 - very confusing, but that is the world of Midi from 40 years ago.
I adjusted numbers back and forth, and I noticed one song was changing, which was All Fired Up. I delved a bit further, changed numbers, but then I noticed that 20Good Reasons had 0:88, and 3AM had 0:14. I removed the PC change, and put it in again, and those numbers disappeared. I tried switching again, and it works. Now to find play with arpeggiators and Samplers, plus tinker with Ripchord.

1 Like

Another step down the track is getting my Ipad to send PC changes higher than 127.

There is no PC message higher than 127
You need to send bank messages and then send the PC message.

1 Like

And based on that screenshot, his iPad is indeed sending bank select messages (CC 0 and CC 32 values) so it shouldn’t be an issue.

Note that those bank select messages will always be zero-based

Yes, I was aware of that (Thank you, anyway :slight_smile: ).

I haven’t had much success in getting Mainstage to recognise the control changes coming from Linkesoft. Linkesoft unfortunately don’t do Midi advice/support. :frowning: