USB Hub Issues

Hi Group… I am having some difficulties when connecting 2 x controllers to GP with USB cables via a Hub. I’m using a Microsoft Surface device with 1 x USB-C and 1 x traditional USB connector. When I connect either of my 2 x keyboards direct to the computers USB, GP can see the device and recognises the device in the rig manager and throughout the system. If I try to connect the same devices via a USB hub, the rig manager does not see or recognise the device?

I have tried 3 x different USB HUB’s to see if that is the issue and all are the same (one of them a powered hub). Before I order a Midi Hub to see if that works, is there anything that can be done to prevent these devices from dropping out of view when connected to a Hub?

Thats the reason why Rig Manager is there,
When using a usb hub this issue occurs.
In Rig Manager just learn your correct physical device and you Are Ready to Go.
In the Gig Performer Website there is a Blog about that and what you can do that the usb ports are remembered by the Operating System

1 Like

I will try to find the blog piece you have referenced…but I’m using the Rig Manager and I’m saying that it IS the rig manager that cannot “see” my keyboards connected by USB (rig manager shows all of the mapping greyed out)

How looks your midi ports window in the options?

Can you Learn your controller in Rig Manager?


Please check the available Midi Ports! If your controllers are in that list, they are ready to be used - if not then there’s an actual issue!
MIDI Ports (

The Rig Manager is most probably seeing your controllers, but it doesn’t “know” them by their actual name, that’s why the entries are greyed out.
Since stupid Windows tends to “rename” the USB-devices when they are plugged into another port, the formerly known name in Rig Manager isn’t available anymore and thus has to be re-assigned again.
That should be all…

Excerpt from the manual…
How to create an alias for a MIDI device and a MIDI control? (


This is a well-known Windows issue that has been around for decades.
Link: Gig Performer | USB MIDI Port names keep changing on Windows

Another possibility is that your USB hub does not have enough power to accommodate devices attached to it. I’d try with a different hub.


Thank you for the article link. I will definitely check this out. Hub wise…I have tried 3 x different Hubs including a relatively expensive “WavLink” hub which is mains powered. None of the 3 x I tried was able to correctly identify or acknowledge the devices via the Rig manager.

I’d like to try connecting using Midi instead. I know it’s one-way and a much older technology with less bandwidth but I’m hoping that it offers a much simpler way of recognising connected devices.

Rig manager is not for identifying changed ports correctly.
It is for an easy way to manually connect, if necessary

1 Like

If the Rig Manager can’t see the device, then it may be that the controller you’re using is not class-compliant and needs a driver to be visible. I’ll bet that other applications you have can’t see the device either.

Unless you actually have a MIDI port on your computer (very unlikely) , you’re still going to need to connect through a MIDI-USB converter and it will be that USB converter that will be seen as a port.

1 Like

(maybe his interface has MIDI inputs)

Anyway, here is a useful article that covers (or should cover) all connection variants step by step: Gig Performer | How to change sounds and control plugins from your MIDI controller

Sure. But his interface will be connected via USB and it will be the interface that is seen as the midi port

I guess it would be useful to see a screenshot of the Midi Port options screen when the controllers are connected but they “don’t work” in the Rig Manager… are they generally available or not?

So, first of all it doesn’t seem to be a driver issue, your controller are probably class compliant.

This is the power hub I use if it can help:

Rig manager can see one device if I plug that device directly into the PC. Problem occurs when I need to connect multiple things to the same USB port and have GP recognise and work with each device. Here is a list of devices/items which I need to have connected simultaneously:

1: Small Router (used to control IEM mixes via a Behringer X32 rack mixer)
2: Roland A800 pro controller (also using BUS power form the USB connection)
3: Roland FA08

So I only need 3 things connected however, as soon as I connect all 3 via a USB hub (and I’ve tried 3 x different hubs so far) GP cannot identify the devices.

I did find a post from yourself recommending this HUB. I have it in my Amazon basket ready to buy…but I must confess, because I have already tried 3 x different hubs (one of which was DC powered and is in the higher price bracket for Hubs (well over £100) I still don’t have full confidence that this Hub will see my devices correctly. I will certainly try it though if you don’t feel the issue lies elsewhere in my settings or config.

Is this the controller that is not being found?

If so, have you configured it as a generic USB device?

When you connect the hub, how looks your MIDI Ports in the Options Window?

1 Like

You tried 3 hubs but have you tried different usb cables?

I’ve had problems with loose fitting usb connectors. I wish they made connectors that reliably snap in like 1/4” phone plug.

I did purchase better USB cables than I had and I did swap out a couple of cables early on in trying to troubleshoot why Reg Manager could not recognise the devices. I purchased UGreen braided USB cables. These to be exact in 1m and 3m lengths.

How looks your MIDI Ports Window in the options when you connect the HUB?
And how looks your Rig Manager when you press the icon with the 3 dots?

1 Like