Trouble with UAD Arrow interface


#1

Hi All,
I bought a new laptop to use with Gig performer on gigs. I specifically bought a powerful laptop with thunderbolt 3. Gig performer recognizes the Arrow, but after a few seconds the screen turns red, and I get a message that the connection is lost. Using the Arrow with a stand-alone plugin works fine. I then tried the arrow on my desktop with thunderbolt 3 (built in to the motherboard - not an add on card), and Gig performer does the same thing on this machine. Cubase 9.5 and standalone plugins again work fine. I tried a USB2 interface on the laptop, and Gig Performer works great. Any ideas? Otherwise, Gig Performer is amazing!
Thanks,
Bob


#2

Is GigPerformer the only audio software which is using the audio interface?
Which ASIO-Driver are you using?


#3

What samplerate and buffer size are you using?


#4

Hmmm, this is the second time we have had a report of a problem specifically with Thunderbolt on Windows. Having said that, a google search suggests that this problem seems to be quite widespread. Gig Performer has functionality to detect that an audio interface went away (so it can detect if you unplug, for example) but I’m sure what’s going on that would cause GP to decide that a Thunderbolt interface “went away”. I guess we’ll have to get a Thunderbolt interface to try it ourselves.


#5

Thanks for the reply. Yes, Gig Performer is the only software. I’m using the UAD ASIO driver that came with the Arrow.


#6

I tried several. Even at 44.1 and a 128 buffer, it did this. A larger buffer, and I start noticing the latency. My NI USB interface runs fine at 48k and 64 sample buffer. Thanks!


#7

Thanks David. I hope you can figure it out! I really love the product. I can do more with my laptop and a small interface than I used to do with racks of modules, thanks to your software.


#8

Could you please try the following.

  1. Start GP and wait for the red overlay to show
  2. Click on the Options->Audio setup… menu item
  3. Click on the “Reset device” button.
  4. Click on the red “Apply settings” button.

Please report if the red screen goes away after a few seconds.

Thanks.


#9

The problem with UA Thunderbolt audiointerfaces is fixed in 2.5.2


#10

Incredible! I can’t wait to try it again! That’s a really impressive, quick turnaround on this issue.
Thanks!
Bob


#11

Let us know how it goes


#12

OK, so I installed the update on my new desktop last Friday night, practiced for a while, and let it run until Monday morning, playing a plugin here and there to give it a chance to fail. There were no red screens, no issues what so ever! I do believe you have it fixed. I REALLY appreciate it! I’d love to know what the fix was. Thanks again!
Bob


#13

Glad it’s working for you and we certainly appreciate your patience while we figured it out.