Some experiences from the move Intel/BigSur to M1/Monterey

Helle Mac users,

I spent some time on the last two weekends to move from a 2015 MBP 13" under Big Sur to a 2021 MBP 14" under Monterey.

Here are some of my findings and some open questions I want to share:

When preparing the move I decided to leave some stuff behind and just setup the new MBP as new one and not to use my TimeMachine backups and ‘just’ migrate. Also I want my old MBP for backup in the next months…

So, as a first step I decided to start with a basic installation, copying some data and preparing a list of my needed plugins and a Logic Pro installation from scratch. I also had to export/import some of my general user settings for some plugins.

To sort out my plugins I did an analysis of my Gig Performer.settings and my 3 main .gig-files with a small Python script and some Excel-cleanup I described here I'm looking for whatever file that keeps the list of plugins/VSTs that GP has found before - #8 by tripleB (the script has meanwhile expanded…)

After some long time, reboots and tests all my needed plugins have been setup and found by Logic Pro. The only incompatible plugin I found was the Air Hybrid3 which still runs if you ignore the warning.

So far so good :heart_eyes:

Now I started installing Gig Performer 4.1.5 and rebuild my global and rig settings. My basic GP setup are two instances of Gig Performer.

Basically all fine and working. However I had to switch from native M1 to Rosetta due to some VST Plugins which have been blocked due to incompatibility. Interestingly Hybrid3 is reported in this case as compatible…

Now here are some of my findings and questions:

1> when switching GP to Rosetta my main instance had to rescan all plugins and everything works OK now. However, my (existing) 2nd instance did not rescan properly (i.e. showed the same failing plugins). So I deleted the existing 2nd instance and created a new one. Everything fine now!? But: is this the intended behaviour?


  • What happens technically when switching M1/Rosetta to settings/instnce behaviour?

  • How can I setup a third instance running native M1? I just would like to have this possibility to see when I’m ready to switch off Rosetta to normal M1… :thinking:

2> some plugins in 2-3 .gig-files have been shown missing. I had to replace them and recreate the settings. This have been plugins from Arturia and the PG8X.


  • What could cause this? For the Arturia I first suspected the new installation /w a newer version of the plugins. However nearly all plugins have been found correctly. On the PG8X it has been exactly the same installation source?! :thinking:

3> Sometimes I had mixed up MIDI in assignments in rig-manager and underlying scripts when opening an old gig the first time. Safe way: load gig, check rig manager, Apply(to recompile scripts…) and save as new/updated gig.

4> even if you have not setup all your plugins completely (e.g. imported you user presets) the plugins used in the .gig are OK thanks to saved plugin state :sunglasses:

So, finally everything is up and running - I’m looking forward to the first rehearsal on Wednesday to see if there are any new or remaining issues. :grinning:


1 Like

As one of the developers (but also a serious user) I’ve been watching the reports of people moving to the M1 and wanting to use Gig Performer, or even other DAWs with their plugins.

My own personal position is simple

  1. GP will run either native Apple Silicon or under Rosetta

  2. However, while I think we can be clear about GP native under Silicon, I’m less comfortable with the “mixed” environment because there are too many extra pieces … some drivers running native, plugins and GP running under Rosetta (so Rosetta has to be perfect) and so forth. There are just too many variables and too hard to figure out why things are seen, not seen, maybe work, maybe scan but not work and so forth

  3. For my own live situation, I’m staying with an Intel laptop until every single one of the plugins I need to be able to use live is available to run natively on M1


Hi @dhj - I absoloutely understand your point. A mixed M1/intel would be a nice add-on, but at the end it’s not relevant.

For the moment I’m fine with Rosetta. This combination gives me more possibilities as with my DualCore 2015 MBP 13" :wink:

I digged a litte bit deeper this afternoon. At least I can see now one remaining issue:

Following Gig Performer | What to do if Gig Performer 4 can't find or use your Intel plugins on the new Mac M1 processor I started the journey to Rosetta.

Everything is fine as long as I open GP by the Launchpad, out of the program folder, by Spotlight or with the Dock. Also when I start my second instance out of the file menu

However, if I use my good old AppleScript hook like

do shell script "\"/Applications/\" -nosave &>/dev/null &"
do shell script "\"/Applications/\" -in=MASTER -nosave &>/dev/null &"

This seems to run the M1/native app, and not under Rosetta?!

And yes, of course the instances read their dedicated and independent Gig Performer.setting or Gig Performer.MASTER on startup…

So when I started to sort things out, I correctly ran GP under Rosetta, did a PlugIn Rescan, tested my previously failing Plugins and everything is fine.
If I now close and restart GP by my AppleScript, GP seems to start in M1 mode! The plugins are still valid according to the previous scan/ no rescan at startup, however cannot be found or added/opened.
If I now do a rescan, I got the previous M1 results with most VST(3) plugins invalid, as before switching to Rosetta. Aha! I was able to reproduce this :innocent:

So magic question: How do I launch GP in Rosetta mode from AppleScript?


Note to myself - and all other interested…

do shell script "arch -x86_64 \"/Applications/\" -nosave &>/dev/null &"
do shell script "arch -x86_64 \"/Applications/\" -in=MASTER -nosave &>/dev/null &"

does the trick :innocent:

arch -arm64 ...

would force native silicone / M1 mode…


I’ve been considering getting a M1 Macbook Pro at the beginning of 2022, however my question is this. Can you run the native M1 mode in GP 4.x while still running plugins that are not native M1 plugins. Can you run plugins that require Rosetta while running GP in M1 native mode?


I think that is not possible.

Kinda …. Apple did something vaguely sleazy (IMO)

They needed to make sure that their M1 versions of Logic and MS could keep running user projects that still had Intel plugins. So under the covers, if an M1 DAW tried to load an Intel plugin, Apple will load that plugin automatically under Rosetta. But only if it is an AU plugin. They didn’t do it for VST plugins thereby making any other M1 DAW that supports VSTs as well wouldn’t load.

1 Like

Bottom of Gig Performer | What to do if Gig Performer 4 can't find or use your Intel plugins on the new Mac M1 processor :wink:

1 Like

such a script has been posted here by @rank13 in one of the early M1mac vs. GP4 threads.

i in fact can open GP from the title bar in my M1mac.
Each, of all 4 GP instances, each as a Intel or a Arm version, …each by its own entry.
So, 8 entrys, 8 choices,…i just need to Mouse click the one i want to open.

i give you here the scripts how i have it on my mac, for my instances (with my names) ,
1 for ARM (first),
1 for Intel (second).

JFYI: I don´t understand this things !! But you seem to :wink:

do shell script "\"/Applications/\" -in=GP4_1_MAIN &>/dev/null &"
do shell script "arch -x86_64 \"/Applications/\" -in=GP4-1Intel_Main &>/dev/null &"

this are the (my) specific names here: (You´ll get the idea, i´d guess you´ll figure it out )

allways the same script text, in 2 versions, for arm and intel, just the name changes for tzhe 4 different instances ( just for completeness )

hope that helps. Or else, @rank13 might be here from further help :wink:

1 Like

@Funky40 thx! somehow missed this post - however good: same result on my side :sunglasses:

I am using the traditional way in my 13" M1 MacBookPro to choose compatibility: from finder there is a way to set an application as intel mode (asking Rosetta translation).
Currently I use both LogicPro and GigPerformer in Rosetta mode: this way 99% of my plugins work well, no performance issue.
Since few days Arturia went M1 native, and many other synths can now be driven in a full M1 mode, such as U-he and Synthmaster.
So my question is: better staying safe keeping everything under Rosetta or trying to accelerate and translate only the AU not M1 native?
Is there any difference with Monterey? No software house reports to be ready but all users with new machines seem to be happy.
Like me one year ago with BigSur…
Any experience here?

@Furio I had no chance: my MBP 14" came with Monterey out of the box. I run Logic Pro in native M1 mode. All my (AU-) Plugins (from Arturia, Korg, Plugin Alliance, Valhalla, GSI/VB3-II, Cherry Audio and some more) are reported OK besides the Air Hybrid3. And as @dhj mentioned: Apple invokes Rosetta automatically in the background for AU plugins :sunglasses: So for me there’s no need to force Logic Pro to run under Rosetta.

Under GP the situation is different: as I use some older VST Plugins (like the great MLVST PG-8X) which do not support native M1 (yet), I have to run GP under Rosetta.

Also: no problems with other software, audio interface drivers (Focusrie Scarlett).

For me the sun is shining after figuring out my scripting issue :innocent:


If your beloved old plugins are available as AU you could run GigPerformer too in M1 mode.
Does anyone knows if this setup is better performing?

I’ve been on Monterey for about a month now with no problems…except one. My IK Syntronik 2 will crash GP when closing the plugin window. This happens with VST, VST3 & AU. It will also crash Reaper, Reason and Ableton Live. I’ve opened a support ticket with IK on Nov. 29 with no results yet other than their acknowledgement. But, as far as Monterey goes… :+1:

Good to know. One can live without Syntronik if there is Arturia working…

1 Like


I had my first rehearsal yesterday evening with my new MBP 14" and it worked like a charm :sunglasses:

To slightly push it I reduced the audio buffers sizes in my two instances (/w respect to the buffers I needed on my old 13" MBP 2015…).
I just ran the MBP on battery with providing power to an unpowered USB3 Hub, my Arturia KeyLab
MkII 61 and a USB LED light. Active WLAN and BT connections for BT MIDI and WLAN remote control of our mixing desk. Both GP instances under Rosetta. Focusrite Scarlett 8i6 as audio interface. Forte SE as 2nd manual.

I ended up after 3.5h with remaining 68% on battery :sunglasses:
Aboslutely no issues with anything :sunglasses: :sunglasses: :sunglasses:

Everything worked as expected and before, with ‘just’ improved performance.

I’m happy and looking forward for further improvement of my gig-files (and geting rid of some limitations I had before)



Very good… I have similar experience with my M1 MBP 13". Three hour rehearsal with hub, two midi controllers and audio board.
Everything on battery. 70% at the end. And no performance issues.
This is strongest point of M1.
Very nice to see that Monterey works flawlessly


Any of you with an M1 Macbook Pro using Korg Collection 3? If so, is everything working as expected?


With BigSur yes. No problem here

1 Like

I saw no issues on the KORGs that I’m using out of the collection 3. But remember: I’m running under Rosetta!

1 Like