SOLVED!_GP4: PA-unlocked on M1mac, my plugins are shown in "red"(missing)

sorry, i kind of think and write,…which makes it longer winded than you might prefer…
i´d say we are here up on something.
a short sum up:
The plugins that DO work on my M1mac as a VST/VST3 are (as far as i can see) ALL, plugins which are “native apple silicon ready” !!!
Also: the pluginAlliance GP4-unlocked, has no distinction between a “intel” and a “native apple silicon” version. It is just one Mac version ! (screenshots at the end)
…My guess now: here along all that must have happened something at plugin alliance.
and my furter thought: there is some communication needed between the Deskew developer Crew and PluginAlliance.

Thanks to everybody helping here !! Much appreciated

My Post with the Quotes:

Thank you very much !!!
thats a first hint towards that there is a problem with the PA-unlocked version.
Also = —> i´m not the only one with “that specific Problem”

(i´m on Mac / M1macs)

let me add here something in general:
The PA nomeklature seems confusing.
I personally do just look at the “unlocked” version as the “regular one” !
so, its the other way around: its not “unlocked” but the PA Version IS “locked”.
Also, and thats important to understand: you can´t buy the “PA (locked) one” as such.
It is only part of the subscription model,…and i´d guess that everybody who is buying GP3/4 from PA, knows that upfront. ( since you can´t buy the PA one)
I think i´ve seen here just onece a problem coming from a “subscription model GP3”.

so in short, under us, the regular GP users, is NO confusion on the table with the two differnet versions from PluginAlliance. at least it much looks like.

now something to something very interesting:

Huh ?..WoW

At PA, there is One GP4 version for the Mac ( we speak the unlocked one) .

Do you say, at Deskew original, there are two Mac versions ? one for intel Macs and one for apple silicon ?
With PA, thats definitly NOT the case !
…which could be a point…no ?

The patch was made in GP3 on a M1mac.
I run a M1mac since early dezember 2020 ( and only play on the M1mac since)
So, here is everything running on Rosetta, finally. automaticly.
All my plugins used in my patches, do work ! I´ve not donne one new patch on GP4.

But wait:
these plugins which do work, means—> also working as a VST/VST3 (since the AU version would run with any of my plugins / AU version not causing problems) are native apple silicon ready.

Fabfilter is native apple silicon ready. Pianoteq too. BlueCat too.
That small freeware thing from “CaleumAudio” is iirc too.
Ay look, U-He loads too, also native apple ready.
Ay, my polyverse plugins load too. ( again: we allways speak here VST or VST3 /since the problem is not present for the AU versions)
I installed the Polyverse plugins just tonight, and they are fresh “M1 compatible” ( seems that means they are “native apple silicon ready”.

OK, i can make out a pattern here, at least for my problem-case:
The plugins which are “native apple silicon ready” DO load as a VST/VST3 .

I´ve not tested them all, but most of them just right now.
also: i´m not totaloly aware what all is M1mac ready.
But hey, its kind of a granted thing now, THERE IS A PATTERN.
----> VST/VST3 versus “native apple silicon ready” and the Plugins that are not.

but @SirTommes, he says hi is on a windows machine…???

so, what are you using ?
edit: ahh wait i see !
so we two have not the same problem then…so i´m still a lone Cat, lost in space, haha :wink:

screenshots btw. from PA, download section for GP4-unlocked :slight_smile:

I know this download pages, but every time I load the “Unlocked Installers” I install the GP 4-PA Version…

I think, that is a the problem, that I cannot activate my "unlocked-"Version. But I’m on windows, perhaps I should try it on Mac.

Until now no answer from the support.

1 Like

sorry, the screenshots were not meant towards you.
i mean, the question is open: is the original deskew version a double installation thing vs. mac ? (Reaper for example is / or at least was when i installed mine)
or how is it handled here with GP4 ?
how is somebody who runs the deskew original GP4 (on a mac) knowing if he runs the Intel or the “native apple silicon” version ?
whats the deal there ?


no reply either from pluginalliance

I too have the same issues. All of my plug-ins are missing. I mostly use PA.

Thank You

1 Like

PA has just answered:

“If you are on a Windows machine, there is something wrong with the unlocked installer. You should be able to activate the PA version, nonetheless. Please send me screenshots of your activation process.”

I can’t activate the PA-Version, I will send them a screenshot.

But as I said, I will try GP 4 on my MacBook and see what happened.

1 Like


i don´t understand this message, and how it would/should help ?
just posted there…coming with my questions :wink:

If you are using a new M1 Mac, then it seems that the PA Installation Manager did not install M1 versions of their plugins. Hence any plugin host, including Gig Performer, running natively (as opposed to under Rosetta) will not be able to load the plugins.

i still don´t understand that point and whats the cause of the problem, since i am since 6 months on a M1mac, and everything went fine so far.
= everything worked fine under Rosetta !
even most plugins that were not specificly rated as such do run.

But am i right with my assumption that this problem is only existing with the PA-unlocked version, but NOT with the original Deskew GP4 ?

and i still don´t understand:
with the original Deskew GP4, it would install two different versions of GP4 on the mac ?
how would one chose which one to be loaded, intel vs. arm64 ?

as sayed, i´m perfectly fine with running GP3 under Rosetta.
I have small latencys ( with my TB3 Audio interface / even at 128 samples Buffer / i run Bass roundtrip / works like a charm)

The Deskew version comes as 2 separate installers: a ‘Universal’ version that is intended for newer Macs, including M1, and a ‘Intel only’ version. My understanding is that the Intel only version would still work for an M1 Mac - as it would run in Rosetta (same as GP3).

My question to you: does PA offer the ‘Intel only’ as a download option?

No, it does not !
it´s only one installer for the mac.

i´ve posted screenshots for that specific reason, to show this.
its 10 posts above this one. In fact the first screenshots that appear if you scroll up from here. These two pictures show the download section at PA at the GP4 page

If you use Finder and go to the Applications folder and right-click on GP4 and select ‘Get Info’, do you see a tick box to force it to use Rosetta?


If you did not install ARM versions of the plugins - they cannot be loaded into the ARM binary of GP.

As @rank13 pounded out - right click on your and select “Info” then TICK the box titles “Open using Rosetta” to make sure that INTEL version is opened on your ARM computer.

That should allow you to load your Intel only plugins normally.

1 Like

Someone needs to confirm whether the PA Installation Manager is actually installing Apple Silicon versions of their plugins or not.

1 Like

I have just installed the GP4 Unlocked Version from PA on my MacBook (late 2013, macOS Catalina). I have found only one installer. I could activate the version in contrast to the Windows version.

And it works fine, I could load my GigFile, no red plugins. I had to change some General settings and I had to change some AU to VST (for example Keyscape), but then I could play the whole Gig without problems.

1 Like

Of course. Everything in that scenario is Intel based so there are no compatibility issues.

1 Like


here,…screenshots, both the same, different zoom ( Info is in german language)


Huh, i posted to early, my brain missjuggled something, BUT:
it finally is it, indeed !
i checked that checkBox, and GP4 is loading now all my VST/VST plugins used in that particular Gig.

Problem solved !
Very Much thanks to everybody, especially @rank13 with your invaluable help.
( i will edit now my inititial post again, adding some lines on top)

1 Like

Well kinda — you are running GP4 under Rosetta and it won’t run quite so fast but perhaps good enough.

hmm,…vs. the Reason DAW, the developer says you should not mix and match arm64 ready plugins with the intel ones.

So, thats ok how it is, …i´d guess.
And i´m used to run GP under Rosetta.
Fact is: the M1macs are affordable, especially the M1mini, and the capabilities with GP3 is allready stunning !

AND: you can run several GP instances in parallel ! for example the “instrument/initial Sound making” Rack in one instance, and another one for the (complex) FX processing.
I had to do this to run big "patches (Rackspaces) with low buffer sizes ( i stick now allways to 128 samples)
one thing: my TB3 audio interface has noticeable less latency than for example my NI kontakt 6.
I also run my Bass sometimes roundtrip, thru fat patches, and the latenzy is absolutely ok.
The Amp simulations ( PA) do add some latency. So you want to have a super fast AI to keep things still within reason.
The M1 mac is awesome, even under Rosetta !
But its Gigperformer to unleash now all that power we allready have given with all those VST/AU plugins.
It opens up such a huge world !!!

I have several plugins that are arm64 ready.
i will make some tests to see. But it might take a while.
Hope i can bring a FAT patch together to make some hi CPU load tests, Arm based vs. Rosetta.