Roland Zenology Plugs Out Of Pitch (sample rate?)

I know there was another thread about this, but saw no definitive answer to it. I am finding that often - not always - adding a new Roland Zenology instance/sound or sometimes switching from one rack space to another where there are Zenology plugs, one of the Zen plugs is out off pitch - likely a sample rate issue. Sometimes going into audio settings, re-setting, and saving/updating will fix it, but what I have to do most of the time is quit and restart GP. At that point, things tend to stabilize until I add another one.

I’m running at 44.1 and 256 samples. Someone had speculated that while Zen plugs will run at 44.1, they default to 48 maybe? Anyone have any experience/advice on this. I’m going to be using LOTS of Zenology sounds, so I have to get this one figured out. In the middle of a gig, this would be awful!

This users told us the issue was solved with a sample rate of 48kHz. Could you please test this and confirm? Of course this answer wouldn’t satisfying as any plugin should adapt to the current sample rate of the audio interface.

I’ll have to set that tomorrow and try. I do not have the fastest computer in the world, so trying to keep CPU down.

This is driving me freakin’ crazy! There is no rhyme or reason to it, no repeatable steps to reproduce it I can find, and yet - it happens. I spent a full hour yesterday trying to get it to reproduce. No luck. Later just goofing around - all of a sudden it does it! Most of the time when I first boot up and open GP - no problem. Today I opened one time, and every single rack space with Zen in it had the problem! Other 5 times I’ve opened it today - no issues! LOL! Here are some “clues” - and I’m not sure they are very consistent.

  1. It seems to occur more often after adding/editing a Zen plug and then bouncing around between rack-spaces.
  2. I’m not sure - but I think if I can pick a rack space where no ZEN plugs are unloaded (all get unloaded by predictive loading) and then reload a zen patch - it seems to “fix it”. I’m going to pay attention to this trick when it happens again - and it will!
  3. At other times, re-applying audio settings seems to fix it. I don’t like this method.
  4. If it is happening - quitting and re-opening GP will often fix it.
  5. Once it gets “fixed” in a session - it seems to be OK from then on. I’m sure there have been exceptions to this, but for the most part - that’s true.

FWIW - I tried to run at 48k and my system really doesn’t like that - get a lot of noise on a couple patches - building up until I have to panic (dbl click panic) out to save my speakers! I’m staying at 44.1 thank you.

FYI - I am cross-posting this in the Roland Cloud Forum on FB.

Thanks for this feedback, please go on posting here if you find something new. This is really strange… :face_with_monocle:

Could you please follow this guideline and provide us the regarding information, and maybe also upload your gig file?

You haven’t told us anything about your system so far… or what other plugins you use besides the Roland ones.
I could have a look at it and i’d like to try myself if something like that happens in my machine.
Thanks. :beers:


I appreciate what you’re saying - but I’m not the only one having this issue, so pretty sure it has nothing to do with my system, gig file, or other plugs, and everything to do with the interaction somehow between GP and Zenology. No other plugs are affected this way. Are you running Zenology?

I think Zenology is part of the Ultimate subscription… so, yes I do.

  1. Who else is having that issue?
  2. With respect, please don’t make assumptions around what might be the cause and help us to help you by answering the questions that were asked. As the well known author Arthur Hailey once wrote, “Mistrust the obvious”



Sorry - not trying to be dismissive - but having been a software developer/programmer for 40+ years, I’m usually pretty good at narrowing things like this down.

I’m Windows 10 on an ASUS Vivobook 4 core x2 (hyperthreaded). 20G RAM. I’m using a Scarlett 4x4 USB interface - a brand new one - forget the model right now.

There was one other user/thread referenced above that had the problem, and at least two more have spoken up over on the Roland Cloud FB forum - including at least one who is active here too.

It happens with the Zenology plug-in - doesn’t seem to matter what patch/tone is selected or if there are other instrument plugs involved in the rackspace. MOST of the time I have noticed it it is with other plugs, but that’s likely because that is what I’m messing around with. It does help make the pitch difference obvious.

I’m 99%+ sure it is a sample rate issue. I run at 44.1 and it sounds to me as if the Zen plug is not (always) getting the message and sometimes wants to play at 48? Again - I can not find definitive steps to reproduce it. My best suggestion is to set up a few rackspaces with a couple Zenology instances in it plus maybe another plug or two. Then just bounce around them either directly or via associated set-list songs - that’ what I usually do. Make sure to be at 44.1 on your audio options. I run 256 buffer.

1 Like

Ok, that’s an information base which is helpful, thanks for that. :+1:
And believe me or not (and please don’t be offended): I don’t give anything on people’s background when they emphasize how long or how successful they’ve been in their (mostly) IT jobs. Because despite of all this, those people are here to ask for help.
And so very often, we always have to ask again and again for some details, so that we can understand the problem and have an idea of what to do to reproduce it.
Anyways, now that i got the information, i will see if i can reproduce this issue.

1 Like

Were both of those Gig Performer users?

And it doesn’t happen with other plugins — that suggests strongly that the Zenology stuff has some problem and Gig Performer is merely exposing it (GP tends to push plugins much more than DAWs).

1 Like

that suggests strongly that the Zenology stuff has some problem and Gig Performer is merely exposing it

I agree and have never suggested otherwise. However, I think it would be great if we here (or the GP devs) could figure it out and maybe I would have something to tell Roland. There’s a dog and a tail thing at work here :wink:

Were both of those Gig Performer users?


Great, so, you should have the skills to set your system at 48Hz and verify if the issue disappears or not. :wink:
It could perhaps validate the theory of a default value at 48KHZ that would be reset by mistake in circumstances that would then remain to be determined.

Definitely! :wink:

I think the only user who complained was @ahutnick here:

Do you know other users in the GP community faced to this issue?

Here is the link to the Facebook post. You may have to be a member of Roland Cloud to see it. Two people who responded over there were Dave Boulden and Lars Altvater.

Hi @ahutnick, @DaveBoulden and @larsalt, you guys are invited to the big party here! :partying_face:

It will be a pleasure to see you contribute to this topic with you own findings regarding the present issue. :wink:

@kbmatson, reacting to this si also a way to help :wink:

LOL! You would think huh? :wink:

I’ll give it another try when I get the gear set back up - stuff is packed for gig at the moment.

1 Like

I stopped subscribing for the Roland plugins a while back and yes changing to 48000 solved the pitch issue. Obviously Roland hasn’t fixed the issue yet