RME Digiface Dante and number of inputs/outputs

I’m demoing Gig Performer for FOH with a major band with an Allen and Heath desk with a dante card. The Dante card feeds my RME Digiface Dante which is basically a Dante to USB sound-card which I connect via USB to my Macbook.
All good. It works. But the Digiface has 128 inputs and outputs which is slowing Gig Performer down when selecting Options (several minutes to open). So what I did was unselect all but 32 inputs and outputs in the Audio preferences in Gig Performer. All good and things speed up considerably.
However when I quit and re-open …the 128 inputs and outputs are all selected again. So I have to laboriously untick each one ,one by one.

  1. Am I doing something wrong not to get the audio preferences to ‘stick’
  2. Can there be a way of selecting multiple inputs or outputs in the audio preferences so that one can untick en masse? Shift click does not work.


Which options did you select exactly, the audio options?

The General options then Audio. But it’s the same for any option.

Actually it’s the Recording option that kills it, but if I go in to Options through General it’s the same.

We are talking about this options window?

I did a test with loopback and 32 virtual output channels.
I deactivated output 17-32, closed Gig Performer, started GP again and in the options output 17-32 still disabled.

BUT: when GP is opened while the interface (in my case loopback) is not active and then the interface goes on => all outputs are selected again.

In your case: The Interface was active when GP was opened again?

Another test: I switched from loopback to the internal soundcard and back again => all channels have been enabled again.

Are you sure you pressed the red “Apply Settings” button after your changes?

You means it takes minutes to access any options?

Yes, that’s correct

No, that’s weird :thinking:

Yes I hit apply.
The problem is the Recording option tab. It is basically unusable. I get the spinning wheel constantly.
Has anyone used GP with 128 inputs and 128 outputs- perhaps it’s just too many. That’s why I tried deselecting half of them in the Audio options and though this was painful- one tick at a time! it did help. However I cannot do that all the time…I’ll do more test.

Unfortunately I use only the 16 inputs and 16 outputs of my RME UCX, and of course no issue with that.

OK thanks anyhow.

So I have unticked 192 ticks !! in the Audio options to get down to a 32 input/32 output Dante set-up. I then quit and re-opened and it has retained that set-up. All good.
However it takes 15 secs Options>General and then another 15 secs to open the Recording options tab.
Alternatively if I try to go directly Menu>Recording it takes 30 secs (which figures)

This workable… as long as GP remembers the unticking of all those boxes in the Audio options.

OK so I tried pulling the usb lead live…not good I know …but in fairness GP just dealt with it really well and I still have only a 32 in 32 out Dante set-up…pianopaul maybe you were right and I forgot to hit apply! :grimacing: :rofl:

Improving this stuff is on our list but it wasn’t that high a priority as typically people are only recording a few channels.

Watch this space!


Thanks everyone- this kind of support is a huge factor in making a decision about purchasing and using.
All best


I guess a relatively easy fix in the short term to make working with large Dante streams is just to have a ‘All’ or ‘None’ select option in the Audio options just like there is the the Recording options? Just a thought…


@andyp - this is definitely on our list of improvements. Can’t promise when will we get to it, but it’s definitely on the list which means we’ll deal with it eventually.



Yeah, I’ve implemented something similar to this yesterday - it will be in the next released update.


That’s great. :+1:

running dante here with d-live and sq 7
what i do not understand is why having a rme “in between” the ah and your computer.
coz i am pretty shure there is a bottleneck made from dante “down” to usb.
pretty shure you have your reasons.
in my case (as said dante from ah straight to the pc) i just activate 32 channels in dante network (dvs)
therefore only 32 audio devices appear in gp4 or in any application on my pc…

ps to the devs
maybe a “lock audio interface” and “lock midi interface” option would do
as well for the purpose

  • soundcheck n` stuff done
  • i`m in the hotel with my laptop and make some changes, and of course i dont want to take my (whatever) interface with me.
  • with the option “lock audio interface”/“lock midi interface” on i get no sound but i do not create a mess if it is a complicated setup according to routing…
  • if you call me a weirdo now, i do in fact agree…