Refx Nexus 4 suddenly crashes GigPerformer

I’m on Mac M1 and have the Plugin reFX Nexus 4.

I have 6 rackspaces with this plugin (VST). Today in rehearsal it works, in our rehearsal room we have no internet. Back home I tried to open GigPerformer on my MacBook, it crashes immediately. The report says “Thread 0 crashed” and then something with Nexus. So I deleted all rackspaces, that use Nexus with an editor and I could load my gigfile.

When I try to use Nexus (newest version) AU, VST3, VST Gigperformer crashes and Nexus sends a report to reFX (“nexus has crashed your DAW, will you send a report?”).

I can not understand this issue, there was no update and nothing between Rehearsal room and my home.

Tomorrow I’ll try to reinstall Nexus 4.

Would be awfully nice to actually see the full crash report!

This? (5.8 KB)

Yes - unfortunately you don’t indicate whether you’re using the Deskew build or the Plugin Alliance build.

The crash is definitely happening inside the Nexus plugin. Assuming it’s the Deskew build, then it is happening when GP is loading the plugin and sending the saved state to it. The plugin does not seem to be handling it properly

Thread 0 Crashed:: HotFudge Dispatch queue:
0 Nexus 0x13ede57c8 0x13e910000 + 5068744
1 Nexus 0x13e9fe228 0x13e910000 + 975400
2 Nexus 0x13e9fe228 0x13e910000 + 975400
3 Nexus 0x13e9fd6bc 0x13e910000 + 972476
4 Nexus 0x13e9e4a10 0x13e910000 + 870928
5 Nexus 0x13e9e0050 0x13e910000 + 852048
6 Nexus 0x13e9dfc80 0x13e910000 + 851072
7 Nexus 0x13e91ed74 0x13e910000 + 60788
8 Nexus 0x13e91ec34 0x13e910000 + 60468
9 Nexus 0x13e9196a4 0x13e910000 + 38564
10 GigPerformer4 0x10522c2d0 0x104c60000 + 6079184
11 GigPerformer4 0x105026af0 0x104c60000 + 3959536
12 GigPerformer4 0x1050288b0 0x104c60000 + 3967152
13 GigPerformer4 0x105110494 0x104c60000 + 4916372
14 GigPerformer4 0x10510c7b8 0x104c60000 + 4900792
15 GigPerformer4 0x1053d2ed4 0x104c60000 + 7810772
16 GigPerformer4 0x10515b8a0 0x104c60000 + 5224608
17 GigPerformer4 0x1050c06d0 0x104c60000 + 4589264
18 GigPerformer4 0x10529fac8 0x104c60000 + 6552264
20 CoreFoundation 0x1a2aad99c __CFRunLoopDoSource0 + 176
21 CoreFoundation 0x1a2aad70c __CFRunLoopDoSources0 + 244
22 CoreFoundation 0x1a2aac310 __CFRunLoopRun + 836
23 CoreFoundation 0x1a2aab878 CFRunLoopRunSpecific + 612
24 HIToolbox 0x1ac18bfa0 RunCurrentEventLoopInMode + 292
25 HIToolbox 0x1ac18bde4 ReceiveNextEventCommon + 672
26 HIToolbox 0x1ac18bb2c _BlockUntilNextEventMatchingListInModeWithFilter + 72
27 AppKit 0x1a5d3184c _DPSNextEvent + 632
28 AppKit 0x1a5d309dc -[NSApplication(NSEvent) _nextEventMatchingEventMask:untilDate:inMode:dequeue:] + 728
29 AppKit 0x1a5d24e0c -[NSApplication run] + 464
30 GigPerformer4 0x10512f494 0x104c60000 + 5043348
31 dyld 0x1a26a3e50 start + 2544

Thank you!

I have both, but I use the Deskew build.

One hour ago in the rehearsal room it works.

Tomorrow I reinstall Nexus 4 and I try to connect their support.

Good night, it is late in Germany… :wink:

then it is certainly related to restoring the state - the plugin is doing something funky — you’ll have to provide the crash report to the Nexus developers

I was in Germany at the beginning of the week and it was not that late… :thinking:

1 Like

Are you a night active man?


No, but after rehearsal I can’t sleep immediately. Because of “Schienenersatzverkehr” I took my overtime as vacation and it snowed … it could have been such a nice evening, until Nexus crashes GigPerfomer.

Well, musicians are often night active :wink: :innocent:

Yes, and not only musicians. reFX was active too, they just updated Nexus 4 and now it works with my GigFile. Problem solved in so far.

Very strange, I hope that such an issue never happens before or during a live gig.

Perhaps I should work on a backup on my Kronos or on my Ipad (with Aum oder Camelot). :thinking:

1 Like

You could use a 2nd instance of GP as backup

That does not help when a Plugin suddenly fails.

Why not?
When the main instance crashes, you can switch to the 2nd instance.
Or do I miss something?

Sure you have to setup the 2nd instance not to react on your controller, rig manager is your friend.

In this case the second instance would also try to load Nexus (or whatever plugin crashes) and fail.

Perhaps I could use a second Laptop with Windows and GP.

When you have a crash in loading the plugin then you are right.
I thought of a situation when a plugin crashes while playing …

Can you please test this more and definitely confirm that a plugin update solves the issue?

What shall I do?

Yesterday my Gigfile crashes every time, I have uploaded the crash report in this thread. I loaded an empty Gigfile and loaded Nexus 4 - the Gigfile crahes and Nexus 4 says, that it has crashed my DAW and wants me to send a report.

Today I want to reinstall Nexus 4 but there was an update (Vers. 4.5.4 to 4.5.5). Yesterday there was no update. I updated Nexus 4 and my normal Gigfile with 6 Rackspaces, that use Nexus 4, works. I tried every rackspace and had no issue.

Don’t use a plugin that crashes!

1 Like