Plugin Manager can't initialize Ivory 64-bit

Here is the message I am getting from Gig Perform’s Plugin Manager:
“Deactivated after failing to initialize correctly”

I was able to instantiate and use Ivory in Ableton Live with no problem. i checked it out in Live and it said it was 654-bit.

Did I miss the memo?

Here are the Plugin Manager trees I used ->

VST3 Tree:
C:\Program Files\Common Files \VST3

VST Tree:

In what folders can you see the Ivory DLL?


I see this path you use for VST and VST3 plugins

Maybe that is causing the problem?

I upgraded to the 64-bit Ivory II last night, but the installer never put the plugin into D:\Steinberg\VSTPlugins64. Instead, it placed it in D:\Steinberg\VSTPlugins which is typically my 32-bit plugin folder.

When I opened the plugin from D:\Steinberg\VSTPlugins in Live it worked fine and said it was 64-bit.

Ok, please delete this entries "“Deactivated after failing to initialize correctly”
in Rig Manager and start the scan again.

The scan did not validate because Gig Performer only works with 64 bit,
Seems that the last scan marked this 32 bit plugins as failed.
As long as plugins are marked as not validated they are not scanned again,
Therefore you have to delete this entries and scan again.

Humm, I have Ivory 2.5 installed in a custom directory. It is not the latest version, but I could specify the installation directory. I only installed the 64bit VST which is the only one I use. Regardless of what a third party DAW « says », are you very very sure you installed the 64bits version and not the 32bits ? I would check it twice…

Do you know for sure that that version is the one Gig Performer is finding?

I may have found the problem. The Ivory VST.dll was installed outside of the Synthony folder. I just moved it into the Synthony folder and will try to see if Plugin Manager grabs it this time. Give me about 10 minutes…

Nope, it still didn’t work. Here is my file folder with the 64-bit .dll

Are you sure that only valid 64Bit DLL’s of Ivory exist in all paths?

This is outside the folder tree structure you posted in your first post as D:\Steinberg\VSTPlugin64 is NOT on any of your lists you shared with us. Are you sure that this folder is in the Gig Performer’s search path list for VST2 plugins?

Please open the Plugin Manager window and make sure you paths are correct. Then rescan again or if the path was correct - can you find “Ivory VST.dll” at the bottom of the plugin list marked red? If you can - try selecting the option to rescan failed plugins or remove it from the list manual and scan again.

OK, I fixed my problem. Even though Ivory VST.dll is a 64-bit plugin, it belongs in the 32-bit folder. In my case, it goes into - D:\Steinberg\VSTPligins\Synthogy

Also, the structure of the folders must be exactly the way they like it. If anyone is having trouble with GP recognizing this new 64-bit version, just ask me and I will help.

1 Like

I am happy that your issue is solved, but I am surprised about that, as I use a custom defined directory with my Ivory VST and have no problem with that. :thinking:

I do that as well ( change the ‘library path’)… but you can only do that once you have it working! :):):slight_smile:

Why? And what did you do to make it work?

Evidently, I had the old .dll (32 ibt) in the VstPlugins. Once I moved the 32 bit .dll to the trash and move the new .dll (64 bit) into VstPlugins, it worked. Someplace along the way, I got my fingers crossed when I was trying to get clean up my disk and delete older plugins that were not 64-bit.

Ok…that makes more sense.

OK, now I agree too :wink: