OSC routed from local to global rackspace


what is the best way to route OSC from local to global rackspace for playing instruments?

My idea is to have some most important instruments in global rackspace (e.g. Pianoteq and Kontakt) and be able to reach them from local rackspaces. Typically, not to have dozens of local Pianoteqs for the same sound…

I have tried to specify MIDI OSC IN ports in global rackspace, (e.g. named PianoteqOsc and KontaktOsc), connected to one Pianoteq and Kontakt instance placed there.

In local rackspace, MIDI OSC OUT was created, meant for connecting to dedicated MIDI OSC IN in global rackspace. Like this: OSC address “/PianoteqOsc/Midi”, IP “”, port 54321.

Gig Performer listening port is set to 54321.

Interestingly, in one gig file it works, in the other one (with a lot of more rackspaces and GP scripting) - sometimes yes, sometimes no, rather no.

Is this the only way to do it? Or, is there something more elegant? :slightly_smiling_face:

Thank you very much


In the OSC Options you see the port Gig Performer is listening.
In this case 9001

Now put in the OSC Address of the MIDI Out (OSC) plugin
for example /midi_osc/MIDI
and the port 9001

In the global rackspace include the MIDI In (OSC)
and give it the OSC handle midi_osc

From the above it seems that port 9001 IS the GP listening port? Or I’m missing something…?

Anyway, this was exactly what I was doing. It worked in test small gig file, but in the larger one sometimes I “get the signal” (playing works), sometimes not, it is dead. Everything else being equal. Could it be somehow affected by GP scripting?

Update after further scrutiny:

I have realized that GP switches off receiving all incoming OSC (but not outcoming) messages under certain conditions. One can’t send anything as OSC message in either from local rackspace to global rackpace or externally via TouchOSC etc. Transmitting OSC messages from GP out works (confirmed via Osculator app).

It happens in large gig file with 84 rackpaces and vast global rackovský, not in small test gig file with 2 rackpaces.
I have tried to reconstruct this gig file by adding songs one after another, the bug starts to appear after adding 60 songs or so.

Everything other within GP seems to be ok - it does play and behaves normally.

Could anybody help, please? :slight_smile:

I think the normal issue with receiving OSC is when GP can’t open the listening port. I know I always have to be careful when using monitoring apps that they don’t open the same port.

Does this issue occur only when starting GP, or does it stop working after a while when GP is open?

The issue seems to be dependent on number of rackspaces in a gig file - with smaller ones (up to 50 or 60 rackspaces) it works well. The listening port doesn’t change at all. I have listening port always set to 54321, in all gig files.

When I start load large gig file, it doesn’t work right from the beginning. A connection of other apps etc. probably has no influence.

It shouldn’t be. How did you determine this?
What version of GP are you running?

The latest one, 4.5.8, but it started to appear with previous version as well (4.1.5 I think).

Do you have a stripped down gig where the issue occurs?

You can check it out here…
Binge new OSC.gig (8.0 MB)

Thx, will check

Thank you :slightly_smiling_face:

I played all rackspaces and watched the MIDI In in the global rackspace for Blue3 and Pianoteq, all was working fine, no issue.

But for what this script?

On SystemEvent Matching GigLoaded

    var count : integer = GetRackspaceCount()
        system_time : double = 0 
        check_interval : double = 1000
        i : integer

    for i = 0; i < count; i = i+1 do

        system_time = TimeSinceStartup()

        while TimeSinceStartup() < (system_time + check_interval) do
        // wait
1 Like

Ouch, that loop will suck up CPU

Maybe he thinks that when a plugin is loaded and removed (because of using predictive load) the next time is has to be loaded, it is much faster?

And there is something strange:

GLOBAL RACKSPACE: Program change was sent to Triton (MSB 0, LSB 2, PC 15)
Pianoteq 7:Galway girl failed to load.
Kontakt 4 8out:Galway girl failed to load.
TR5 CSR Room:Galway girl failed to load.
GLOBAL RACKSPACE: Program change was sent to Triton (MSB 0, LSB 1, PC 8)
Blue3:Frantisek failed to load.
Kontakt 4 8out:Frantisek failed to load.
OrilRiver:Frantisek failed to load.
GLOBAL RACKSPACE: Program change was sent to Triton (MSB 0, LSB 0, PC 11)
Kontakt 4 8out:Fields of gold failed to load.
Ambience:Fields of gold failed to load.
GLOBAL RACKSPACE: Program change was sent to Triton (MSB 0, LSB 0, PC 24)
Pianoteq 7:Feeling good failed to load.
Kontakt 4 8out:Feeling good failed to load.
Ambience:Feeling good failed to load.

This messages are logged when I switch the song in SetList Mode

But when I switch to the Rackspace Feeling good in Rackspace View, no message appears

This is for loading GP Presets of plugins placed in the Global rackspace. Because you don’t have these presets, it gives you an error. Loading GP Presets worked always flawlessly for me.

You really use Kontakt4?

Basically yes, I have better luck with doing this, because without it sometimes I’ve had short glitch on few first notes in each rackspace.

Why do you think so? It runs just once in the start, it shouldn’t make anything later…