Multiple Instances and Midi Controller Issue

I tried to set 2 instances of GP, one for each keyboard I use.

The first instances works well.

The problem is that my second instances seems to not be able to receive any midi data from either keyboard and controller. All my midi keyboards and controller are detected and checked in both instances midi settings.

Other problem is syncing the tempo. I use tap tempo widget in my first instance and I want my second instance to follow along whenever I change the tempo in the first instance.

I use specific midi in blocks. So in one instance I use Roland RD64 and in the other Samson Graphite 64.

Could anybody please help? Thank you.

For the MIDI In Problems of the 2nd instance

Did you check this in the options of the 2nd instance?

For the tempo, did you enable Link in both instances?

Thanks, the tempo problem is solved. My bad, I didn’t see the solution in plain sight.

About midi setting, I don’t understand it yet. And for now I can not see anything in my midi port setting because my gear is not with me right now. Can you explain a little bit. Sorry for my many question. I am not so familiar with this kind of things.

ps. I am using windows, not mac.

For the MIDI ports (and that is the same on Mac and Windows)
You have to enable all MIDI Ports Gig Performer should be able to use.
That is for the Input and for the Output.
When your devices are physically present you can enable them and Gig Performer remembers your choice.

That is checked. All port available is checked and all my gear are listed correctly. But the second instance didn’t receive any midi data.

Be aware that settings have to be done for each instance.

All port enabled in both instances. Maybe it’s because all is checked/enabled? Do I need to enable only the specific controller for each instances? Like my Roland for Instance 1 and Samson for instance 2?

I am not aware that this must be done this way, just try.

By the way, what can you see in the global Midi monitor in both instances?

Do you mean this?image
In second instance it showed nothing when I tried to press keys or buttons on my controller.

No, I mean this:
Bildschirmfoto 2020-07-30 um 16.02.16

Tomorrow, I will try again, and I will take some snaps of the screen so you can better comprehend the situation. It’s already night time here, and my gear is in my church.

Thanks a lot for your help. See you.

Where are you from?

Some users don’t provide much info… not the case :wink:
Just click on the “logo” in this case D

I am from Indonesia.

:smiley:

1 Like

I tried once again today. When I finally assign specific midi controllers to a specific instance, it works. So, supposed I have 2 midi controller: A and B. To control first instance of GP with A, I enable it in first instance and disable it in second instance. Then I do the opposite for B.

Seems like I cannot use one midi controller to operate two instances simultaneously. I don’t know if it’s the limitation of my controller driver or the GP itself.

So, looks like the problem solved. Thanks everybody.

This is a typical limitation of some MIDI drivers under Windows. But you can you something like loopBe1:
https://nerds.de/en/loopbe1.html

The idea is to authorize your MIDI controllers only in the first GP instance, and send the MIDI messages you need from the first instance to the second using loopBe1.