Multi-client driver nanokontrol2


the new machine seems to work very well so far. I am still not ready with setting up GP
to the same status as it was on the previouse computer.
I currently have problems with the integration of the nanokontrol2.
It will be recognized from the first instance, but another instance which I use is not recognizing any signal coming from the nanokontrol2…
I guess it is again a problem with multiinstance drivers… but it was working on the older Computer in three different instances (one main and two additional) paralell.
If somebody has an idea…


Download the Nanokontrol2 windows 10 driver from Korg. If you haven’t installed the driver yourself Windows is probably using its default midi driver, which is not a multi-client driver.

Downloads | nanoKONTROL2 | KORG (USA)

1 Like

This driver is installed already…

Can you go into the windows Device Manager and scroll down to the “Sound, video and game controllers” line and take a picture of what it shows? Like below.


Hello @Vindes,

I am currently not with the machine, in two hours I will do!

I am running Win11 on the new machine, just as Info.
May that is the reason I do not get it running in more as one instance.

I thought the Korg midi driver would be multiclient capable, but maybe it’s not.

When it’s not multiclient capable then the first instance that grabs it will keep the others from getting it. Do you need it to send to multiple instances at the same time?

I see you’re running Bome midi translator. Do you have the pro version or just the free version? If you’re running the pro version you can turn the nanokontrol into a multiclient version by creating virtual in and out ports with Bome and connecting your GP instances to the virtual ports and have Bome route the virtual ports to the real nanokontrol ports.

I’m not sure why it would have been working fine on your last system and not the new one, though.

Hi Vindes,

it was working on three instances paralell with the same gig as I am using now.
New computer, win11 instead of win10.
I think the Bome is the OSCBridge. In any case I will not increase the complexity
of my current set up. As I can see now, the moving to a new computer is not as easy as I thought.
OSC will be the next I have to check if it is still working… No time left to make music…
Thanks for your help.

Thanks for the above link to the other Korg NanoKontrol2 thread!
It could be that I used MidiOx as well as loodmidi to get it working. :shushing_face:
In any case I will try it tonight, I guess it will work with this two little programs.

Why don’t you try this: Sending MIDI from one device to multiple programs

(MIDI OX is very old)

1 Like

OK, I will see.
May just LoopBe is enough for me, but I have to try…

I followed the instruction in the link, it worked!
In loopMidi I created for each Instance one virtual midi device.
In the MidiRouter (TXL) I connected the nanokontrol2 (as midi-in) to the four midi devices (midi-out…)
for each instance.
I had no time to check if it worked seamless, but
in all instances I opened parallel the nano signal was recognized!.
The loopmidi is on auto start and opens with the booting of the PC, the MidiRouter I had to start manually before starting GP.
So far, so good!
Will keep you updated!

I put the MIDI Router on the PC in the Autostart, now the set up starts with the booting of the PC.
In GP it’s working now in all instances parallel.
Only the LED’s at the nano are not showing the current status; the setting in the nano is on “External”.
May I have to set up the MIDI Router with the reverse connections as well…
I will try next :wink: