Losing midi connection when clicking "Midi Ports"

Ok, but I use the TD27 just in the first instance, in the second and third instance the TD27 is not checked in the midi settings.
The second instance is just for mics and has connection to my NanoControl, the third is for the E-Guitar, just controlled by a midi food switch.
All three have to react on my Keyboard (Roland RD2000). Could it be a midi through setting of the Keyboard?
I am on Win10, the laptop is just and only there to run GP and is completely stripped down for Audio (and works well, with a lot of load, as the whole band is running through GP).
The „problem“ is not a „show stopper“, but I would like to minimize the chance of an interruption during a Gig…

So, if I understood correctly, TD27 works great in the first instance and if you open the MIDI Ports options in the second instance, the MIDI connection is lost in the first instance?

The root cause is definitely the (single-client) driver (I immediately suspected on your driver) so when the second instance queries for available MIDI devices, the first instance loses the connection.

I’m not sure if this behavior is the same for all single-client MIDI drivers, but if it is, perhaps devs can do something about it (e.g. implement a button that manually lists available MIDI ports, don’t know, just thinking out loud).

Yes, it is like this.
Why is the midi connection “shut down” in the first (main) instance if I open the „Midi Port“
Window? That is the reason why another instance is grapping the connection, for no reason, because I did not tell another instance to connect…

If I were you, I’d try the same gig file with a different computer and a keyboard to test if this is a universal behavior for single client MIDI drivers.

I will try.
Could be Midi-OX the correct tool too route the midi signal from the TD27 to all three instances?
Anybody working with it?
Flodder

MIDI-OX is very old (älter als der Böhmerwald).
Perhaps try with AudioGridder (see this blog) or Blue Cat’s Connector (see this blog).

Or what I mentioned, send MIDI to the virtual MIDI device which is available in multiple clients. I never tried that, but I saw people discussing it.

1 Like

Thanks @npudar ,
but I do not want to run the TD27 on more as one instance, I just check it in Midi Port settings in my main instance.
How should the multi -client midi help?
RG
Flodder

I tried today again with loopMidi and Midi- Ox and other Midi helpers, no success…
If I open in the main instance the “Midi Control”
and a second instance is running, the incoming midi signal will be not used (in the main instance), after leaving the “Midi Control” anymore.
The midi in lit is shining green, just in the main instance, but is not in use anymore.
For me it is an GP bug…

No it isn’t, It comes from the limit of your MIDI driver which is not multi-client. When using a non multi-client MIDI driver you have to disable this MIDI port in all GP instances, but the one where you want to use it. Also don’t use third party apps like MIDI-Ox at the same time, because if it opens the MIDI port it will be missing somewhere else. In fact it is difficult to predict what a non multi-client MIDI driver will do if several applications or instances of an application try to use it concurrently. So, dont do that :nerd_face:

2 Likes

Thanks for the answer @David-san , but,
I just use and want to use the device in one instance,
I do not want and need it in the second and third instance and the device is not chosen in this instances.

Even if you don’t use it, if you don’t explicitely block it in the GP global options menu of each of the GP instances where you don’t need it, GP will open the port and make it possibly available to you. At the time GP opens it, we don’t know how the non multi-client driver will react. So, now that we could figure out that this MIDI port driver is not multi-client, please block it in all GP instances where you won’t use it and tell us if it works better for you.

OK, how I can block it?

Hi Paul,

as explained before, it dosn’t make a difference of if remove the tick, I guess I have to work with a midi filter?. I have to check if I can un-Allow the TD27.

The MIDI Filter is after the physical device, so it will not help in your case.

OK, any other way to block it for nothing else as the main and first opened instance?
Thanks
Flodder

MIDI Port Options.

They are off in the Midi Port “Option”…

Can you show the settings for all your instances?
And you only started GP and no other program which could use your MIDI Device?

@npudar is probably right, it could be that in the particular situation of a non multi-client MIDI port driver, opening the MIDI options could be an issue. So, once you configured everything, don’t do that anymore.