Losing midi connection when clicking "Midi Ports"

No it isn’t, It comes from the limit of your MIDI driver which is not multi-client. When using a non multi-client MIDI driver you have to disable this MIDI port in all GP instances, but the one where you want to use it. Also don’t use third party apps like MIDI-Ox at the same time, because if it opens the MIDI port it will be missing somewhere else. In fact it is difficult to predict what a non multi-client MIDI driver will do if several applications or instances of an application try to use it concurrently. So, dont do that :nerd_face:

2 Likes

Thanks for the answer @David-san , but,
I just use and want to use the device in one instance,
I do not want and need it in the second and third instance and the device is not chosen in this instances.

Even if you don’t use it, if you don’t explicitely block it in the GP global options menu of each of the GP instances where you don’t need it, GP will open the port and make it possibly available to you. At the time GP opens it, we don’t know how the non multi-client driver will react. So, now that we could figure out that this MIDI port driver is not multi-client, please block it in all GP instances where you won’t use it and tell us if it works better for you.

OK, how I can block it?

Hi Paul,

as explained before, it dosn’t make a difference of if remove the tick, I guess I have to work with a midi filter?. I have to check if I can un-Allow the TD27.

The MIDI Filter is after the physical device, so it will not help in your case.

OK, any other way to block it for nothing else as the main and first opened instance?
Thanks
Flodder

MIDI Port Options.

They are off in the Midi Port “Option”…

Can you show the settings for all your instances?
And you only started GP and no other program which could use your MIDI Device?

@npudar is probably right, it could be that in the particular situation of a non multi-client MIDI port driver, opening the MIDI options could be an issue. So, once you configured everything, don’t do that anymore.

It’s a bit different:
If I just run the first instance, in which I use the TD27, I can open and close any window and have no issue (as it seems).
If a second instance is open and i open the “Midi Port” in the first instance, the TD27 is quiet, as well after closing the midi port window. The midi is reaching the first instance, as the green midi light is litting (paralell to the orange one below…) but no sound of the TD27 (which is in each rackspace).
If I now close the second instance and once midi panic in the first instance, the sound is back again.

I hope it’s clear now.
If somebody is interested to see it we can exchange mobile nb. in a privat chat and go through it via video call.
I will be with the system this afternoon 6:00pm CET (Germany)

Could you post a screenshot of the Globale MIDI monitor of a note played at this exact time?

And you are very sure that the MIDI port corresponding to your TD27 has been blocked here? ANd of course you didn’t open the MIDI port settings of the second GP instance while a first GP instance is started, right?..

I will do this afternoon!

I can not say if it is blocked, I can say that the tick at the TD27 is not set.
If I open the Midi port setting at the second instance it makes no problems, just if I open it in the first instance, if the second instance is open…

For both the TD27 input AND output ports?

Yes, sure

I will upload some photos later, no other software running.

Gray is main
Red and Green, second and third



Nanokontrol in all instances?