Losing midi connection when clicking "Midi Ports"

Hello specialists,

on my win10 with GP4 I face following problem since monthes.

After some “settings” in GP our E-Drum TD-27, which is connected via USB/Midi,
was not triggering sounds anymore. On incoming messages I saw the litting of the little green light, paralell to the orange one below.
I thought it would be the cable/ hub/ win and checked and exchanged everything.
I run “USBDeview” to eliminate/ deinstall all not used, from win stored, old usb connection etc…
Yesterday I figgured out what is causing the “disconection”.
If I open “Midi Ports” the TD-27 becomes quiet, when I close the page"Midi Ports" nothing happens, the TD-27 is still quiet. Midi reset dosnt work, repluging the midi cable dosend help. It just works again if I shut down GP completely and start it again.

The related link to download the gig file is attached


Thanks in advance!

Do you use a MIDI to USB adapter?

To me this looks like a driver issue. To experiment, see this thread: Loop MIDI ports not automatically discovered on Windows - #8 by npudar

Gig Performer responds to what a driver sends to it.

I use a brand new Anker USB-Hub.
It happens when I open “Midi Ports” at GP, why?


I assume that Gig Performer queries drivers of all MIDI devices and that a driver reports wrong data to Gig Performer.

The TD-27 offeres a USB-A connection for sending the Midi data. This is connected to a Anker, active, USB-HuB. This HUB is connected to a USB 3.0 connection at the NoteBook.
It works fine (and it worked fine for years with GP3, without issues), until I open “Midi Ports” in GP.
The software “USBDeview” is very simmilar to DevCon, as i understand. The device is still “green” and active. No status is changed, but GP is not reacting anymore after opening and closing “Midi Ports”.
I do not understand what the solution should be?
Deinstall the driver and reinstall? I made already several times.

Do you see these indicators flashing when you experience the issue?
Can you open the Global MIDI Monitor and see are there any messages displayed?

How is that so, you reported that you have a brand new Anker hub.
For an experiment, you can try installing GP v3 and see is the issue the same. I bet that it will be the same.

Don’t know what solution to propose. Do you have any USB 2.0 ports to try them?
IMHO, this is most likely a weird driver issue, but wait to see what will other forum members suggest.

Yes, the indicators are flashing during the issue as well, that means the connection is generally there. I will check with Midi Monitor if something will chane before/ after.

I exchanges already the midi cable, the HUB and tried different ports.

Everything works well until I open “Midi Ports” in GP, that means it is caused from GP.
Lets see if others have some exspeciance with it.
Thanks for your help!

Short Update,

as I wrote before the Midi from the TD27 is not recognized from GP anymore after opening the „Midi Port“ Window (and closed it) if a second instance is open.
After closing the second instance, and the midi reset in the main instance the TD27 is back!?

Any idea?

Are you on windows?

Ah, that explains it. Your driver is not multi-client, i.e. only one instance can use your controller at a time.

1 Like

If you need to split an outgoing MIDI signal to two different locations or merge 2 incoming MIDI signals, you can use Bome MIDI Translator Pro, or Bome Network to do this.

Steve Caldwell

There is also a way using virtual MIDI drivers (they are multi-client), but you need to wait for someone who used it (I remember that I read about it somewhere on the forums).

Ok, but I use the TD27 just in the first instance, in the second and third instance the TD27 is not checked in the midi settings.
The second instance is just for mics and has connection to my NanoControl, the third is for the E-Guitar, just controlled by a midi food switch.
All three have to react on my Keyboard (Roland RD2000). Could it be a midi through setting of the Keyboard?
I am on Win10, the laptop is just and only there to run GP and is completely stripped down for Audio (and works well, with a lot of load, as the whole band is running through GP).
The „problem“ is not a „show stopper“, but I would like to minimize the chance of an interruption during a Gig…

So, if I understood correctly, TD27 works great in the first instance and if you open the MIDI Ports options in the second instance, the MIDI connection is lost in the first instance?

The root cause is definitely the (single-client) driver (I immediately suspected on your driver) so when the second instance queries for available MIDI devices, the first instance loses the connection.

I’m not sure if this behavior is the same for all single-client MIDI drivers, but if it is, perhaps devs can do something about it (e.g. implement a button that manually lists available MIDI ports, don’t know, just thinking out loud).

Yes, it is like this.
Why is the midi connection “shut down” in the first (main) instance if I open the „Midi Port“
Window? That is the reason why another instance is grapping the connection, for no reason, because I did not tell another instance to connect…

If I were you, I’d try the same gig file with a different computer and a keyboard to test if this is a universal behavior for single client MIDI drivers.

I will try.
Could be Midi-OX the correct tool too route the midi signal from the TD27 to all three instances?
Anybody working with it?

MIDI-OX is very old (älter als der Böhmerwald).
Perhaps try with AudioGridder (see this blog) or Blue Cat’s Connector (see this blog).

Or what I mentioned, send MIDI to the virtual MIDI device which is available in multiple clients. I never tried that, but I saw people discussing it.

1 Like

Thanks @npudar ,
but I do not want to run the TD27 on more as one instance, I just check it in Midi Port settings in my main instance.
How should the multi -client midi help?

I tried today again with loopMidi and Midi- Ox and other Midi helpers, no success…
If I open in the main instance the “Midi Control”
and a second instance is running, the incoming midi signal will be not used (in the main instance), after leaving the “Midi Control” anymore.
The midi in lit is shining green, just in the main instance, but is not in use anymore.
For me it is an GP bug…