Loop MIDI ports not automatically discovered on Windows


It appears that in GP 4, if you add any new ports to your Windows OS, GP will not discover them unless you shut it down and re-open it. Here is what I tried.

  1. Start GP
  2. Add a new loopMIDI port
  3. Wait 10 minutes
  4. Look at Options MIDI ports (the new port does not show up)
  5. Quit and Restart GP
  6. The new loopMIDI port is now visible.

So auto discovery of the loopMIDI port does not seem to occur and GP looks like it is only checking for MIDI port configuration at startup.

I haven’t tried this with real hardware ports at this point. Only with loopMIDI ports


I just tested with a real MIDI controller (MIDI Fighter Twister) and got exactly the same results so the issue is not just tied to loopMIDI ports. The controller is not recognized by GP until I restart it.


What happens if you plug it in, then open GP options and then close then again?

Hi @dhj

Opening and closing GP options doesn’t change it. Still does not show up. The only thing that seems to work is if I close and then re-open GP. Then it sees it.


MIDI Ports are definitely discovered and enabled automatically on Windows just the same as they are on OSX.

Plugging in a MIDI device into a USB port on your computer will display a message in GP and say that its connected (unless you deliberately disabled it in options).

Not sure how that particular software MIDI port solution works though. Something called LoopBe gets opened and works automatically for example.

Can anyone else reproduce this? I just plugged in a Korg nano for example and it got immediately recognized and I was able to use it right away in GP.

Sometimes there are various drivers you have to install on windows. Maybe there’s something going on there.

I tried to plug/unplug and switch on/off my Icon Platform M+ yesterday in the evening with more or less luck. I couldn’t come to a definitive conclusion. Sometimes, the corresponding MIDI port was back and sometimes not. I even had a situation where it was displayed as an available MIDI in block, but no incoming MIDI, and no MIDI information were displayed in the Global MIDI monitor. It could be that it is indeed related to some particular MIDI drivers. I will continue to dig a bit in this direction, but for the moment even if I was faced to weird situations, nothing is reproductible up to now.

I tried with two MIDI devices, works as usual.

Perhaps with virtual MIDI devices the driver is always connected.

I experimented a little bit with LoopBe1. And yes, the driver is always enabled. Once you disable the driver, Gig Performer immediately registers the change and puts back the virtual MIDI port in options.

Once I load the driver again, Gig Performer immediately registers the change. No Gig Performer restart needed.

To experiment, find out the name of your driver (driverquery):


… and use a utility, such as command line DevCon, that can enable/disable drivers.


Interesting, this is not the behavior I’m getting, however I had never had a port named “Test” l(loopMIDI) or “MIDI FIghter Tworster” connected before. Now that they were at one time connected, if I connect them again after GP is loaded, it will find them this time. I will check later today.


Well for now my hardware controller changes are magically being recognized when I plug them in and remove them. I don’t know why it started working.

As far as loopMIDI. Now when I create new loopMIDI ports, GP recognizes them but if I delete one, then GP doesn’t see it gone. So I suspect loopMIDI keeps the driver active even after the port is removed. I shut down and restarted loopMIDI and the removed port still showed up in GP. So there might be something strange here in just loopMIDI. Still a mystery why my real hardware controllers changes all of a sudden started being recognized today.

In either case, this is not a high priority issue as a re-start of Gig Performer always solves the issue.


1 Like