Lemur Bi-directional communication is now only one way

Hi, I’ve been using GP and Lemur for a couple of years without problems. Within the last 10 days, I’ve found that communication will still trigger Lemur from GP, but not the opposite. Thought I’d solved it a few days ago, when noting that the iPad’s Bluetooth had been left on. Problem reappeared the following day and I’ve been scouring manuals and the forum trying to find a fix, but to no avail. Have tried many methods to troubleshoot or resolve the issue, but am at wit’s end, especially since it had previously worked flawlessly. I’ve included some screen shots in hope that someone may be able to diagnose the issue. It must be user error, but I can’t determine anything obvious.

Try changing the entry in your iPad lemur settings from MichaelsMacbook pro to the actual ip address of your computer

Hi David, that was among the many things I’ve tried, but it made no difference.

THere’s no magic - something clearly changed.

Try downloading OSC Shark (http://sebastianruml.com/downloads/projects/OSCShark/OSCShark%20v0.0.1.dmg) and, after quitting Gig Performer, run OSC Shark and have it listen for incoming messages on the port 54344 and see if anything is being received

1 Like

The link was a blank page, but had earlier downloaded Wireshark. Didn’t read enough of the manual to specify a port number, but this was the result when I started a capture and moved a fader in Lemur, then in GP.

The port is displayed in the GP OSC settings and as mentioned above, it’s port 54344

Wireshark is far too general and I don’t see the port there either.

As for that link, you’re right - there’s something wrong with it. Try Hexler’s tool instead


I’d also downloaded Protokol earlier today and connected to port 54344. It doesn’t appear to receive any data from Lemur.

Your response triggered another idea. I changed the port number in Lemur from 54344 to 54376 and Protokol immediately received data from Lemur. However, when I made the same change in GP’s OSC settings it worked the same as before. GP talked to Lemur, but heard nothing in return.

I assume you know that you can NOT have two applications listening on the same port. If you tried Protokol while Gig Performer was still running, then Protokol will not receive anything on that port if Gig Performer is properly listening.

Also, do you have any kind of a firewall running that might be blocking incoming connections to Gig Performer?

The fact that it was working a week or ten days ago, as you mentioned, means that something else changed on your system

No, I did not know that. There’s a lot regarding OSC that I don’t know. BUT, when I quit Protokol and then changed the port numbers on Lemur and GP to 54376, the bi-directional communication was re-established and once again works as intended. It’s a Festivus miracle!

Nothing to do with OSC – only one network application can listen on any given port

If it works with a different port then either

  • some process is stuck with the other port open
    Try running netstat -p udp from a terminal window and you’ll see if the port is already in use


  • some firewall or permission issue is blocking it. Did you try try rebooting
1 Like

My firewall isn’t on, and I’ve rebooted many times in the last few days, but you’re right. Something else is indeed hogging port 54344.

Try the command

lsof -i :54344

That should tell you the name of the application using that port

1 Like

Ah, it’s something from Waves, which I updated about the same time that the communication breakdown began. I’ll wager it has something to do with why GP scans the Waveshell at every launch.

Look at the filtering field I used here:

Wireshark is a very powerful tool which knows about the OSC protocol and can sniff it transparently, but there are other useful OSC monitoring application available. See here:

Can you confirm this? If Waves has started using the same port we are using, users need to know about it.

1 Like

Yes, this was the post that sent me to download Wireshark, as well as Osculator.

Apparently, things have changed since shutting down last night. Could not confirm Waves was using port 54344, but GP was no longer responding to 54376. I changed both apps port numbers back to 54344 and connection was re-established. Then I ran your command on both port numbers and got these results.

That’s bizarre — so now Waves started using the other random port that you chose?