Latency of plugins in bypass?

I am running a few real time effects in parallel using a mixer and noticed pretty intense phase cancellations if I had the parallel mixer channels still up when the effect was in bypass.
Of course GP cannot compensate plugin delay times when the effects are active, but there should be no delay in bypass?

Just run for example a guitar signal through a 4ch mixer. Channel 1-2 is thendry amp sound, Ch 3-4 is sent through let’s say an Eventide Pitch. Switch the Eventide to bypass and you hear the phasing caused by Ch 3-4

I guess that also means if I run a long chain of serial connected FX, these will cause a delay, even when they are in bypass?

Edit: I made a small phone video to demonstrate the issue:
https://youtu.be/OHDWxMX0YEo

Did you bypass the Eventide Plugin within the plugin itself or did you bypass in the plugin window(the button rendered by Gig Perfomer)?

1 Like

As you can see in the video I bypass the block. The GP bypass not the Eventide bypass. So in theory this should render the plugin completely inactive.

Sorry, the video was small, I could not see completely the plugin window.

1 Like

No issue. Thanks for looking into this!

I am running a big chain of effects that I switch in and out but with this behaviour it seems I am piling up latency even if I am bypassing the effects on the host side of things …

I tested with Unveil from Zynaptiq which a well noticeably latency.
When I bypass this, the latency is gone.
So I think this is an issue with Micropitch.

Hm, weird. Ok let me test some other FX …

Can you test Micropitch in a DAW and play live, just to see how it is working in a DAW?
I would expect the same behaviour as in GP.

So I tried some more plugins. It’s like a 50/50 thing. Torpedo has lag, so does Amplitube, so does Helix Native (but it’s less apparent on the Line6). It’s no issue on Eventide UltraChannel for example, not on ADA Flanger, not on Mercuriall TSC.

Interesting is that on Torpedo the phasing sounds different, more apparent on the AU and less so on the VST3 version of the plugin.

Very strange. I can make a test with Micropitch in Logic and will report back.

So some plugins face the issue and others not?
As far as I know the Eventide Ultra Channel works with near 0 latency.
Maybe some plugins still report their latency to the Host event when bypassed.

No issue in Logic with Micropitch. Of course it gets louder when both identical channels run in parallel but no phasing with Micropitch in the channel insert and the plugin window set to off.

In your test you played live ?
I am asking because just playback track is a different thing - plugin latency compensation cannot work live.

Sorry I don’t think I can test it live in Logic. The same input can be monitored only on one track simultaneously as far as I know. And I cannot test live here, I used the same audio file little guitar track.

I think the test could be done this way:
Create 2 channelstrips in Logic.
Put the same instrument (for example the inbuilt e-piano) in both channels.
Then in both channels the eventide micropitch.
IN the 1st channel bypass the plugin in the 2nd channel not.
Now play your keyboard and check if you notice any phasing issues.

Both channels should react on incoming midi messages from your keyboard.

Hm I don‘t even play Keyboard!
Maybe it’s safer I change my patches and run the sensitive effects in parallel and mix them in the plugin rather than with the mixer. Just switching channels on GP mixers.
It’s not just Micropitch that does this. These are too many plugins with that issue.

Ok, you should just include a gain control as send level to the plugin and
when not needed just bypass that gain plugin and not the plugin itself.

I can confirm this. It’s happening with plugins that have additional latency - when you are using them as a parallel effect and then mixing them together with a GP mixer - if you then bypass the parallel effect there will still be latency that’s not compensated by GP - causing the phasing issue.

I have replicated this with Soundtoys EchoBoy and a Melda plugin that has additional latency.

@jaeger this is what resolved the issue for me. Whether it highlights to the devs what the issue might be?

After MicroPitch, add the free Melda plugin MUtility.

In MUtility, enable the ‘Delay’ and set it to 8 samples (which is the additional latency introduced by MicroPitch).

This then brings the parallel audio paths back in sync when MicroPitch is bypassed.
Soundtoys EchoBoy adds 32 samples of latency when active, so for that I need to increase the MUtility delay to 32 samples when EchoBoy is bypassed.

1 Like

Couldn’t you just create a widget to mute Channels 3-4 in the Audio Mixer?

For me it was about confirming that bypassing a plugin could cause this issue. I thought the GP ‘Bypass’ completely removes any influence of that plugin in the audio chain. But this is obviously not the case.