How to mute/unmute via MIDI Notes

I have a knob which is assigned to mute a Gain and Balance Element via a MIDI Note On Command. So far so good, but how do unmute the Element via a MIDI Command? Because it seems that the knob has no toogle behavior.

Why use a knob? If you had a switch and set the option ‘Momentary to Latching’ it should toggle when you send multiple note messages.

Knobs will toggle a parameter when they cross the half-way point (unless you change things via the widget scaling options).

Per @rank13 , use a button

2023-07-22 07-27-23.2023-07-22 07_27_54

2 Likes

I suppose that what you mean with « mute » is to set the knob to a « zero » value when you play a note and you would like to get this initial value back when playing the note again? Do I understand right? If yes why can’t you variation for this?

Well, they should use the Mute button on a gain control rather than doing it with volume

1 Like

He is also speaking from a « balance element », so I think we need to know a bit more about the use case…

I think he just means he is using the GP Gain and Balance plugin, not that he is trying to do actual balancing,

I was not aware of the difference between knob and switch because I don’t use these things often. I will have a try with a switch. It is probably what I was looking for. Thank you very much.

I am sorry for the confusion I was just trying two things at the same time. Balance or Gain doesn’t matter the basic question was just how to mute and unmute something.

Look up in the manual how to create and use widgets and connect the widget to “bypass” in the “MIDI in block”.

You should be able to set the widget up so it bypasses that plug in (for example, if you want you use a variation where a particular plug in is bypassed).

Jeff

1 Like

I am trying what you are showing above. It works, but I have to press on my controller two times to change from mute to unmute and vice versa. What am I doing wrong or how could this be changed that I only have to press once in order to mute/unmute?


That doesn’t sound right if you are sending a note message. Take a screenshot of the Global Midi Monitor window after you press your controller key/button once. Is it sending note on when you press, and a note off when you release?

Yes, first button press on controller is a note on and the second is a note off. So that seems to be ok.
note on

Is this a second press, or the release of the first press?

If it’s the former, what happens is you deactivate the ‘Momentary to latching’ option in the widget options?

Its the second press. When Momentary to latching is deactivated nothing happens. The button press triggers no reaction at all.

Your issue is do to the fact that your controller has a latching behavior AND uses note events. This situation cannot be handled by GP out of the box. Two solutions:

  • modify your controller such that it becomes momentary, or such that it uses CC# messages rather than notes messages (or even better, do both)
  • use a Gig GPSCript to transform your notes messages into CC# messages

Example of GPScript for the second solution:
Here is an exemple of Gig GPScript converting note events ranging from C1 to G1 (you will have to modify this) and coming from Rig Manager MIDI port alias My_IAC (you will have to define your own alias name for the MIDI port you are using with your controller, e.g. for IAC-Treiber Bus 8):

Var My_IAC : MidiInDeviceAlias;

On NoteOnEvent(m : NoteMessage) Matching [C1..G1] from My_IAC
  InjectMidiEventViaRigManager(My_IAC, WithCCValue(ReinterpretAsControllerMessage(m),127));  
End

On NoteOffEvent(m : NoteMessage) Matching [C1..G1] from My_IAC
  InjectMidiEventViaRigManager(My_IAC, WithCCValue(ReinterpretAsControllerMessage(m),0));
End

Once modified to fit your MIDI notes range and Rig Manager MIDI port alias name, copy this GPScript in the Gig script editor and compile. Then relearn your widgets and disable momentary to latching as your controller is already momentary

Thank you. I use among other things a Korg Nano Control. I use now CC 60 and it works. The thing is that I try to do two things at the same time with sending CC60 first thing is to mute a Gain Block in Gig Performer. The second thing is that I send the CC60 via UA Midi Control to my Console Software where it mutes another channel at the same time. Now comes the challenge: I would like to unmute the channel in the Console Software while muting the Gain Block in Gig Performer and vice versa. I guess that Gig Performer maybe has a trick in its toolbox to kind of invert the reaction to receive the CC60 message?!

If your controller is latching (toggle), that’s easy. In the properties of the widget you use, MIDI tab, enable “Thru”, in the Value tab you will perhaps also have to Reverse in case both the Gain plugin and the external device mute simultaneously.

Thank you very much for your advice, but I can not follow you. Is this answer referring to Gig Performer or my UA Software? I don’t use a widget in Gig Performer. Just a switch button. Or is a switch button a widget? In the moment my problem is that the Gain Plugin in and the external device mute simultaneously. Where and how can I reverse this in Gig Performer?

Yes, it is a Switch Button Widget. All buttons, knobs, sliders and whatever you put on a GP panel are Widgets.

Can you confirm your MIDI controller is latching (toggle)? Elsewhere, there is something else to do…