Helix Native missing on each reboot

So no, I didn’t reformat the drive, could something be messing up from there? I mean the install looks clean, there are some “greyed out” folders with duplicate names, like programme files etc that looks like they may be from the previous installation. Aaaaargh, I don’t want to do all this again! Hehe…(I will if I have to obv…)

Yes, I’d go with a clean install. From scratch.

Ok…wiping the disk here now…will install soundcard drivers, helix then gig performer only then test…fingers crossed…

Yes, that’s how I would do it.
If that works - full backup.

Then setup everything else.
If that works - full backup as well.

Wow, it opened after a clean wipe and hours of install…thanks.

Now i need to figure out how to make an image of the system to be able to restore from if it goes south after installing the rest of the plugins…:slightly_smiling_face:

I wonder if one of your other plugins installed a dll that conflicted with Helix?

I was 100% sure that reinstall will solve the problem. My guess was that a plugin or Windows Update messed up with some of the underlying system or shared libraries and consequently resulted in an odd behavior. That’s also the reason why “roll back” didn’t work.

Well, that’s lots easier because the Gig Performer team provided instructions :slight_smile:
You know that we have a Windows optimization guide that besides many optimization tips includes other useful stuff and best practices that people will find handy, i.e. backups: Create a full system backup of working configuration

More tips: FREE e-book by Deskew - Optimize your Windows PC for the stage!

NB: If you don’t want to use Microsoft tools, there are great free third-party tools, such as Macrium Reflect.

Thank you so much for your time! Yes, i have checked out the windows guide, its indispensable, what a great resource! (Just didn’t remember it explained the system backup yesterday, but i figured it out)

Now for some hours of vst installs.
Thanks again, veey happy user here.

Hi again,
So, after installing plugins from one vendor at the time, then checking that everything works, helix opens etc, i tried to open my previous gig file. It opened, then i added helix, nothing…
I tried to close out one thing at a time, still nothing. Luckily when i reopened my test file helix still works.
Is there a way to debug that gig file? Something must have been corrupted in that. Strange that it made it impossible to load helix even in a blank gig earlier though, at least now it loads in the testfile.
I’ll include a link to the offending file here in case you can debug.


Let me know if you run into any issues accessing the file,


Set rights to that file as public. Otherwise, “You need access” dialog will show up.

Thanks, done!

Aaaaaargh, I have to revive this thread.
I got the Helix plug working after a complete erase and reinstall.
I took the system to a session for the first time the other day as I mentioned in another post. Flaweless.
Literally, the next time I’m booting it up, right now, Helix is disabled and I can not enable it. It’s red saying it’s missing. However in the plugin manager all is ok, it’s listed, and it’s green.

Help! :slight_smile:

By the way, Helix opens fine in Reaper on the same laptop. So install, license etc are all fine.

Did you disable all automatic updates?

Of windows…actually not sure, ill have to check in the morning.
I was able to open helix again in gp now by shift-starting gp and opening a blank gigfile.
There i could add helix and it opened.

But the gigfile from friday is dead. Was working friday at 14:00…


Hi again,
Apparently I did not disable all automatic updates. I have now tried to disable all through the task scheduler, as well as placing windows updates on hold (They were on hold by the way)
I use windows 11 home, and can not find the local group policy editor. Apparently, after a google search I discovered this is not available in the home edition, correct?
Anyway, I had not disabled the microsoft store app updates, could this have had anything to do with it?

Now, Helix is opening again in my newly made gig file, but the gig file from before the weekend does not open helix, it says it’s missing.
I am very far from being techy, but it seams bizarre that this happens within the same system and the same program? So something must have happened to my gigfile from before the weekend?
This was also the case earlier, it was working, then not and I had to build a gigfile from scratch to get helix to open.

Let me know if it would help any debugging to share the gigfile in question.

Thanks for super responsive assistance, :smile:

Home editions are crippled down in terms of group policies, you can’t add them in a domain, etc.
Windows Update is also not easy to control. I recommend installing the Pro edition.

Anyways, please try this application to see if it works on Home editions.

I’d recommend you to try this tip I wrote, but I’m not sure if this exists on the Home version.

Do you have a hard disk?

Yes, I have a hard disk, what do you mean, an external or internal? I have both, but don’t use the external for other than a system disk image.
I’ll update to windows pro. :slight_smile:

I asked if you have an HDD, because you might want to check it for bad sectors.
(SSDs are different when in comes to failing).

Aha, gotcha!
No, only ssd’s, one internal. :slightly_smiling_face: