GP clock will NOT sync with external MIDI clock

I’m trying to get Gig Performer to sync to an external clock.

I have both a Roland Fantom (newest version) and a MOTO Micro Express MIDI (4in/6out). Both my synth and MOTO are recognized by my MacBook pro. I’ve installed the snoize MIDI Monitor application to verify that MIDI clock and data is flowing freely into/out of my Mac.

In each of the Rackspaces I want to sync, I do flip the switch to “sync with external clock”.

ALL my MIDI devices show up in the Global MIDI window inside of GP and are all enabled.

The ONLY thing that happens when I send GP clock signal is the “play” button turns green, or if I stop MIDI clock it turns back to gray.

Yes proper clock information is being sent to GP which is verified on both my MIDI Monitor ,as well as my Roland Fantom will respond to an external clock.

What am I missing here? This is NOT an “Ableton Linked” product but just clock coming out of another iPad ( Play software).

Ultimately, I’m trying to get my GP instances synced with my church’s playback software.

What version of GP are you running?

I’m using the latest GP software, 4.7. My MacBook Pro is a M1/64GB/2TB running Ventura 13.5.2.

MIDI info is flowing into this computer, but there is NO DOUBT I’m missing a switch somewhere. I can not get the clock to change on GP.

Double click on the rackspace name in the left pane to bring up the rackspace properties. There is an option to sync to external clock.

Yes, I mentioned that in my post. I have it enabled on the rack space level. Clock is working, GP is not responding, I’m missing a switch somewhere.

Did you enable MIDI Clock for the device in the Rig Manager?


See item 11 in the documentation

dhj, you might be onto something. Been a busy few days but I’m going to dig into this Saturday because I don’t recall enabling this in Rig Manager. Hopefully I can figure it out by Sunday for my church gig!

I sincerely appreciate the feedback. - Dan

I was also having the same issue in terms of connection path. I now get a yellow signal on the top right corner signaling I am receiving the midi clock in GP4. However, my new issue is that the clock isn’t synced appropriately and is all over the place, and is currently unusable as it is currently.

Multitracks, iPad

Gp4, Macbook Air and
Gp4, Dell xps 13

Gp4 starts and stops on both systems when multitracks is initiated, however the clock itself is all over the place. Is there a fix for that?

Everything is interconnected via Bome Network, if that makes any difference.

Is it possible that GP is receiving clocks from multiple places?

We have tested GP’s MIDI clock receiver using high precision hardware (Midronome) and it tracks extremely well.

Thank you for giving me something to consider. I’m just an average Joe trying to figure this stuff out. I’ll fumble through this in my free time over the next few days.

I know it’s possible to get this behavior when I use (by accident) multiple midi clock sources and enabling them by selecting more than one midi input as ‘Responds to MIDI Clock’. Maybe a thing to check?

1 Like

Slight update:

In my very limited time I’ve been running various tests to see what is the potential problem, and gig performer works just fine. Especially when using Ableton link, everything works as it should, but the issue is not everything I use uses Ableton link. Again, I’m I’m trying to use the app playback from multitracks, and that is ultimately the problem child. However, I just came across this this morning, but the answer to my problem may involve using a midi bus. I’m definitely going to have to spend some time looking into it, but that may be the potential solution.

I’m not sure if Midronome is considered a midi bus, however, I want it just because it looks cool :rofl:.

Hey there DHJ, I have a Midronome and have it working great with a bunch of different apps, but I’m reading and scratching my head on getting GP on my Mac to listen to/respond to Midronome’s clock to change Songs’ tempo in setlist view. I looked at Rig Manager and tried associating Midronome Commands device. I turn off “override global tempo” on both the song and the song’s parts as I want GP to use Midronome’s clock. The yellow rectangle never shows up around the tempo no matter what I do.

I have done it the other way…sending MIDI cc:88 command to change the tempo from GP and that works well. Just can’t get GP’s tempo to follow Midronome. Can you share your setup procs?



Ahhhhh…just tried one more thing. In Rig Manager, I created an ALIAS of the GP Local port, then associate that to the Midronome Commands device. NOW you can see the “Respond to MIDI clock” and it’s working! (sort of) As I flip between songs, the MIDI cc command is setting the tempo to the song’s default tempo just like before, and if I want I can turn the nob on the Midronome and the tempo in GP changes in real time (use case: the band wants to crank up the tempo in the heat of the moment, I want to accelerate the click being sent over IEMs to the rest of the band, and all my delays/arpeggiators stay in time).

BUT, that darn elusive yellow rectangle still never shows up. Regardless, I can live with that as the functionality that I want is achieved. :slight_smile:

I don’t understand. That device is connected by USB and has its own MIDI port. Why aren’t you just enabling that port in rig manager for clock?

I removed the GP Local alias in Rig Manager, and created an alias for Midronome Start and Stop, then did a “Responds to MIDI clock”. Back in the main GP gui, Midronome is sending clock, and turning the nob does change the tempo on any song. But that yellow rectangle still doesn’t show up around the tempo.

Regardless, the resulting functionality does work so I’m ok. (works the same as it did mapping Midronome command to GP Local).

There’s no yellow rectangle around the tempo. If you’re referring to the blog article, those rectangles (yellow and red) are just there to highlight the parts of the display you should be looking at

1 Like

OMG, do I feel stupid now. :crazy_face: Thanks for the guidance!

1 Like

Started a new job and just getting back to this. I have the checked the MIDI in-ports that are listed from my MOTO 4x6 MIDI interface. Yes I have check marked the box to “respond to midi clock” on one port and the “rx receive” is highlighted. I’m properly feeding that specific port with a clock source coming from an iPad.

The front panel my MOTU MIDI device clearly indicates it’s receiving clock from an external source, but GP just doesn’t respond with no flashing of the MIDI data indicator.

I’ve read through all the literature, reviewed every forum topic on this, and followed every instruction. It’s gotten me so frustrated and I loath the idea of switching platforms, but I so need this this to work especially with Christmas shows coming up. I have ZERO issues gettting Ableton or Mainstage responding to external clocks, but those programs suck compared to GP save this one issue. This shouldn’t this hard to setup.

The examples that GP uses on the referenced sync documentation focuses on using software as a clock, and not external specifically.

What am I missing? Does ANYONE make a current video showing how they did it using an EXTERNAL clock?