Enso Looper, no playback

Hello all,

I’m currently testing the Enso Looper and whereas I can get it to work in Logic Pro X I’m having a hard time getting it to work within Gig Performer. That’s why I pose the question here, I hope you can help me out!

I simply inserted the Enso between Helix Native and Audio Out, just as I would do with a looper pedal in my guitar setup. I found out that the transport ought to be running, so I press play in the upper region of Gig Performer. I can hear my signal and I can see it record into the loop. So I press the trigger again and visually I can see that it plays back. But I don’t see the outputs lighting up and I can’t hear my ‘dry’ signal anymore, although I do see them lighting up in the corner. What’s happening here, any clue?

Thanks in advance!

Can you post a screenshot of your rackspace (the ‘wiring’ view) and also of the Enso looper open? That will help debug if there is a setup issue or if it;s something in the plugin itself.

There are a few Enso users here - and I’ve tried the demo and seen it work - so it definitely works in GP, but we just need to work out why it isn’t for you!

Thanks, speed12, here they are!

I replicated your setup and had no issues with Enso (although my version is 1.0.15).
It’s very strange if you can’t hear your playing, because the only setting for that in Enso is the ‘Input Monitor’ which you have correctly set to ‘Always’.

Your screenshot of Enso shows no recorded audio. I assume when you were testing, you were seeing a waveform show up in the circle in the middle?

Were you pressing the Trigger button in Enso manually via your keyboard, or have you set up widgets and mapped/learned them to a controller?

Thanks, rank13, for checking it out for me. I didn’t use any widgets yet, so I controlled it manually via keyboard. And yes, I can see the recorded input, but not on the example I posted. I’m running the demo mode (fully featured for 20 minutes at a time) and I guess it starts when the whole of Gig Performer is opened instead of the plugin itself. Maybe I should just buy it to see if it works when I register it. But what if it doesn’t? :thinking:

Don’t do this! Prove you can get it to work. I had a bad experience with this vendor not answering my emails asking for support.

The demo timer should only start when you first add Enso to your rackspace. Are you Windows or Mac. Is there another plugin type you can try (VST3, VST2 etc).

1 Like

@Mell I’ve definitely had just the demo version work in GP so as rank13 says, don’t buy it until we’ve worked out what is causing it not to!

1 Like

@rank13 - do you have the GP transport playing when you use Enso? @Mell - maybe try it by starting the GP transport and see if that works?

Yes, I think it is linked to the host transport (not at my computer to double check).

Here’s a little clip on my proceedings. The audio didn’t get captured but you can see both the input/output meters of GP and Enso.

So the first time I tried to record, there was another sort of feedback loop/glitch on the headphones, see the red lights on the meters. The second time it did record but didn’t playback as you can see.

Hope this helps in troubleshooting!

i had the Enso looper running fine as a Demo, …then i bought it, installed the non demo
( or unlocked it, but i guess it was the first)

and then it was nolonger running. ( no audio, …don´t remember the details)
but: i´m on a M1 mac !..which makes things a bit more complicated
and: there was an update. not tested it since again.
need to check again

In your video clip, I see you selected the VST3 version of the plugin.
Does the same problem occur with the VST version?

Also, the current demo version available for download is 1.0.15. You’re using 1.0.14, so perhaps update that to the new version also.

That’s very unexpected behaviour! Hopefully the update will fix it. If it does, will you use it? Or do you have another Looper?

No, it’s on all versions. And strange, because I downloaded the demo version yesterday from their site, I would guess it should be the right version! But I will delete this one and try again.

I think I found it! It’s a sample rate mismatch between my audio device (which is at 192kHz) versus Enso (48kHz). Finally I can do some more testing. I hope my latency will not increase too much from lowering the sample rate. Let’s find out!

Why are you running at such a high sample rate? Most people use 44.1k or 48k

1 Like

I use the XTone Pro which has the sample rate between 44.1 and 192kHz. I just went with the highest thinking it would help keeping the latency low. Not sure if that’s the case, though. Maybe anyone can chime in? The audio buffer size changes when changing the Sample Rate, here are the different values I get:

I would use 44kHz and a lower Audio buffer size than 512 Samples.
Try 256 Samples and when the latency is too high then lower it step by step.

As a keyboard player, I run at 44.1k with 256 buffer size - never noticed any softness. My guitar friends typically use 128 or 220

Latency is very overrated (see this article written by a colleague on the topic)


Yeah, I use 128 samples at 44.1k and find it absolutely fine - I’m by no means a great guitarist but I can’t notice the difference between 32 and 256 to be honest… 128 seems best compromise of latency and resources.

Obviously it does depend a bit on your PC/Mac specs as to what you can push the number of samples to; but if you were running 512 at 192k then I’m pretty sure you could handle 32 or 64 at 44.1k if you wanted!

But going back to the fix for your issue - its very important that everything in the chain is running at the same sampling frequency; when I first set up a VST based rig I had this set wrong between interface and - what I used at the time - Mainstage and it caused no end of headaches until I figured it out.

Glad you’ve found a solution though!