Distortion creeps in through the gig

I’m posting this on GP, because it’s possible someone else may have experienced the same problem, although it’s not strictly a GP problem.
I noticed at last night’s gig that as the evening went on, my sound seemed to become increasingly distorted, even though I hadn’t altered my levels. I suspect the problem maybe the interface, which is a Steinberg UR24c. I power it using the USB connection direct to the laptop, but there is an option to give it its own power supply, and just use the USB connection for data.
Does anyone think this would make any difference?
Also, on your main outputs from GP into the soundcard - what do set your max levels at - because I guess the problem could be there as well.

Do you only use VST plugins from GP or do you play with a stationary synth through the sound card? Thought you could see the signal through the Steinberg software mixer. I probably recommend that you use a power supply for your sound card. You can have similar problems with USB hubs if you don’t have an external power supply.

I once had that interface too and one day it started to spoil the sound after a while of use… sometimes. It was like a slightly upcoming buffer underrun… never could find the cause of the issue. I then sold the device finally.
What OS do you use, Windows or Mac?

Sorry, should have said, Windows 11.

Only vst soft synths. No audio goes through the interface. Im going to try a dedicated power supply, because if that works, its a zero cost solution.

I observed a similar behavior on macOS during our last rehearsal! :disappointed_relieved:

At the start of the session, sounds were clear. After like an hour and a half, I noticed the sounds coming from computer/GP started “crackling” in my IEMs. And it started building up very noticeably in the span of only a few minutes time.
At some time there was only crackling left, and a tiny bit of the low end kick. Only could hear sounds through the noise 'cause I knew what to listen for.

My WIP setup is:

Using 2 VSTs in Global rackspace: drum VST & bass VST. Behringer X32 Compact via USB as audio interface.

To paint the full picture:

Was also running GP’s metronome click, + tempo sync via Ableton Link was enabled as well. Connected to my Soundbrenner client on phone over laptop’s ethernet → router → phone via WiFi.

Additionally was multitracking some audio channels (vox, guitars, 2 stereo channels of hardware keys, …) using GP’s built-in recording feature.

For now, key sounds are coming straight from my Kronos into the X32. GP is not involved in that audio chain (yet). Just connected the keyboard via USB to the laptop for MIDI recording only.

Haven’t done any “tweaking” of my audio card, or done any stress testing yet. Started at 48K, 512 buffer size.

:muscle: I resolved the crackIing issue for the session’s last 30 min by going into GP’s audio settings, selecting the next available buffer size and hitting save. The gig reloaded, and crackling was gone.

Initially I suspected that I was overloading my older Mac’s CPU processing or something like that. But that doesn’t explain why the first hour and some more, the setup worked flawlessly.

:shushing_face: Completely off-topic:

The crackling gave me some flashbacks to the setup I had many years ago. :scream: Different laptop, different sound card and using MS.

Getting that started at the beginning of a gig was hit or miss. Sometimes the sample rates between the host & sound cards would not line up. No software setting or system preference I found could reliably fix that issue.
Only way out of that situation whenever it happened, was disconnecting the sound card, do a full system reboot, plug in sound card again, start up MS and hope for the best. Or repeat until it worked.

Playing music should be fun, not Russian Roulette. Hence the reason years ago I made the switch to hardware in the first place. :sweat_smile: :man_shrugging:

'caus of these prior experiences and symtoms: I’m pretty sure it probably is NOT GP that was causing my issue. :wink:

My first thought was the heat, so there was some kind of a CPU throttling. Strange "Out of Tune" during performance - #22 by bigalminal

My second thought was that you should check with a powered USB hub.

My third thought is to check with another interface or even with an internal sound card.

(a little bit of experimentation is necessary here)

I think, like you, that its heat related. Ive looked at the cpu load a few times during a gig, and its typically around 15% to 30%, maybe up to 50% with a complicated song. So i dont think its that.
Im going to try your 2 suggestions and see what happens, but the only way to try it is at a gig.
The only other thought i had was whether it was hardware, and my onstage amp is overheating, but i think thats unlikely.

Was this on v4.5 or v4.7 ?
The version 4.5 is here for a relatively long period of time.

And if this was working OK for months/years – it’s important to analyze what happened (what changed) so this started to happen (update, different cables, … … … ).

In my case i think its always done it to a greater or lesser extent. When i soundcheck at the gig the sound is perfect. Beautiful, crisp, and with no distortion of any kind. Then throughout the evening it gradually decays. I use the same leads and wire up the same way at every gig. I have noticed it at rehearsals too. I dont think its the laptop. I have a big gaming cooling fan sat underneath it, and ive checked temps at the end of a rehearsal and it hasnt overheated.

It happened on 4.5 and this weekend 4.7. Im convinced its the interface. I dont think its a GP problem.

I was already on v4.7. I just updated to the latest version few days prior.

To be honest, I hadn’t tried a longer session yet before; not on v4.5, nor v4.7.
Except for when tinkering and setting up the gig file: configuring VSTs, signal flow, widgets, …

That 2h+ (indoor) rehearsal was my first real-life test drive with GigPerformer in a “live” setting.

I don’t think it was the cables or X32 firmware. I have previously already recorded as many channels with the same cable successfully. All be it recordings were made on a different machine (my Linux laptop).

But now that you mention it, I also did some lighter recordings via GP v4.5 on the same hardware.
Just tracking 3 vocal channels. No VSTs. Not sending back any output from GP.
Don’t think those recordings were “distorted” in a similar way?

Yikes. :scream_cat: That would suck if the X32 was causing those issues? :cold_sweat:

I don’t have any Behringer-specific drivers installed on my system.
Just plugged it in (so probably running via CoreAudio?).

Rehearsal was indoors. No direct sun on the machine or something like that. Not that super hot, either.
But will monitor CPU activity & core temperatures next time it might happen. :wink:

To get a bit more technical: Are there any log/dump files, metrics, … or other places that we can look into? That could shine some light on this?

FYI: I really liked the power & ease of using GP as my power “command center” :heart_eyes: :muscle:
Only those last thirty-something minutes – where the distorting started happening – were a bit less smooth sailing. :man_shrugging:
Nothing the reset didn’t solve. But being able to prevent this from happening – thinking ahead to live stage performances in the near future – would be nice. :see_no_evil:

I wonder if you have a plugin that’s leaking memory - or you’re at the very edge of the amount of RAM needed and your Mac is swapping?

When touring, I routinely do a sound check and leave everything on and it could be 4 hours before we start - have not seen an issue. In my studio, I often leave everything on overnight (often multiple nights) with no issues. There has to be something going on beyond GP itself that is causing this.

Im using a windows 11 laptop, not a Mac. I have left my system on all day when ive been practicing, and ive never had the problem. It seems gig related. Maybe heat.

The problem has been resolved. At the last gig i powered the Steinberg audio interface separately, and thus only used the connection to the laptop to transmit data.
Instantly the problem went away, and i noticed that CPU usage in GP was lowered as well.
Thanks everyone, and it wasnt a GP problem, rather user error.