Cracks and tails!

Hi all,

I’m running GP on a headless desktop : i7-6700k, 12gb ram, RME Firerface 400, and tiny WiFi router for rdp control from laptop/tablet/smartphone.
I’m on win 10 LTSC with ultralite and optimized install.

All is working like a charm with 2 instances (one for each keyboard) running b3x, pianoteq, arturia synths… I’m at about 20-30% on two of the four cores, with 128 samples buffer @ 48khz. Nothing higher than 400us on latencymon when GP is running. No cracks…

No cracks except when I launch my gig file when GP is started. When plugins are loading there are some rattles. Were it possible to start the sound engine once all the plugins are loaded ? Do it automatically ?

I notices that there is almost no rattling when I connect RDP from Android (Microsoft rdp client from playstore) and Linux (remmina, freerdp) devices… Seems more frequent with the win RDP app from my win 10 laptop.
Any idea ?

Another little thing : I use some pad presets with long release times. When I switch back and forth rackspaces, I can hear the tail of the pad sound. Is it possible to ‘‘cut the sound tail’’ when I switch to another rackspace and not hearing it when I switch back ?

Sounds like an old RDP audio redirection issue.

The trick was to run the Group Policy editor and from there disable “Allow audio redirection”.

You can google for the exact guidelines.

As for the audio tails, you can configure it in the Rackspace Properties window.

I’ve disabled the ‘‘audio recording redirection’’ of local group policiers (on the headless pc, not the laptop). Changes nothing, still 2 or 3 loud cracks during the plugins loading.
I also tried with my Android smartphone. Actually I noticed it happen with the phone too, but it is only when I start GP and load my gig for the first time after reboot. Once it has been launched one time, no more cracks on next loadings. Same behavior on win10 and Android.

Concerning the audio tails I tried to fiddle with input muting and output fading with no really success. When I play a pad chord and switch quickly to another rackspace, the sounds fades out, ok, but even after 10-15sec although it’s dead quiet, when I switch back to the pad rackspace, I clearly hear again the pad tail.

Reach out to the plugin developer (what plugin is it)

If you’re hearing sounds when you switch back then the plugin is not properly clearing its audio buffers when it is sent a reset request.

It’s mainly with Arturia Solina. But I can also hear it with pianoteq and some Roland string plugin, when I bypass and power it on.

Regarding the big pops at first loading, no way to delay the sound engine starting once all plugins are loaded ?

Crazy thing, you are not supposed to hear anything. Does this happen with only one GP instance too? Does it happen when one GP instance is started and you start the second one?

This probably not a good idea, as if you are using the Prédictive Loading option, the sound engine has to be active anytime because you are playing while GP is loading the next song.

It happens with only one instance just after booting the PC. Once it has been launched one time it doesn’t glitches anymore on next loadings.

I have the same cracks issues when moving from one rack space to the next, happens with different plug ins

It’s best to create a new thread and explain what is exactly happening.

OK, so if I understood well, everything is OK when RDP is not active?

When RDP is active, you hear a crack when you first run Gig Performer?

Can you try VNC or VPN connection instead?
Or AnyDesk, there is a client for Android.

Will do cheers

Ok I’ve fiddled with audio params of the Firerface (unchecked all useless input/output, restricted fw bandwidth to analog signals). I’ve rebooted the pc a lot of time, checked with win10 rdp, Android rdp…
I’ve also restricted GP to 2 of the 4 cores with Process Lasso, optimized PSU performance…
Glitches at the first launch are gone !

Now the remaining concern : audio tails!
In fact the phenomenon happens when I use a bypass widget to turn off a plugin.
For instance, I’ve a rackspace with piano and strings layered. Two widjets buttons are bypassing bith plugins. When I bypass the string as sound is still in the release phase, it is cut. But when I reactivate the plugins, I can hear the remaining sound tail that was cut at bypass. Even if it’s 2 minutes later !
Is there a trick to mute and de-mute audio when bypassing/reactivating plugin ?

This can only be solved by the plugin. It should be clearing its buffers when it’s bypassed. You should contact the plugin vendor.

1 Like