Auto engage Wah Wah

Can you realize a auto engage wah wah in gp3? So when you push the pedal it’s on and when you pull it to the first position it goes off! Thanks.

What wah wah plugin are you using?
The pedal you are using is sending midi messages to gp?

Using the Wah Wah from the plugin Cory Wong from Neural DSP. Only the Wah turned on.

OK, can you map a widget to the wah wah turning on?

There will be lots of options if you use GP Script. However I think the simplest place to start will be to look at using widget ‘groups’ and also value scaling. In this example I’m just using the internal gain plugin.
group-widget-scale-value

Add 2 widgets, one mapped to the wah pedal, the other mapped to wah on/off.
In the widget General settings, set them both to the same widget Group.
For the on/off widget, go to the widget settings ‘Value’ tab, and try these settings as a starting point:
[EDIT: I don’t have Neural but on my Mercuriall Euphoria plugin, these settings worked well]

The idea behind these scaling settings is that having 48 as the minimum and 51 maximum means that you’ll hit 50 (rounded) very quickly, which is the value at which most on/off parameters will turn on.

If your midi pedal isn’t calibrated to go fully 0 in the heel position, you might need to lower the minimum setting further (or calibrate!).

2 Likes

Great I will try this!

I decided to test the Cory. Min 48 and Max 51 for the wah on/off seems to work well.

1 Like

Thanks man! :metal:t2:

Yes, exactly what I wanted to propose :wink:

1 Like

I thought we’d had this query recently, but couldn’t find it. But it was there in my subconscious :wink:

This works great. Thank you all for the help!!!

2 Likes

I am happy if it works for you :+1:

1 Like

I’ve come back to this again, and for my purposes have found the perfect solution using GPScript.
I wanted to avoid any pops/artefacts that I was getting when the wah effect was bypassed/enabled, and I also wanted to not disable it immediately in the heel-down position (value 0) to avoid it being switched off when I was using the pedal’s full range.

I’ve used timers in GPScript to check how long the wah parameter is in the heel-down position, and it will only disable it after 800ms (can be customised in the script).

I’m also using a GP balance control as the wah on/off mechanism. So the wah plugin is always active to avoid pops/artefacts and a button connected to Balance will immediately crossfade between L+R to either route my signal to the wah or bypass it. Any detected movement from the expression pedal will activate (route to) the wah.

Plugin routing:

Widgets: (also showing the Balance control: right is bypassed, left is enabled). As I’m moving it you can see that when the wah parameter value hits 0 it still stays active. But at the end, when I leave it at 0 it will turn off automatically (e.g. Balance moves fully right).
Wah auto engage and timed disable

Wah Auto Engage and Timed Disable.gig (11.3 KB)

3 Likes

@rank13 Genius! Thank you so much for this solution! I’ve been wondering how to get that to work for ages and - like all clever things - it was so simple: a timer.

The problem with having it just cut off the wah on zero is that it will usually make the sound jump in and out of ‘wah’ mode: even with the pedal at the zero position, the sound will not be that same as with the wah bypassed. And I find it impossible not to accidentally go to zero while I’m using the pedal…

I had resorted to dedicating a button to turning the wah on and off - but now I don’t have to! Thank you so much!

Great solution. Will also try this!!! Thanks man.

Outstanding!

yes, nice one on the timer!

Nicely done :raised_hands:t2:
Some clever thinking.