A few bugs

Sure no probs :slight_smile:

Sorry I only just got back to be able to double check this. Yes, all inputs are enabled

Oh sorry I forgot to mention (in case it’s significant). I’m using it as part of an aggregate device. The X-USB with system outs. 33 & 34 (system outs) are fine as are ch 1 to 31. Just no ch 32 for some odd reason

Are you talking about output or input?

Input

What do you mean by that?

Ie I can drag a connection straight from ch 32 direct to an output channel and get zero. Every other channel is fine

when you connect ch 32 input to a mono gain control plugin, do you see a level?

Sorry if the aggregate thing added to confusion. Yes I’m only needing the aggregate part for output. Just thoughts I’d mention it just in case somehow it had any kind of bearing on it

Sorry, I mean the audio out in use (and yes, I know the issue is with input) is an aggregate device with the x32’s X-USB 32ch input aggregated with the Mac’s 2 system out channels. So on the aggregate device channels 1-32 appear as the 32 channels of the X-USB and channels 33 & 34 are the stereo LR of the built in (headphones/speakers) system out.

When you do not use the aggregate davice but the native 32Channel, what happens then?

Sorry I was all over the place in a rush yesterday and didn’t read your reply properly. Ok, if patch persist only relates to notes still held down (i.e. note on and no note off yet) then maybe GP doesn’t do what I assumed it did. Because in my case I’m using drum samples therefore it’s a one shot sample with the note off event happening an arbitrary (but usually short) time after the note on and the tail I want to hear is long after the note off event (but not an effect tail). I was hoping I could change rack and have the tail of any samples playing from previous rack play to completion.

I tested with Superior drummer and played a short note.
The release of the sample (crash) was heard and when I switched to the next rackspaces it faded out within the audio tail length.
When I shortened it to for example 0.5 s it faded out within this 0.5 s.

What exact issue do you face?

Bizarre. I play a crash, switch racks and the sample plays out for about 3.5 seconds and then cuts off

And when you shorten the audio tail, it has no effect?
I used the VST version of Superior Drummer.

What version of Gig Performer are you using?

Maybe there is something wrong with the gig file, please create a new gig to make sure there is no issue with your gig.
By the way: Are you playing in a band?

Here is a short video of my band:

1 Like

Ok, it seems to do it about half the length you set it to. I set it to 0.5 sec and it did cut it abruptly (but top marks for doing a rapid fade rather than cut). Turns out before I had only set it to about 8 seconds. When I set it to ten it cuts off after about 5 seconds.
And yes I am in a band, sadly nothing to show at the mo. Working on album/show at the mo (at a glacially slow pace :weary:).
Thanks for the vid, looks like a good gig :sunglasses:
If you like Pink Floyd I’ll tell you a story you might find amusing. My kids used to go to school with Dave Gilmour’s kids. Used to see him around quite a bit. Not a chatty fella. Anyway, one night I’m at home alone and there’s a knock on the door. There’s Dave on my doorstep. Turns out his boy had accidentally taken my son’s gym bag home so Dave decided to bring it round :slight_smile:

1 Like

So Audio Tail is working like it should?

Here is another vid, playing my Alan Parsons Medley

Not entirely. Like I said, it seems to cut off at about half the time that you allocate on the slider. As I said, I’d set it to about 8s and got about 3.5 and allocate 10 and get about 5

Did you create a new gig and does it work the same?
How many audio out channels are you using?
Which version of Gig Performer?

In the past there was an issue which was related to the number of audio channels used.

I haven’t tried a new gig. I don’t have time right now. Will do in due course if you like.
I’m using all 34 out insofar as they’re enabled. Only 4 we’re actually having any sound output through then when this happens (the stereo overhead mics feed) and the main outs.
I just disabled 16 ins and 16 outs and made no difference. 10 second tail setting still cuts off after about 5