Windows Changed my External Drive Letter! (and Start up box blocks error box on GP start up)

I using the latest version of GP on my Windows 10 laptop.

I recently loaded a new sample library on my external SSD.

Even though I turned everything off and pulled out all plugs, I am getting an error on start up.

It looks like some sample libraries are not loading.

My first simple question is I can see there is some type of error message, but it is blocked by the start up block. (I think is said something about the Sitala sampler I use.)

Is there a way to move that?

Also, now GP is loaded and a lot of sounds are not working.


Could my external sample drive have somehow changed from “D” to “E” because I had plugged in a hard drive in that port?

If there a way to change that?

Added: Yes, it seems like that’s what happened. I just checked my “duplicate” laptop (designed to be set up exactly the same with regard to GP.) My external drive is “D” on that one. I am pretty sure it should be “D” on this one.

I had added another drive to save the sample library (to safe the sample library and to use to to transfer it to my duplicate computer). It made the new drive “D” and changed my sample drive to “E”, And now it seems to still be named “E”.

I think (hope) if I was able to get it to refer to my sample drive as “D” again, this would fix everything.
As always, any help is appreciated.


If I open up the “E” drive, it lists the “D” drive as a short cut. I do not remember seeing that before.

But, GP still did not load up my samples correctly (I think because of this).

If someone can walk me through the safest way of re-naming my sample drive (back to “D”) I would appreciate it.

Do you think it is safe to use Solution #1: How to Permanently Assign Drive Letter with Ease

UPDATE: I followed the Microsoft steps to change the drive name back to “D”, shut off and restarted and everything is working fine.

So, maybe keep this thread in case someone (not tech person) has this issue.

But, this has happened several time where the samples did not load of the external drive, but I could not see the error message because it was blocked by the GP start up box. I think I tried to move the start up box to see the error message underneath, but was unable to do so. Is there a way to deal with this?

I’ve had this issue. Specifically when I swapped an SD card to a different hub. I know how to change it back, but I would like a way to permanently set a drive letter so that it is fixed at least for my system.

I think the first article I linked to provided a “permanent” option.

I just took the one that seemed simplest and least likely to cause any issue.

I’m just glad I was able to figure it out and sort it out.


I’ve previously done what you article says, but it hasn’t held in the past. Have you tried going through the process again and testing whether it is permanent?

I don’t know about permanent, but it returned to how it previously was.

I suspect if I did the same thing I did here (how I connected and disconnected drives), the same thing would happen. Luckily I don’t have to do this very often.

But at least I know the issue and how to quickly fix it.


Hold down the ALT key and press the TAB key several times to focus on the desired window, then release the ALT key.

Your sample drive must be first connected then connecting another disk should not modify the letter of the first one.

Thank you!

Yep, that’s what I did. I should be able to avoid this going forward. (But if it does happen, I know what to do now).

A thread made for those who would come to bash apple computers in any Mac-only thread.

sorry for OT