Weird display of VB3-II GUI as AU

So I’m trying to go through my big main gig setup to convert all of my plugins to something that will run on Apple Silicon. VB3-II only shows up as an AU plugin when I run GP natively. But when I try to open the GUI, I see this. I don’t believe I have this issue with any other plugin (at least from what I’ve been able to see). Has anyone had this issue before?

And in that situation it is running under Rosetta.

What happens if you run GP under Rosetta as well?

See also this article

Unfortunately I know this issue with other AUs. From time to time all AUs have this strange GUI (Apple MacBook M1 Monterey). In the Apple console I can find a crash report called “AUHostingServiceXPC”. By the way: all AUs have lost their settings in GP4 after that. So I try to use only native VSTs.

I think, that is an Apple Silicon problem.

1 Like

So it’s failed under Rosetta once, but it also has worked. It seems to be inconsistent. I flipped it back to Rosetta and then native and it seems to be working again. I guess as long as I can get my sound the way I want in time, it’s not a huge deal. It plays fine either way.

Yes, you are right, but when you are in a live Gig, you can’t work with inconsistent behavior of plugins.

Speaking with my music hat on rather than my development hat, I have never really trusted AUs.

Even on a Mac, I always use VSTs or VST3s

1 Like