Weird bug in switching audio configuration

This is something that’s never happened to me before. I was working in my main gigfile at home, on my MacBook with a MOTU audio interface. I made some plugin changes in a couple of rackspaces and saved the gigfile, then took the MacBook uptown for rehearsal.

When I’m at rehearsal, I don’t have the MOTU, so I plug the MacBook’s built-in audio output into our sound system. Up until today, what has always happened when I open the gigfile is that I’m presented with these two dialogs (because the built-in audio only has 2 channels, but my gigfile uses 8):

  1. Enable virtual channels? (I click OK)
  2. Route virtual outputs to physical? (I click OK)

After that, everything works normally.

However, today those two dialogs did not appear at all. The gigfile just opened. But there was no sound from the plugins. I could see my audio meters moving up and down, but nothing made it to the MacBook’s output. That makes sense, since I never got the chance to Enable virtual channels and Route virtual outputs to physical.

I restored a backup of the GigPerformer.settings file, but I’m still getting the same behavior. Now my only recourse is to restore the last backup of my gigfile and try to remember all the changes I’ve made since the time of the backup.

I’d love to know if it was something I did that caused this to happen, so I can avoid doing it in the future. The only thing I can think of is that before leaving for rehearsal, I saved the gigfile while the MOTU was connected, and then I did Options > Audio Setup > “Load Audio Configuration” and loaded my saved configuration for Built-In Audio. “Load Audio Configuration” used to tell me to exit and re-run GigPerformer in order to make the change stick, but recently (since which minor update?) it no longer does that, apparently making the change without needing a reload. I’m wondering if there’s a bug somewhere in that update?

Thanks for any ideas…

I figured out how this happened. The way “Load Audio Configuration” used to work, it would modify the GigPerformer.settings XML file and tell you to exit and restart GP. On reload, GP would recognize that the gig file has more outputs than the selected audio interface, and ask you if you want to Enable and Route the virtual channels. Now, “Load Audio Configuration” does all this in-place, without requiring me to exit GP. Unfortunately, it is also modifying the audio outputs in my gig file (see below), dumbing them down from 8 channels to 2. I suppose if I’d remembered to not save changes when I exited GP, I wouldn’t have ended up with a messed-up gig file. Instead, I’ll stop using “Load Audio Configuration” and just modify the GigPerformer.settings manually like I usually do.

Here are before and after screenshots of my local and global rackspaces. Before I loaded the 2-channel Built-In Audio configuration, my rackspaces had 8 channels. Afterwards, they only had 2 channels, and in the global rackspace this completely rerouted the audio that was supposed to go to outputs 6-8, to the built-in outputs 1&2. Not only that, but the path that gets them to outputs 1&2 goes through a “motu monitor” that I normally leave muted, which is why I wasn’t getting any sound out of my plugins until I un-muted the motu monitor. This modified gig file will not work properly when I take the MacBook on stage, because nothing will go to outputs 6-8 of our 8-channel stage interface.

1 Like

@npudar Solved? It’s a workaround, not a solution. Does the new version of “Load Audio Configuration” work this way by design, or is this perhaps a bug? Either way, having an audio configuration change reach into the gig file and modify the number of output channels, is an undesirable outcome.

@dhj Can you add this to the GP4 bug list? I’m sure you have a lot more pressing things to work on, so it’s not a high priority, but it is an issue for me – even though I have a workaround, I do have to remember to avoid using “Load Audio Configuration” under Options > Audio Setup because it can make my gigfile unusable on stage.

Just to reiterate, this is new behavior for “Load Audio Configuration”. I’m not sure when it changed, it was sometime in the last year I believe, but the old behavior (telling me to exit and restart GP) did not cause this problem.

Yes, we did - thank you for your patience.

1 Like