VST windows come up the wrong size on 4k monitors

Hi! I’m on Windows 10 on 4k screens.

A fair amount of the time, when I open the plugin editor for a VST or VST3 plugin, it comes up too small. I have to keep closing and re-opening it until, finally, it decides to size itself properly.

Here’s an example with a MeldaProductions plugin, but it’s happened to me with many vendors’ plugins in both VST and VST3 modes:

Eventually, if I close and re-open the editor a few times, it finally decides to come up properly:

Anyone else having this issue? Any thoughts? I’m happy to provide more system and configuration details.

Thanks, community!

1 Like

You should be able to drag the lower-right corner.

@npudar I think his issue has more to do with Windows scaling.

@dcitron Do you have scaling set to anything other than 100%? I have a 4K monitor, and run Windows at 200% scaling. Some GUIs do not respect the scaling setting, often the one’s that use images, but some just won’t scale. One weird example is Analog Lab 5 which does have a size setting, but it’s Audio/MIDI settings dialog doesn’t scale and is hard to read. Some of those plugins have a scaling/size setting that you have to select. They often have multiple subdirectories, one for each size they offer, with images scaled to the different sizes. In MeldaProduction’s case, they have a setting for HiDPI support. Do you have that ticked? If so, then there’s some weird rendering issue going on with MP’s plugins, which is unlikely to be a GP issue.

Copied for emphasis – the issue is not specific to MeldaProductions and I could’ve screenshotted similar behavior from many other vendors’ plugins :man_shrugging:

I agree, though, that, in general, on Windows, HiDPI support is still sub-par. I just wanted to know if anyone else had experienced this specific issue. There’s no ability to resize the window, @npudar

I just added an Arturia plugin and had to fight with it to render correctly, too.

Oh, and, yes: Windows is at at “150% Scaling (Recommended)”

Seriously, to me this looks like you only need to drag the corner. I’ve just tried it.

Note that the plugin editor is resized and is now all over my display.

Simply move your cursor around the bottom-left corner until you see that the cursor changed its shape to the “double-arrow” cursor. Then drag the window to the desired size.

1 Like

Hi, @npudar

Almost none of the plugins that I have allow drag-resizing by that corner.

The Roland Cloud ones do:

Most of the remainder do not:

Additionally, @npudar – the ones that do allow resizing by dragging, that sort of resizing changes the scale of the plugin.

It doesn’t reveal or hide portions of the plugin GUI.

FYI, when the Melda ones come up in the wrong-sized window, the resize drag area is hidden (clipped):

After closing and opening the plugin editor window a few times, once GP finally creates the correctly-sized window to wrap the plugin GUI, the resize area is now visible (revealed) and I can resize the plugin within the constraints that it allows:

It’s impossible to resize the window that wraps the plugin – i.e. under no circumstances does it allow me to clip/hide parts of the VST GUI

Yes, there are plugins that don’t allow you to change their size. But some of those plugins, i.e. the Legend allow you to choose the desired size.


That depends really on how the plugin is implemented :slight_smile:

See for example this one:

Anyway, I’ve never seen that a plugin is clipped by default. :thinking:

Can you please try changing the renderer in the Display Options. If the OpenGL renderer is selected, please try Software Renderer (or vice-versa).

1 Like

They’re not clipped by default on purpose – if I close and re-open the editor window a few times, eventually it comes up properly. It’s some sort-of sizing bug. Maybe a timing issue between the VST rendering its interface and GP calculating a window size?

I had it set to “Software Renderer”. When I switch it to OpenGL, I have this problem:

The UI is unusable that way – the mouse target areas are where the interface is supposed to be, so I have to click up in the blank, black area near the top to effectively click on the buttons down below.

Note: I have this option enabled in Windows for GP:

If I don’t enable that, then the GP interface is blurry.

1 Like

Hm, I’m out of ideas. My experience is quite the opposite, both renderers are working fine, and I primarily use the Software renderer.

I also use Melda plugins, never had an issue that you described (although at first it looked like the window size simply had to be adjusted).

If I were you, I’d try:

  • a different video driver
  • or try with an integrated graphics chip
  • try different DPI / scaling options

Thanks for the ideas, @npudar

  • I’ve updated the video drivers multiple times over a few years, and I’ve had this problem the whole time I’ve used GP (for a couple of years now) on pretty-much any plugin, so :man_shrugging:
  • I don’t have another graphics chipset available at this time with this CPU/motherboard combination
  • I’m a bit reluctant to change any global Windows settings, since every other application I use behaves properly and looks good

Again, the Melda plugins are just an example. I have the problem intermittently with many different plugins from many different vendors, at random. Any plugin can look fine/not-fine/fine (or any other permutation of therein) if I close and open its editor 3 times in a row.

Of note: I also use Reason with its new VST and VST3 support and I don’t have any problems in that application. The VST editors always display correctly, and the entire interface is scaled properly on my 4k screens and looks sharp. They spent many development cycles recently fixing up their Hi-DPI support on Windows, with many beta releases and bugfixes, so maybe that’s the difference.

For now, I guess I’ll just live with it. My live rig is a MacBook anyway, but it’s nice to use GP on Windows sometimes…

1 Like


@ Windows users with 4K monitors: what is your experience? Please share.

1 Like

Once again, I instantiated a Melda plugin and it did NOT have the lower-right resize option. Per your suggestion, I then changed the rendering to Open GL, and was able to resize Melda windows! I’ve never changed that option before, so I assume the Software rendering is the default on install on Windows.

Windows 11 Pro on a Lenovo P17 with a 4K internal display (Intel video). There’s a second video chip (NVIDIA GeForce) for an external display, but I’ve never hooked up an external monitor to it.

EDIT: OK, gotta backtrack on my comment. I went back and changed the setting to “Software Renderer” and was able to resize MP’s plugins by dragging the lower right-hand corner. What fooled me was that the cursor doesn’t change to the two-headed arrow when you hover over that area like most implementations do. You have to left-click with the cursor over the right-hand corner, then you get the two-headed resize cursor. So, both rendering methods support resizing of MP plugins. I switched back to Open GL anyway.

1 Like

@dcitron I didn’t understand everything (I use an automatic translator) but I didn’t see if you had tried
changing Melda’s size in the settings/style configuration (60% - 300%) and if it makes a difference?

The described issue is not only about Melda’s plugins, so, though it might help to reduce the problem, the issue might still exist for other plugins