VST Plugins as dll's

Hello, just installed GP, downloaded a bunch of free 64 bit VST plugins and
copied them to my Steinberg/Vst plugins folder but they load in red(unavailable)
in Gig Performer. Any idea why?


Are you absolutely certain they are 64-bit?

Yes! I

Got them from here : https://blog.landr.com/best-free-vst-plugins/

Did all of them show as unavailable in the Gig Performer plugin scanner? Do you have any other plugins and if so do those ones show up in GP?

Yes they’re showing up in red as unavailable and all my other old 32 bit plugins are ok and usable as I use JBridge. I also tried unloading all the bridged plugins and re-scanned pointing only to the 64 bit plugins but that was unsuccesful.

Very odd — I’ll download them into a Windows machine and see what happens here. Thanks for your patience.

Hmmm, I’m not going to download 200 plugins manually — can you suggest a couple that I can try that failed on your system so I can try them?

All these plugins have different origins, so the issue is probably somewhere else. Rights of the dll files or of the vst sub-directory? :thinking:

Well, so I tried downloading Cheese Machine but it wanted to send me an email link which I never received. The next one I tried was Ample Guitar M II Lite. I downloaded installer, and it installed a 64-bit and a 32-bit DLL into c:\ProgramFiles\Steinverg\VSTPlugins. Then I ran the plugin scanner, added that directory to the list to scan and it verified the 64-bit version and disabled the 32-bit version.

So far so good.

Can you give me one example that failed on your machine so I can try it?

Some I tried : DSK synthopia, DSK the Grand, Royotoms, solostrings

@electric61 I just tried DSK the Grand and it works just fine:

One issue is that whoever packed these into a ZIP file also packed the .AppleDouble files from Mac OSX and inside it are links or other stuff with the same name e.g. PluginName.dll which are obviously not plugins so you’d get an error message and THAT file will go into the red list.

Could you check your list of RED plugins you mention and see if the path maybe contains .AppleDouble.

Are you certain that the real plugins didn’t properly scan into you GP? If you right click to add a plugin - do you maybe see the plugins there after all ?

I finally tried extracting the zip files straight
to my VST folder instead of extracting them in my download folder and then copying the dll’s into the VST plugins folder. For some reason, I guess creating a separate folder for each plug in into the VST plugins folder works! Before I had just copied the dll’s into the vst plugins folder.

To all who helped me out, thank you!

You shouldn’t need separate folders. Sounds like something went wrong while copying. Glad it’s working now though.