Vst not responding on keyboard

Hi there. Hope you can help me.

I build some rackspaces for two songs. To begin simple. I have 2 keyboards who are recognised by GP5. One of them is devided in two to play independently a vst.

One of them is sending a signal to the vst. I can see that because the orange line from keyboard to vst is white while touching the keys. But it seems like the vst is not responding. The wiring behind the vst isn’t changing to white. Whats wrong here?

The other part of the keyboard triggers a vst perfectly.

Plugin often reacts only to MIDI channel 1, it could be that your controllers sends to another MIDI channel. Could you try to put a GP MIDI monitor at the output of the MIDI in block of your controller to check this ?


Is the vst set up to respond on a different midi channel than the midi channel that is sending the signal.

Try connecting the MIDI IN Block of the midi monitor. See what it says.

I have also run into similar issues when the USB hub swapped one keyboard for the other. Do you have the Rig Manager set up?

Good tips. I will try this as soon as possible. And let you know.

This type of thing happens to me pretty often. Invariably I did not set up something right.

So other options:

So, in addition to using the midi monitor, I try to trigger the VST using the MIDI IN block virtual keyboard and also the VSTs virtual keyboard.

Sometimes the audio interface is not properly connected. Sometimes I forgot to connect the 1/4 audio cable, once my speaker was turned off, etc.

So @jeffn1 and @David-san I’ve tried the following:
Set the MIDI IN block after my left side of the Oxygen 61 keyboard. Wit these keys the vst responds.
I then deleted the MIDI IN block and put it new in the wiring view. Tried it. Fail. Then I inserted the MIDI Monitor. And the picture shows midi signal. But still the vst is not responding.

So Omnisphere is not responding?
Are you sure that Omnisphere reacts on Channel 15?

Can you try this - Map Input Channel 15 to Output Channel 1 in the MIDI In (Oxygen 61) ?

1 Like

@pianopaul that’s it!! Also for the second vst I want to play with the same keys at the same time.
But … how the hell could ive known this?? How can I prevent this issue a next time?

This should be written in the OMNISPHERE manual.
In Omnisphere MultiMode you can define which part reacts on what channel

In Omnisphere SingleMode Omnisphere reacts on the Channel set in the MIDI Options.

Page 102 and 829 explain

By the way: It is allways a good idea to read the User Manual

This sounds similar to Kontakt. Half the time I add a new Kontakt instance I do not get a sound at first because I forget to set the Kontakt midi channel to same channel main controller is sending data on. LOL!

1 Like

I didn’t tell you that the MIDI monitor would fix the issue, the idea was only to confirm that your controller sends MIDI information on another channel than channel 1. Which is the case. So, you might have deduced that you need to correct this by having your controller transmit on channel 1, or by having GP force the conversion of this current channel to channel 1. The solution from Pianopaul works perfectly, you could also add a MIDI constrained converting from any channel to channel 1 at the output of your controller MIDI in block. As you can see there are a lot of different solution to fix this issue.

1 Like

I guess you’re right (ofcourse :blush:). But reading the manual of all vsts and GP takes a lot of time and … i never had this issue in Ableton. I never thought of this. But nevertheless I thank you!!

I do not know your system, but maybe the easiest fix is to make sure your controller is sending out data on channel 1? (And everything else is set up to handle channel 1, including Omnisphere and the Midi In Block).

No you didn’t. And now I know by using the MIDI Monitor I know to which channel my keyboard is sending and how to change this. Thank you also!!

1 Like

It’s my intention to build up the songs by using a standard rackspace over and over again. Ill make sure the controller will send out midi from channel 1 from within that rackspace. Good advice (again).

1 Like