Version 4.7 Auto-Sampler

Upgraded to 4.7 primarily to grab a couple of external Synth patches I’m missing in my VST rig (wishing to sample these from a Juno-G that I no longer want to drag around to gigs).

I’m following the connection guidance using a Focusrite Scarlett as for all interface I/Os:

  • Auto-Sampler Generator block is connected to a Midi OUT block
  • Midi out cable plugged into Juno Synth Midi IN
  • Juno audio out L+R connecting to Audio in 1+2 of interface
  • Audio In 1+2 connecting to Auto-Sampler Recorder
  • Auto-Sampler Recorder is then connected to interface Audio Out (although I’m not sure that is necessary tbh)

I can set the parameters best matched for the patch being sampled (velocity, release tail etc) and when I hit “start” it appears to be ripping out each note as expected (but I do not hear any audio when this is happening).

Once finished, there is no sign of the file, or file type, required to load into a sampler VST (I am using the Decent Sampler" as suggested in several tutorial vids on the new auto-sample function). No problem dropping in the decent sampler block into a new or existing gig. The issue is loading up the extracted sample file. What could I be doing so wrong?

So your issue is, that you cannot load the generated sample files into Decent Sampler?

Well, that lets you hear the sounds that are being recorded and if you’re not hearing anything, then your synth is not making any sounds or is incorrectly wired.

Make sure that just playing your synth works. Then make sure that it’s configured to respond on the correct MIDI channel (the auto sampler only uses channel 1)

I don’t believe it is that. I think it it is in the creation of required files by the auto-sampler feature. Do you know what I should be seeing in the file location once the sampling has been completed?

Can you post a screenshot of your Auto Sampler Generator?

Thanks for your help. I think I am going to need to eliminate all possible causes to know what is wrong. The external Synth is outputting sound if I play the patch prior to starting the “sampling process” (which I would expect given the L+R main outs are connected to the interface). I will check the midi channel settings on the synth though. And if I understand correctly, you are saying that the auto-sampler is effectively playing each note in the chosen range and broadcasting that out via mdi channel 1?

Should I be hearing that note data play the patch note-by-note as the sampling takes place? So far my attempts to sample this patch have not produced any sound out of the board.

Yes, by either connecting the Recorder to your audio output (as you seemed to be doing) or by connecting the external audio input that you’re sending to the recorder directly back to the audio output

Here you go :+1:

(note: I did change the range of notes to be sampled AND the note interval to 5. This was just to speed up each sample execution. If I can solve this I intend to sample every semi-tone with a note range of 1 for a 61 note range)

Here is my wiring view. If you can spot anything not looking right please do say :+1:

I think you first need to figure out if your Juno G is accepting incoming MIDI data, and produces a signal. Just plug in a headphone to your Juno G and listen while the Auto Sampler is active.

If OK you need to figure out if the audio signal reaches the inputs of the Auto Sampler Recorder. Just insert a Gain and Balance Plugin between the Audio Inputs and the ASR and watch the level meter


Thanks tripleB :+1: I think establishing that midi data is going into the board is solid advice. I will check the midi transmit settings on the Juno :pray:

a quick test that worked for me was to turn midi local off on the synth and try to loop the the midi through gig performer. If you can’t hear anything, your issue is with your synth itself receiving midi. I had the same issue with my prophet 12

The most likely possibility is the wrong MIDI channel

1 Like

Thanks - I do think it is an issue with midi instructions going into the Synth…but I’m not 100% sure I understand why doing this helps to confirm? Are you looping back the midi signal to GP to establish that the midi data is getting “in” in the first instance? And are you then looking for midi transmit indicators, or are you connecting up to a VST so you can hear some kind of audio?

Same reason medical doctors do differential diagnoses….to eliminate possible reasons, starting with the most likely.
If your synth is not responding to MIDI, then he process won’t work, so that needs to be established (or eliminated) as the cause.

My Apologies. I haven’t been clear. I understand the valuable & productive process of diagnosing, eliminating possible causes, narrowing in on the most likely causes. I also see that establishing if midi is reaching the synth to start with is important. What I can’t grasp is how you measure & monitor the midi coming back into GP after bypassing the synth (local off) and routing the midi back. Are you adding a new Midi IN block and looking for activity in that block?

I think the proposal was to create a dedciated rackspace which has only a wire between MIDI in an MIDI out. Your Juno is connected MIDI I/O both ways, Local off. Then you should hear your Juno generation sound when played on the local keyboard - cabling, connections are OK…
Independent from your AS trouble…

As advised I cycled through all possible Midi settings on the Juno G to try and see if anything was blocking the midi in data…(it’s been a while as I don’t use this board live at all now - hence why I’m sampling a few patches - luckily Roland make manual downloads easily available :+1:). Any way, it was down to having “Remote Keyboard Switch” set to OFF which obviously needs to be set ON if you want an external keyboard to communicate (which is effectively what the Auto-Sampler generator is doing. Once done I could start the sampling process and I could hear the audio being generated as it ran the process.
I may experiment a little with the velocity tolerances and also the qty of samples between those velocity values…but it is now doing what I was expecting it to do :+1: I appreciate your advice…Lee

1 Like