Using Jam Origin's Midi Guitar in a global rackspace

Does anyone in the community know the solution to my problem?

I use Midi Guitar in 80% of my rackspaces and I’m thinking of placing it in the global rackspace.
Currently, when the plugin is placed in a rackspace, I can switch from monophonic to polyphonic mode with a widget.

When I place the plugin in global rackspace, this doesn’t work (nor in midi learn).

Other parameters work perfectly, such as Bends, which has 6 selectable parameters in its selection window instead of just 2 in the polyphonic selection window.

This forces me to add an extra instance of Midi Guitar and switch from one to the other to change modes. This imposes therefore additional manipulation + one more dedicated footswitch…

Here’s what I’ve found:
I put Midi Guitar in the Global Rackspace, assign the Polyphony parameter to a widget, and give it a global assignment.
I put a widget in the local rackspace and assign it to that global parameter using the From Rackspace block
When I change the position of the widget in the local rackspace, the polyphony changes–however, the displayed parameter in the GUI of Midi Guitar doesn’t change.

Does the actual polyphony of the instrument not change for you?

3 Likes

It works: I hadn’t tried it with the headphones on, only by sight.
This will teach me to rely only on my eyes. :grimacing:
Thank you very much for the express delivery reply :+1:

1 Like

Another question about opposite problem: a widget correctly changes the display of the bends in Midi Guitar but bends don’t work.
It works for Midi Guitar + an instrument both in the global rackspace but not for an instrument in a rackspace…

Can you send a small gigfile so I can try to reproduce?

mg-test.gig (33.1 KB)

The scriptlet that you are using in the Global Rackspace is only looking for, and transmitting, note data. If you want pitch bend information injected that way you’ll have to have to include On PitchBendEvent callbacks also.

Try this:
mg_pitchbend.gig (35.2 KB)

2 Likes

Thanks again, I’m terrible at scripting and it puts me off, no wonder I couldn’t figure out how to solve this problem, I use scriplets like a parrot talks.

1 Like