Unable to activate demo


#1

Hi,

When I started GP 2.6 demo it scanned the plugins and then opened the GUI with the “Gig Performer Activation” window on top of it. Only the activation window is completely blank! I’ve disabled Windows Defender Firewall and Virus scan, but to no effect. Tried disconnecting the audio interface and all other USB devices, no change.

(I’ve tried on my stationary PC as well, and there it works, except it crashes when I try to switch from Windows Audio to my UR22 mkII)

I really want GP to be my successor to Brainspawn Forte, but when I can’t even run the demo on neither computer I obviously become rather sceptical…

Any thoughts?

Laptop: i7, W10 Home, M-Audio C400, all up to date.
Tower: i7 W10 Home, Steinberg UR22 mkII, all up to date.


#2

That is quite unusual…

Do you have any other third-party security applications?
Is your clock/time-zone set correctly?

The issue where the activation window is blank is typically there if your clock settings are wrong.

The issue where GP crashed when you switched your audio interface is typically related to some plugin you may have loaded. Try loading GP while holding the shift key down so it starts blank, then switch the interface.

Let us know how it goes.


#3

This isn’t related to your immediate problem, but GP is proving to be a capable replacement for Forte for my purposes. I used Forte for ~12 years and the transition has not been without difficulty, but GP appears to be more stable and the scripting capability gives an unprecedented level of flexibility for live host software from what I have seen.


#4

No third-party apps and clock/time is correct. Could it be some administrative rights (although I’ve already tried to runt the demo as admin)?


#5

Sounds promising, can’t wait to actually try it…!:pleading_face:


#6

Have you tried the other suggestion (to start with the SHIFT key down) on the computer where you had an issue with switching the audio interface settings? Is that still not working?


#7

Yes. Same thing: I go to Audio setup, try to switch to ASIO = hang for a few seconds, then crash.


#8

I can switch to DirectSound without crash, so it’s something with ASIO obviously.


#9

Can you try to download and install ASIO4ALL from here http://www.asio4all.org
See if that helps.


#10

It does! After installing ASIO4ALL I’m able to choose the Steinberg ASIO.
I’ve read about using ASIO4ALL with GP, but assumed that I would also have to use it instead of the Steinberg driver.
OK, so one down, one to go!
Really appreciate your help! Cheers!


#11

Could you be a bit more specific please?


#12

I meant the issue with the ASIO crash on my tower PC is solved, but I still can’t activate the demo on my laptop. If I could get that working I’d likely buy it but right now this is a deal breaker.


#13

Check your private messages


#14

Update: the activation window looks blank but the buttons are actually there and you can click them (even if you don’t know what you’re clicking…). I tried the 2.4 demo and it’s the same thing there.


#15

Yeah, I don’t know why they’re invisible. I’ve reached out to the company whose library we are using.


#16

Update: Solved (still weird though), thanks to dhj!
Uninstalling Duet Display made the trick, and now the activation window shows as expected.
Unfortunately the countdown worked in the background, so now I have Zero days left of free trial… :grinning:
Doesn’t matter much though. I was actually starting to look for some other host to replace Forte, but now I’m back on track with GP, especially with v3 around the corner(?). Looking forward to trying it out!
Thanks to David for excellent customer care, with e-mails and phone calls! Wasn’t expecting that level of support.

Cheers!


#17

Thanks so much for taking the time to confirm this – very bizarre – issue and that the fix works.