Trouble toggling widgets

macbook pro M2 / ventura / softstep

problem: trying to set up MSuperLooper in global rackspace and can’t get record button to toggle on/off because widget button reacts only to held foot controller button

as desired, my softstep seems to be toggling alternatingly 0 and 127. sent into GP, my widget button only knows 100 when i touch the button with my foot, and 0 when i take it off. that’s also what showing in the value sub window.

since i’m having trouble understanding what exactly is going on, i tried a lot of softstep setup variations variations and even hosted mode, where i was able to see that indeed i am sending midi values either 0 or 127. i was hoping that this would be the type of message a toggle widget needs?!

maybe a problem setting up soft step advanced editor in standalone mode? in any case, none of this seems to have any effect. what am i doing wrong or what’s the trick to get my toggles to be alternatingly be on or off?

thanks everyone!

Turn on Momentary To Latching in the MIDI section of the widget inspector options.

This is documented

1 Like

thanks for your help! (i read the whole thing, but in the spectrum between arts and tech, my brain works very one-sidedly, so i did not remember and double thank you for your time to point me towards the obvious!!)

1 Like