Tough weekend - looking for insight and ideas

I am performing with multiple bands with an M1 Macbook pro running Big Sur 11.6. Just came off of a rough weekend with the system - but it has been running quite well until last weekend. So I am hoping that you all can provide some insight to my issues…here goes…


My files are about 170 Mb with 50-60 rackspaces. I use Bandhelper on an Ipad to change rackspaces (midi PC to my mac) so I do no touch the Mac during the show…until this weekend.

I use Arturia, Cherry Audio, Native Inst., Valhalla (verbs) and Spectrasonics and Swam for plug ins. I have been working months to migrate to this system and test incessantly. It has been working 98%-100% to this point.

I am using an Arturia controller and Nord Stage 2EX as a controller (plus a digital Hammond but its not connected)

Here’s what happened;
boot up fine - loaded fine. About 4 songs in, some sounds literally failed to show up on the keyboard. Midi was getting to GP just fine, but no sounds. Rebooted, fixed it for a while. Then it happened several times, once NO sounds showed up. Really miserable night with this instability. Totally random in how it showed itself…

So I did some digging - Issue 1 - I believe my USB-C cable is partially culpable. It is replaced. I was running a 10ft cable - the spec is 6ft max (Thunderbolt) so that is fixed and running a much higher grade of cable that is certified and 40Gps.

The rest I am perplexed. In my studio it runs 100% perfect (of course!).

Secondly - with Native plugins - brass to be specific - The first notes hit the attack of the note is broken up - like the buffer for the sound is not allocated properly. Has anyone seen this? Not sure if it is user error or something else, but it is really pronounced in Native’s plugins, does not exist in Spectrasonics or Swam, sometimes shows up in Arturia.

I tried predictive loading but that does not seem to fix the issue.

Thanks guys!

1 Like

Did you try running the non-Universal Binary of Gig Performer. I had similar issues with no sound coming out of Kontakt when I ran the Universal one but when I run the other version everything seemed to work fine.

May not be your issue but I would hold off on Universal especially with any plugins until they are fully supporting Apple Silicon.



Are you running on the Apple silicon and Big Sur?

I thought universal was developed for that setup.

Then there’s clearly something different when you move — are you using a different computer than when you’re in your studio? Or a different interface?

For me, although I might design my sounds on a studio machine, I always rehearse with the actual gear that I will use on stage.

The only thing that is different is the cabling.

Same computer
Same keyboards
Same interface
Same usb hub

I did it this way so I can test the live setup multiple times prior to leaving the studio.

The transient issue though exists regardless of live or studio. I am curious if this is a sample startup issue, buffer with Rosetta or something else.

I am not hearing that issue using the Mac Mini running Catalina 10.15 and a universal audio Apollo interface….which has a huge amount of internal horsepower compared to the focusrite Scarlett 2i2 I use for my live rig.

Yes. I just figured that even though Gig Performer is Universal, the plug-ins are sometimes not and that could cause the issue.

As an example, if you have Soundtoys and you load Logic Universal, they will all fail the plug-in validation. Yet if you run Logic under Rosetta, they will pass.


Yeah, Apple did a scummy thing here — they will automatically let Intel AUs run under Rosetta but they don’t do that for VSTs. So if you run any native host (Logic or GP, etc), your Intel AUs will be found but not your Intel VSTs

I would try to use the same cabling. Also — if you don’t have a cord tester, – I would get one. I have a 5 year old midi snake. Worked fine at home – got to a gig and 2 cords did not work. Ran them through my cord tester – and voila – saw that they were not carrying current through all pins. Yet… worked fine a few hours at home earlier.


Yeah so I am replacing the USB C cables with 40Gps cables to begin - quite expensive - I don’t have a USB C cable tester - they don’t do thunderbolt or lightning.

That’s step one. I am also looking at a higher end interface with lower latency to test the transient issue.

Hi Joel,

interestingly, I have some issues with the very first sound out of NI Kontakt, too.
My rig has 60 songs = rackspaces, and loads 24 GB into RAM. Predictive loading off.
Certain sample sounds in NIK always will have a first click or hick-up, but only the very first time I play them after loading. Got used to play them during sound check as a workaround, no further research on this so far.

Even more interestingly, this is on Win10 using an acclaimed RME Babyface Pro.

There’s a known issue that NI has acknowledged but never fixed where sounds that use convolution don’t work for the very first note and then they’re fine. This has been reported numerous times in the past by many.


I’ve got a 14-inch MacBook M1 Pro with Monterrey 12.0.1. It seems to be fine for normal computing, but not ready for live use. I’ve had a few instances where all sound is lost and I have to restart Gig Performer. II’m 99.9% sure that it’s not a GP issue. In addition, I had some odd behavior with my Scarlet 2.4 when GP and Logic were not running. I’d get some random clicks with the computer just idling. My inputs (guitar & mic) would sometimes route directly to the output and sometimes not.

With Apple focusing on video and audio production on the Pro/Max laptops, I expect that these driver issues will be a high priority for them. Looking forward to 12.0.2…

I’ll note that I’m running the audio interface on a USB-C hub (same as before), and I’ve lowered the latency to ridiculously low setting (not the same as before), so that could have something to do with it. I’m in a development and practice phase, rather than live performance, so I can tolerate issues now. I would avoid it on stage - or run a single, high-quality cable, set a higher latency, disable all possible interruptions, and rehearse with it a lot before taking it live.

That’s the first thing I would look at…cables.

I’ll lower latency first. I never had a problem with my Intel-based Mac using the same exact wiring. Even the velcro holding the wires to my desk is the same. :slight_smile:

1 Like

Interesting…I also get the random clicks when GP is not running. same interface - as a matter of fact that is one of the things I am changing is the interface - going down the chain of variables.

I have changed the cable to meet the thunderbolt 6’ spec @ 40gps and it is running better (Still get the clicks from the interface at idle - GP not running) - amazing this would be the third time in my life I’ve learned the cabling lesson - first with analog audio as a teenager, then HDMI, now USB C/thunderbolt. You would think I would have figured that out by now!

Since I am live (3 shows this wknd) latency will remain @256. I won’t go to 128 until I test it more, the same with sample rate, I am running 48K. 44K is an option with testing. I typically run 20-30% CPU usage on GP when I am playing.

I am not going to Monterey either - sticking with 11.6 until I hear from more folks on the issues Apple is introducing with their latest upgrade…

I just bumped mine up to 256 samples. I’m on a new, 14-inch MBP, and it shipped with Monterey, so here I am.

There’s a situation where I can create issues: when running Logic as the sequencer into GP as the host. When I choose a track in Logic (and [R] is enabled), my keyboard plays through Logic into GP and into a plugin. But during development, I might also have the keyboard hard wired into that plugin. It’s not a feedback loop, but it’s a fast echo - like MIDI slapback. So I could get two Note On messages, etc. I don’t do this on purpose. It might just happen when selecting the MIDI track for a quick edit of a CC value. I don’t play the keys in this situation, but a knob might be at a threshold and a little noise could cause a CC message to trigger, followed by the MIDI echo from Logic.

Anyway, this definitely causes issues. If anything in your setup could cause a MIDI slapback echo, you might look at that.

It’s possible that I had such a fault, shut down GP, and had a lingering problem in the Scarlet (2x4) driver that showed up later. I should probably do a full reboot whenever I cause a MIDI echo, just to eliminate residuals from that.

I’m not sure why echoes would cause issues. Same, back to back messages cause no logical issue, but might mess up buffering. And I’m not sure if the fault would be in GP, certain plugins, the OS, or the driver.

I don’t recall this causing issues on my older setup.

Hey John,

The slap back issue you talk of is not an issue. My system does not have a DAW in it and I have only one path to GP.

I run 256 as my buffer as well.

The focusrite issue I am thinking it’s a driver….and the tick might be a ‘keep alive’ routine….shuts the bus down on the interface then wakes it up again. Seems to be about every 30 mins or so when the computer is idling.

Once I have the RME interface up and running next week I will compare. I do know that RME’s drivers are super tight and they do their own fpga programming custom for low latency.

More to come of course!

Yeah, I figured that echo would be unlikely for most. It makes me wonder, however, if there could be a situation where a MIDI controller sends two messages back to back that could glitch something.

Which plugins are you using? I’ve got Kontakt, EZdrummer, S-Gear, various Arturia instruments, various Waves v13 plug ins, and a Kuassa wah.

There might be two separate issues: something that kills GP’s sounds, and the keep-alive thing in the Focusrite.

Have you read my blog article on using GP with a DAW such as logic?

I’m using the same plugins plus cherry audio and Native. I don’t so much waves or have S-gear….the Kuassa Wah is amazing. I use it for heartbreaker by the stones with the native pianet.

1 Like