TC electronic TC2290 on MacBookAir M1

Hello all,

this is my very first post here and I am also a very fresh user of GP. I will use it as a guitarist and for vocals since I made the personal digital transformation I was looking for exactly this software - great that GP exists!

Unfortunately, I recently started having problems in combination with the t.c. elecreonic TC2290 dt plugin - there is simply no signal coming into the delay.

I recently updated to macOS Ventura 13.2.1, it might be related to that, it would match in time.

A short test showed that it still works in Mainstage cough. Unfortunately, I can only use the AU version on my MacBookAir M1, the VST and VST3 version shows in the Plugin Manager that it has been deactivated because it could not be initiated correctly.

Has anyone else here possibly noticed a similar problem? All my other plugins (Guitar Rig, Amplitube, …) work perfectly.

Otherwise, I will have no choice but to install my backup system (on a Lenovo notebook) earlier than planned and try out whether it might work with GP under Win10 with VST(3).

How looks your routing in the rackspace?

I just downloaded the demo and the AU version is working, cannot detect any issue.
I am on Mac

Did you start Gig Performer using Rosetta?

Apple did something rather sneaky to allow Intel AUs to run on an M1 but they didn’t do it for VSTs. They automatically run the plugin in Rosetta. Since they don’t do it for Intel VSTs, that’s why GP can’t validate them. They presumably did this so that their products would continue to work on Apple Silicon even if the plugins hadn’t yet been converted.

You either need to run GP itself under Rosetta or you need to get an Apple Silicon version of the plugin.

Thank you so much! It’s incredible, you are the best! I’ve just been shopping, come back and here’s the solution!

This is very interesting information from dhj and in my eyes this is a sad approach from Apple. Behringer could also release a native AU for my beloved 2290.
However, I understand that there is some programming involved. But you guys at GP have gone down this difficult road though, haven’t you?

The solution for me: I’m now running GP on the M1 Mac under Rosetta and hold on: everything works (again)!
And if I had done a little more research, I could have figured it out myself. Unfortunately, I didn’t have the Intel/Arm architecture thing on my mind and thought that far ahead.

But it’s also very interesting that it had already worked - apparently until the update to macOS 13.2.1.

I assume you are using an Intel Mac. Or a Silicon with MacOS <= 13.2.1, because that’s how it worked for me. In the meantime I start GP using Rosetta, thank you very much, that was the solution.