Struggling to Fix Bizarre Enso Looper Behavior in GP

Hello GP community! I am having a strange issue with with the Audio Damage Enso looper plugin, and could really use some support. I’m bringing this here because a) Audio Damage has not responded to any of my support requests in the past, b) I believe I can fix the bug using GP scripting, and c) because I know several other GP users also use Enso, and might have similar problems.

The problem I’m having is I’m getting a loud feedback noise under a certain set of circumstances. It happens after I have changed the playback rate, cleared the previous loop, and record another loop. The noise happens as soon as I trigger the end of the new recording, and go into overdub mode. It happens even if I have manually reset all the plugin parameters back to normal, and the playback/recording rates to 1x. I am using my MIDI keyboard and footswitches to manipulate loops (changing playback speed, start time, length), so it’s crucial that I’m able to change the playback speed, clear the buffer and create new loops.

Upon further experimentation, I did seem to find a plugin parameter that fixes the problem (for some unknown reason), the button that says “1:1,” that seems to just reset the recording and playback speeds to 1x. This seems to suggest that the plugin bugs out when recording a new loop with a playback/recording speed that is not 1x. So in order to fix the bug, I need to make sure that anytime I clear the loop, it also resets those speeds back to 1x. However, I have been unable to do this successfully using GP widgets. There is no way to configure a widget to press the “1x1” button, either using Enso’s built-in MIDI CC commands, or the parameters that are accessible through GP. I am able to configure widgets to trigger specific playback/recording speeds, by setting momentary switches to trigger a specific CC value only in the playback speed parameter. However, when I use this method to configure my “clear loop” button to also reset the playback/recording speeds to 1x, I still get the massive feedback noise. Only the “1:1” button seems to do the trick.

So that brings me to the possible GP script solution, that I am feeling daunted about trying on my own. I believe that I should be able to save a GP plugin preset of the empty Enso loop after pressing the “1:1” button, configure my footswitch to load that preset (using a GP script), and it should fix my problem.

If anyone can offer any guidance on how to create such a script (triggered by a CC message or a widget to load a specific plugin preset), it would be much appreciated! Or if you know any other way that I could set my midi controller to press this “1:1” button in Enso, that would also be very helpful. Many thanks in advance for any support folks can offer.

My experience also.

Are you Mac or Windows? What Enso version? What plugin type (VST, VST3)? Have you tried swapping the plugin type to a different one - there can sometimes be different behaviours between them, particularly when it comes to bugs.

Thanks for your prompt reply, rank13!

I am not surprised…

Windows, and I am not sure the version number. I picked it up in March of this year. The plugin file was last modified 11/2020.

VST3. Thanks for the suggestion on swapping them. Just tried it, and am getting the same behavior.

So I believe I found a workaround! Since it is clear that Enso does not respond well to using a continuous control value to reset the playback/recording speeds (as described above), I realized that another way I could reset the playback speeds using buttons I can access in Enso is the + or - playback/recording speed buttons. So I set the footswitch I use to clear the loop to also access those buttons. After configuring that to get me back to 1x playback/recording, the feedback seems to be gone. For some reason I need to set the speed to 2x then clear the loop, and it goes back to normal. So I am all set for now. Thanks!