Strange - Poly Aftertouch not working on Arturia CS-80 v4

I have an Xkey 37 that generates Poly AfterTouch. When I play the Arturia stand-alone CS80 v4 app Poly AfterTouch works fine.
When I try playing the CS80 v4 through Gig performer PolyAT does not work - I have Midi In (OMNI) hooked up, and I hooked up the midi monitor in the same output. The Midi monitor shows the Poly AfterTouch data coming in but the CS80 v4 does not respond.
Channel pressure works in both cases.

Hi @receng and welcome to the GP community. :wink:

Did you use a Global Midi monitor or a GP plugin MIDI Monitor inserted in the wiring view just before your plugin ? If you only used the Global MIDI monitor, it could be interesting to do both and tell us the result.

If I remember well our community member @keyman owns an XKey 37, perhaps he has an idea?..

1 Like

Thanks for responding!
I used a GP Plugin inserted “on the side” after the midi in.
I checked both the Global MIDI monitor and the GP Mini Monitor Plugin and the Xkey 37 Poly AfterTouch shows up on both.
But there is a glitch/bug with GP Midi IN Plugin and the Xkey 37 - I turned the check box for “Event Blocking: PolyTouch” ON and OFF and it DOES NOT block the Poly AfterTouch from the XKey37.

I even tried the Midi Filter in between, before the Midi monitor, after Midi IN and turned the Filter for both Poly and Channel AfterTouch on and off and it - tried all combinations - The filter works and blocks Poly AfterTouch from the Xkey 37.

The Arturia CS-80v4 continues to respond only to Channel AfterTouch in all tests.
I used the filter to remap the Poly AfterTouch from the Xkey 37 to Channel AfterTouch and the Arturia CS80v4 does work with that - But no Poly AfterTouch. I tried both VST3 and AU versions.

The last test was loading the CS-80v4 on Studio One and it is broken there also - so I opened a ticket with Arturia.
Please check the Poly AT filter check box on the MIDI IN.

The poly after touch block problem is already fixed for the next release


I got a reply from Arturia and they had me reset the preferences - it seems to be a GIG Performer issue:

  1. Resetting the CS-80v4 preferences made the AU plug-in POLY Aftertouch work in Logic
  2. Quit Logic, placed the same plugin on GP - the POLY Aftertouch DOES NOT work.
  3. Quit GP, Open Logic - POLY Aftertouch DOES NOT work.
  4. Quit all, reset preferences again, open Logic - POLY Aftertouch WORKS.
  5. Quit Logic, opened GP, removed loaded plugin, instantiated CS80v4 AU again - the POLY Aftertouch DOES NOT work.

The issue remains on GP.

This specific issue is indeed fixed for the next release. But if you have confirmed that polytouch messages are being displayed in a local midi monitor connected to a MidiIn block then the Cs80 should receive the messages and respond to them

Have you tried with a VST version?

OK I don’t have the CS 80 V4 but I have the CS 80 V3 and I just tested it and poly aftertouch works just fine out of the box. I tried both the AU and the VST versions.

I loaded a String patch and then used a tool that first sends two note On messages (C3 and G3) and then individually sends Poly touch messages separately on C3 and G3 and I could hear the CS80 respond perfectly fine. The messages are displayed in the local MIDI monitor. See attached image. I did this using GP 4.1, not even the latest version

So again, please insert a Midi Monitor right after your Midi In block (per image below) and screenshot the results.

No, sorry, it is not a Gig Performer issue. Sending Poly Touch messages to my CS80 works just fine.

Thanks for the tips - I had the exact same set up as the screenshot - the AT data comes in but the CS-80 not responding.
I FOUND THE ISSUE - I started from scratch with an empty GIG File and everything worked.
I think it is one of GP Templates:

  1. Start from empty GIG File - POLY AT works
  2. If I start from “New Gig from Template > Stage and Wurli”, substitute one of the plug-ins for CS-80v4 - no Poly Aftertouch no matter what I do. I even tried deleting everything on the wiring.
    Please let me know if you can reproduce this.
    Thanks again!

This has to be an Arturia issue and the template replace is just a coincidence

I just tested Gig Performer with three other plugins that support Polyphonic Aftertouch

  1. U-He Diva
  2. U-He Zebra
  3. Cherry Audio Dreamsynth

All of them respond perfectly fine to Polyphonic aftertouch (for Dreamsynth you have to select Poly Aftertouch as the modulation source for a particular parameter)

But did you try to replace one existing plugin by the Arturia CS-80 or any of the other plugin you tested? I cannot test myself as I don’t own any polyphonic aftertouch capable controller…

I did a test, and after replacing by CS-80 V4 Poly Aftertouch is working as it should.

1 Like

Yes - I replaced with the Diva from u-he and polyphonic aftertouch works fine.

1 Like

My problem is starting from the built-in template "Stage and Wurli” , substituting one of the plug-ins for the CS80 v4 - Poly AfterTouch is not working.

I understand - but I think that’s a red herring – I’ve discovered various cases where the CS 80 is not responding to poly touch — but my other plugins that support poly aftertouch all work fine, regardless of whether you insert them manually or you start with that template and replace the plugin.

I think there’s a problem with the CS 80

1 Like